aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp13
-rw-r--r--x11/kdebase4-workspace/Makefile2
-rw-r--r--x11/kdebase4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp13
4 files changed, 28 insertions, 2 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 3218cd5fcba2..85cb15d63e7a 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase-workspace
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp b/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
new file mode 100644
index 000000000000..a4685dcdfb1b
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
@@ -0,0 +1,13 @@
+--- plasma/applets/system-monitor/hdd.cpp.orig 2009-07-21 17:19:25.000000000 +0200
++++ plasma/applets/system-monitor/hdd.cpp 2009-08-23 16:07:02.000000000 +0200
+@@ -265,8 +265,8 @@
+ data->value("File System Type").toString() <<
+ data->value("Size").toString();
+ */
+- if ((data->value("Usage").toString() != "File System" &&
+- data->value("Usage").toString() != "Raid") ||
++ if ((data->value("Usage").toString() != i18n("File System") &&
++ data->value("Usage").toString() != i18n("Raid")) ||
+ data->value("File System Type").toString() == "swap") {
+ QStringList list = items();
+ list.removeAll(uuid);
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 3218cd5fcba2..85cb15d63e7a 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase-workspace
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdebase4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp b/x11/kdebase4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
new file mode 100644
index 000000000000..a4685dcdfb1b
--- /dev/null
+++ b/x11/kdebase4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
@@ -0,0 +1,13 @@
+--- plasma/applets/system-monitor/hdd.cpp.orig 2009-07-21 17:19:25.000000000 +0200
++++ plasma/applets/system-monitor/hdd.cpp 2009-08-23 16:07:02.000000000 +0200
+@@ -265,8 +265,8 @@
+ data->value("File System Type").toString() <<
+ data->value("Size").toString();
+ */
+- if ((data->value("Usage").toString() != "File System" &&
+- data->value("Usage").toString() != "Raid") ||
++ if ((data->value("Usage").toString() != i18n("File System") &&
++ data->value("Usage").toString() != i18n("Raid")) ||
+ data->value("File System Type").toString() == "swap") {
+ QStringList list = items();
+ list.removeAll(uuid);