aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/resourceext/Makefile24
-rw-r--r--x11/resourceext/distinfo1
-rw-r--r--x11/resourceext/files/patch-Makefile.in11
-rw-r--r--x11/resourceext/pkg-descr6
-rw-r--r--x11/resourceext/pkg-plist2
6 files changed, 45 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 30cf07e81796..d919ba58655b 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -108,6 +108,7 @@
SUBDIR += props
SUBDIR += qrash
SUBDIR += randrext
+ SUBDIR += resourceext
SUBDIR += rox-wallpaper
SUBDIR += ruby-X11
SUBDIR += ruby-gnome
diff --git a/x11/resourceext/Makefile b/x11/resourceext/Makefile
new file mode 100644
index 000000000000..64bf928734da
--- /dev/null
+++ b/x11/resourceext/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: resourceext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= resourceext
+PORTVERSION= 1.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Resource usage extension headers
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0
+
+.include <bsd.port.mk>
diff --git a/x11/resourceext/distinfo b/x11/resourceext/distinfo
new file mode 100644
index 000000000000..b64c542d5c9a
--- /dev/null
+++ b/x11/resourceext/distinfo
@@ -0,0 +1 @@
+MD5 (resourceext-1.0.p1.tar.bz2) = 2a5763c2d7ebbd6cfe8382387c6235a7
diff --git a/x11/resourceext/files/patch-Makefile.in b/x11/resourceext/files/patch-Makefile.in
new file mode 100644
index 000000000000..bf6424bbcb20
--- /dev/null
+++ b/x11/resourceext/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 22:34:12 2003
++++ Makefile.in Sun Nov 9 22:34:22 2003
+@@ -119,7 +119,7 @@
+ resourceextdocdir = $(datadir)/doc/XResource
+ resourceextdoc_DATA =
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = resourceext.pc
+
+ EXTRA_DIST = autogen.sh resourceext.pc.in $(resourceextdoc_DATA)
diff --git a/x11/resourceext/pkg-descr b/x11/resourceext/pkg-descr
new file mode 100644
index 000000000000..e3b74d0b4444
--- /dev/null
+++ b/x11/resourceext/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Resource extension headers
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/resourceext/pkg-plist b/x11/resourceext/pkg-plist
new file mode 100644
index 000000000000..17abb504967a
--- /dev/null
+++ b/x11/resourceext/pkg-plist
@@ -0,0 +1,2 @@
+include/X11/extensions/XResproto.h
+libdata/pkgconfig/resourceext.pc