aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/bricons/Makefile32
-rw-r--r--x11/bricons/distinfo1
-rw-r--r--x11/bricons/files/DOTbriconsrc27
-rw-r--r--x11/bricons/files/patch-aa49
-rw-r--r--x11/bricons/files/patch-ab38
-rw-r--r--x11/bricons/files/patch-ac22
-rw-r--r--x11/bricons/pkg-comment1
-rw-r--r--x11/bricons/pkg-descr8
-rw-r--r--x11/bricons/pkg-plist11
9 files changed, 189 insertions, 0 deletions
diff --git a/x11/bricons/Makefile b/x11/bricons/Makefile
new file mode 100644
index 000000000000..9ce5c33da652
--- /dev/null
+++ b/x11/bricons/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bricons
+# Version required: 3.0 with colour icons
+# Date created: 31 Jul 1996
+# Whom: shanee@rabbit.augusta.de
+#
+# $Id$
+#
+
+DISTNAME= bricons
+PKGNAME= bricons-3.0
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.uni-paderborn.de/unix/X11/ftp.x.org/R5contrib/ \
+ ftp://ftp.pasteur.fr/pub/computing/unix/X11/R5contrib/
+EXTRACT_SUFX= -athena-3.0.tar.gz
+
+MAINTAINER= shanee@rabbit.augusta.de
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+
+post-install:
+ ${INSTALL_DATA} $(WRKDIR)/bricons/Xbricons $(PREFIX)/lib/X11/app-defaults/
+ ${INSTALL_DATA} $(WRKDIR)/bricons/bitmaps/* $(PREFIX)/include/X11/bitmaps/
+ ${INSTALL_DATA} $(WRKDIR)/bricons/*.xpm $(PREFIX)/include/X11/pixmaps/
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Use ./files/DOTbriconsrc as an example. This file"
+ @${ECHO_MSG} " should be stored in the same directory as the"
+ @${ECHO_MSG} " program is executed from."
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/x11/bricons/distinfo b/x11/bricons/distinfo
new file mode 100644
index 000000000000..cd8639f643ee
--- /dev/null
+++ b/x11/bricons/distinfo
@@ -0,0 +1 @@
+MD5 (bricons-athena-3.0.tar.gz) = bae89aa6efa06b177058c2db83b0ba99
diff --git a/x11/bricons/files/DOTbriconsrc b/x11/bricons/files/DOTbriconsrc
new file mode 100644
index 000000000000..3813d86f9104
--- /dev/null
+++ b/x11/bricons/files/DOTbriconsrc
@@ -0,0 +1,27 @@
+# <-- a line starting with a '#' is a comment line
+#
+
+# first line must have keyword %icon or %text
+# to indicate if button is an icon
+%icon help.xbm
+xman
+%icon letters.xbm
+knews
+%pixmap /usr/X11R6/include/X11/pixmaps/mail.xpm
+exmh
+%icon calander.xbm
+xcalendar
+%text Sub-\nmenu
+%sub_menu
+ %text \n bitmap\n editor\n
+ %pixmap /usr/X11R6/include/X11/pixmaps/clock.xpm
+ xclock
+ %icon load.xbm
+ xload
+ %text+ \n Shell\n
+ xterm -n Shell &
+%end_sub_menu
+%pixmap+ /usr/X11R6/include/X11/pixmaps/xterm.xpm
+xterm &
+%pixmap+ /usr/X11R6/include/X11/pixmaps/editor.xpm
+xedit &
diff --git a/x11/bricons/files/patch-aa b/x11/bricons/files/patch-aa
new file mode 100644
index 000000000000..fe3ca6990f81
--- /dev/null
+++ b/x11/bricons/files/patch-aa
@@ -0,0 +1,49 @@
+*** Imakefile.orig Thu Jan 21 21:27:31 1993
+--- Imakefile Sat Aug 3 14:30:53 1996
+***************
+*** 7,28 ****
+ /**/# Here's what to change to customize the installation...
+ /**/# Where do you want this stuff (if the defaults aren't okay)?
+
+! BINDIR = /home/cur/bri/bin/mbins/${M}bin
+! LIBDIR = /home/cur/bri/lib
+! MANDIR = /home/cur/bri/Man
+
+ /**/# Where is the Xpm header and library files
+ /**/# This program needs the Xpm libraries written by Arnaud Le Hors.
+ /**/# it can be obtained by anonymous ftp to: export.lcs.mit.edu
+ /**/# and from many other sites.
+
+! XPM_DIR = /home/cur/bri/Xstuff/Progs/bricons/xpm
+ XPM_INCLUDE_DIR = $(XPM_DIR)
+! XPM_LIB_DIR = $(LIBDIR)
+
+ /**/# This is -g for debugging or -O for optimization (or nothing).
+
+! CDEBUGFLAGS = -g
+
+ /**/# Nothing to change below here
+
+--- 7,28 ----
+ /**/# Here's what to change to customize the installation...
+ /**/# Where do you want this stuff (if the defaults aren't okay)?
+
+! BINDIR = /usr/X11R6/bin
+! LIBDIR = /usr/X11R6/lib
+! MANDIR = /usr/X11R6/man/man1
+
+ /**/# Where is the Xpm header and library files
+ /**/# This program needs the Xpm libraries written by Arnaud Le Hors.
+ /**/# it can be obtained by anonymous ftp to: export.lcs.mit.edu
+ /**/# and from many other sites.
+
+! XPM_DIR = /usr/X11R6/include/X11
+ XPM_INCLUDE_DIR = $(XPM_DIR)
+! XPM_LIB_DIR = /usr/X11R6/lib
+
+ /**/# This is -g for debugging or -O for optimization (or nothing).
+
+! CDEBUGFLAGS = -O2
+
+ /**/# Nothing to change below here
+
diff --git a/x11/bricons/files/patch-ab b/x11/bricons/files/patch-ab
new file mode 100644
index 000000000000..3da195468e1f
--- /dev/null
+++ b/x11/bricons/files/patch-ab
@@ -0,0 +1,38 @@
+*** gen.h.orig Thu Jan 21 21:27:33 1993
+--- gen.h Sat Aug 3 15:14:37 1996
+***************
+*** 11,18 ****
+ #include <X11/Xaw/MenuButton.h>
+ #include <X11/Shell.h>
+ #include <X11/Xaw/Cardinals.h>
+! /* #include <stdlib.h> */
+! #include <malloc.h>
+ #include <ctype.h>
+ #include <unistd.h>
+ #include "xpm.h"
+--- 11,18 ----
+ #include <X11/Xaw/MenuButton.h>
+ #include <X11/Shell.h>
+ #include <X11/Xaw/Cardinals.h>
+! #include <stdlib.h>
+! /* #include <malloc.h> */
+ #include <ctype.h>
+ #include <unistd.h>
+ #include "xpm.h"
+***************
+*** 32,38 ****
+ #define NO_OF_COLS 18 /* default number of columns */
+
+ #define EDITOR "xterm -e " /* editor used to edit icon file. */
+! #define FORMATTER "xterm -e vi " /* text formatter for help file */
+ #define HELP_VIEWER " " /* viewer for help file */
+
+ #define MAXPROCS 20
+--- 32,38 ----
+ #define NO_OF_COLS 18 /* default number of columns */
+
+ #define EDITOR "xterm -e " /* editor used to edit icon file. */
+! #define FORMATTER "xterm -e man " /* text formatter for help file */
+ #define HELP_VIEWER " " /* viewer for help file */
+
+ #define MAXPROCS 20
diff --git a/x11/bricons/files/patch-ac b/x11/bricons/files/patch-ac
new file mode 100644
index 000000000000..2d7fa06f2e98
--- /dev/null
+++ b/x11/bricons/files/patch-ac
@@ -0,0 +1,22 @@
+*** Xbricons.orig Thu Jan 21 21:27:32 1993
+--- Xbricons Sat Aug 3 15:14:56 1996
+***************
+*** 1,9 ****
+ ! Application resources file for bricons program
+ ! B.R. Ingram 9th Sept 1991
+ *no_of_cols: 16
+! *icon_file: /home/cur/bri/.briconsrc
+! *help_file: /home/cur/bri/Man/bricons.man
+! .bitmapFilePath: /usr/local/include/X11/bitmaps:/s/bri/Pics
+ *borderColor: yellow
+ *popup_layout*.borderColor: black
+ *background: #ffd28e
+--- 1,8 ----
+ ! Application resources file for bricons program
+ ! B.R. Ingram 9th Sept 1991
+ *no_of_cols: 16
+! *help_file: bricons
+! *.bitmapFilePath: /usr/X11R6/include/X11/bitmaps
+ *borderColor: yellow
+ *popup_layout*.borderColor: black
+ *background: #ffd28e
diff --git a/x11/bricons/pkg-comment b/x11/bricons/pkg-comment
new file mode 100644
index 000000000000..82f82b75fc5e
--- /dev/null
+++ b/x11/bricons/pkg-comment
@@ -0,0 +1 @@
+Quick start up utility for applications on an X display.
diff --git a/x11/bricons/pkg-descr b/x11/bricons/pkg-descr
new file mode 100644
index 000000000000..3f14b199e3b6
--- /dev/null
+++ b/x11/bricons/pkg-descr
@@ -0,0 +1,8 @@
+ Bricons program allows the user to quickly start up appli-
+ cations by selecting the appropriate button from the dis-
+ play and pressing the left mouse button. A maximum of up
+ to sixteen main menu buttons can be displayed. Each main
+ menu button can launch an application or pop-up a sub menu
+ containing more buttons. The buttons can be represented as
+ a bitmap, text or a colour icon (i.e Pixmap).
+
diff --git a/x11/bricons/pkg-plist b/x11/bricons/pkg-plist
new file mode 100644
index 000000000000..ae3d3faca952
--- /dev/null
+++ b/x11/bricons/pkg-plist
@@ -0,0 +1,11 @@
+bin/bricons
+man/man1/bricons.1.gz
+lib/X11/app-defaults/Xbricons
+include/X11/bitmaps/calander.xbm
+include/X11/bitmaps/help.xbm
+include/X11/bitmaps/letters.xbm
+include/X11/bitmaps/load.xbm
+include/X11/pixmaps/clock.xpm
+include/X11/pixmaps/editor.xpm
+include/X11/pixmaps/mail.xpm
+include/X11/pixmaps/news.xpm
r>* | | | Change btn-secondary styles to btn-default. Make btn-secondary red warning st...Alexander Tseung2018-06-0116-62/+79 | |/ / |/| | * | | Merge pull request #4419 from MetaMask/deps-bump-keyring-controllerkumavis2018-05-312-8/+14 |\ \ \ | * | | deps - bump eth-keyring-controller for bugfixkumavis2018-05-312-8/+14 |/ / / * | | Prevent loading screen from overlaying the app bar (#4417)Alexander Tseung2018-05-314-12/+4 * | | Merge pull request #4407 from MetaMask/e2e-testkumavis2018-05-311-0/+7 |\ \ \ | * | | Delay before getting address textThomas2018-05-301-0/+1 | * | | Merge branch 'develop' into e2e-testThomas2018-05-3011-79/+143 | |\ \ \ | * | | | Add accountThomas2018-05-301-0/+6 * | | | | Fix error handling on incorrect password (#4401)Alexander Tseung2018-05-311-11/+9 * | | | | Merge pull request #4402 from MetaMask/danjm-changelog-update-52918kumavis2018-05-301-0/+11 |\ \ \ \ \ | |_|/ / / |/| | | | | * | | | Update changelogDan J Miller2018-05-301-0/+11 * | | | | Merge pull request #4403 from MetaMask/bugfix-keyring-controllerkumavis2018-05-303-55/+60 |\ \ \ \ \ | * | | | | ci - job-screens - use e2e funcskumavis2018-05-301-6/+4 | * | | | | deps - bump eth-keyring-controller + update package-lockkumavis2018-05-302-49/+56 | |/ / / / * | | | | Merge pull request #4374 from MetaMask/test-unit-fail-on-onlykumavis2018-05-302-1/+8 |\ \ \ \ \ | * | | | | test - unit - fail if tests contain a .only callkumavis2018-05-262-1/+8 * | | | | | Add rpc key to i18n messages (#4375)Alexander Tseung2018-05-301-0/+3 | |/ / / / |/| | | | * | | | | Merge pull request #4399 from MetaMask/merge-masterkumavis2018-05-307-23/+72 |\ \ \ \ \ | |_|/ / / |/| | | | | * | | | Merge branch 'master' of github.com:MetaMask/metamask-extension into merge-ma...kumavis2018-05-307-23/+72 |/| | | | | | |/ / | |/| | | * | | Merge pull request #4384 from antonper/masterkumavis2018-05-303-10/+37 | |\ \ \ | | * | | cleanErrorStack moved to separate library moduleAnton2018-05-293-19/+36 | | * | | error message fixAnton2018-05-291-2/+1 | | * | | Clean up user rejection error messageAnton2018-05-281-3/+14 | |/ / / | * | | Merge pull request #3997 from jakubsta/masterkumavis2018-05-222-5/+12 | |\ \ \ | | * | | Update: allow other extension to connectJakub Stasiak2018-04-182-5/+12 | * | | | Merge pull request #4140 from MetaMask/v4.6.1Thomas Huang2018-05-0143-660/+887 | |\ \ \ \ | | * | | | Version 4.6.1kumavis2018-05-012-2/+9 | * | | | | Merge pull request #4131 from MetaMask/emitter-cleanupkumavis2018-05-011-7/+14 | |\ \ \ \ \ | | * | | | | require logfrankiebee2018-05-011-0/+1 | | * | | | | log emitter errorsfrankiebee2018-04-301-6/+10 | | * | | | | transactions - run event emitters outside context of _setTxStatusfrankiebee2018-04-301-7/+9 * | | | | | | Merge pull request #4394 from MetaMask/MissionStatementkumavis2018-05-302-2/+20 |\ \ \ \ \ \ \ | * | | | | | | Mission v2Dan Finlay2018-05-301-3/+3 | * | | | | | | Add mission statement v1Dan Finlay2018-05-302-2/+20 * | | | | | | | Merge pull request #4390 from MetaMask/i18n-brave-fixkumavis2018-05-301-4/+7 |\ \ \ \ \ \ \ \ | * | | | | | | | i18n - getFirstPreferredLangCode - guard against missing i18n apikumavis2018-05-291-4/+7 * | | | | | | | | Add notification for dropped retry transactions (#4363)Alexander Tseung2018-05-3016-71/+317 * | | | | | | | | Fix add-token token list placeholder width (#4365)Alexander Tseung2018-05-301-0/+4 | |/ / / / / / / |/| | | | | | | * | | | | | | | Fix text field labels of first time flow. Add text fields to storybook (#4389)Alexander Tseung2018-05-294-44/+84 * | | | | | | | Merge pull request #4393 from MetaMask/newui-unlock-catchkumavis2018-05-291-2/+2 |\ \ \ \ \ \ \ \ | * | | | | | | | newui - unlock - dont catch errors unrelated to tryUnlockMetamaskkumavis2018-05-291-2/+2 | |/ / / / / / / * | | | | | | | Merge pull request #4391 from MetaMask/newui-imported-accounts-select-fixkumavis2018-05-291-10/+10 |\ \ \ \ \ \ \ \ | |/ / / / / / / |/| | | | | | | | * | | | | | | metamask-controller - lint fixkumavis2018-05-291-1/+1 | * | | | | | | metamask-controller - update preferences controller addresses after import ac...kumavis2018-05-291-10/+10 |/ / / / / / / * | | | | | | Merge pull request #4373 from whymarrh/new-ui-e2ekumavis2018-05-297-12/+1143 |\ \ \ \ \ \ \ | |_|_|_|_|/ / |/| | | | | | | * | | | | | Add basic e2e tests for the new UIWhymarrh Whitby2018-05-256-2/+973 | * | | | | | fix: Why does npm insist on reordering the lockfile?Whymarrh Whitby2018-05-251-10/+170 |/ / / / / / * | | | | | Merge pull request #4241 from MetaMask/greenkeeper/ethjs-0.4.0kumavis2018-05-241-1/+1 |\ \ \ \ \ \ | |_|_|_|_|/ |/| | | | | | * | | | | fix(package): update ethjs to version 0.4.0greenkeeper[bot]2018-05-121-1/+1 * | | | | | Fix scrolling in Deposit Ether modal (#4336)Alexander Tseung2018-05-241-2/+4 * | | | | | Merge pull request #4337 from MetaMask/recent-blocks-parallelFrankie2018-05-231-15/+7 |\ \ \ \ \ \ | * | | | | | controllers - recent-blocks - pull first historical blocks in parallelkumavis2018-05-221-15/+7 * | | | | | | Merge pull request #4321 from MetaMask/testingkumavis2018-05-2336-1557/+691 |\ \ \ \ \ \ \ | * | | | | | | Merge branch 'develop' into testingtmashuang2018-05-226-53/+57 | |\| | | | | | | * | | | | | | Merge branch 'develop' into testingtmashuang2018-05-229-13446/+22 | |\ \ \ \ \ \ \ | * \ \ \ \ \ \ \ Merge branch 'develop' into testingtmashuang2018-05-2223-1810/+342 | |\ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ Merge branch 'develop' into testingtmashuang2018-05-228-548/+1503 | |\ \ \ \ \ \ \ \ \ | * | | | | | | | | | Moved loose some loose test files to sub folderstmashuang2018-05-2129-59/+108 | * | | | | | | | | | signMessage and signPersonalMessageThomas2018-05-181-13/+33 | * | | | | | | | | | Merge branch 'develop' into testingThomas2018-05-1726-328/+371 | |\ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ Merge branch 'develop' into testingThomas2018-05-1762-2419/+5812 | |\ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ Merge branch 'testing' of https://github.com/tmashuang/metamask-extension int...Thomas2018-05-17245-5461/+19016 | |\ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | console.log -> assert.equalThomas2018-05-091-1/+1 | | * | | | | | | | | | | | ImportAccountWithStrategies Json and KeystoreThomas2018-05-091-0/+30 | | * | | | | | | | | | | | Remove approvePersonalMessage testThomas2018-05-081-45/+0 | | * | | | | | | | | | | | Merge branch 'develop' into testingThomas2018-05-08114-1662/+7483 | | |\ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | Bump package-lockThomas2018-04-251-621/+186 | | * | | | | | | | | | | | | setupUntrustedCommunication and setupTrustedCommunicationThomas2018-04-252-1/+46 | | * | | | | | | | | | | | | Merge branch 'master' into testingThomas2018-04-24117-1908/+5281 | | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | | ConfigManager markAccountsFound, markPasswordForgotten, unMarkPasswordForgottenThomas2018-04-241-7/+70 | | * | | | | | | | | | | | | | resetAccount and addNewAccountThomas2018-04-201-0/+45 | | * | | | | | | | | | | | | | newUnsignedMessage and newUnsignedPersonalMessageThomas2018-04-191-0/+102 | | * | | | | | | | | | | | | | Merge branch 'master' into testingThomas2018-04-11136-3068/+10732 | | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | | | MM-controlller testsThomas2018-04-111-2/+55 | | * | | | | | | | | | | | | | | Update Sinon methods. sinon.sandbox.create() -> sandbox.createSandbox()Thomas2018-04-057-8/+8 | | * | | | | | | | | | | | | | | Merge branch 'testing' of https://github.com/tmashuang/metamask-extension int...Thomas2018-04-033-7/+466 | | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | Update sinion methods. sandbox.create() -> createSandbox()Thomas2018-04-057-7/+7 | * | | | | | | | | | | | | | | | | Merge branch 'testing' of https://github.com/tmashuang/metamask-extension int...Thomas2018-04-053-7/+466 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | | | |/ / / / / / / / / / / / / / / | | |/| | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | Metamask controller methodsThomas2018-03-281-1/+146 | | * | | | | | | | | | | | | | | | Remove console.logThomas2018-03-281-1/+0 | | * | | | | | | | | | | | | | | | Update blacklistThomas2018-03-281-5/+320 * | | | | | | | | | | | | | | | | | Merge pull request #4333 from MetaMask/test-e2e-check-for-errorsThomas Huang2018-05-233-52/+89 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | | test - e2e - only inspect console for errors in chromekumavis2018-05-221-6/+10 | * | | | | | | | | | | | | | | | | | test - e2e - ignore 'development build of Redux' warningkumavis2018-05-221-1/+3 | * | | | | | | | | | | | | | | | | | test - e2e - ignore 'development build of React' warningkumavis2018-05-221-0/+2 | * | | | | | | | | | | | | | | | | | test - e2e - ignore favicon 404skumavis2018-05-221-1/+6 | * | | | | | | | | | | | | | | | | | old-ui - app - use state.metamask.selectedAddress instead of currentView.contextkumavis2018-05-221-3/+3 | * | | | | | | | | | | | | | | | | | old-ui - ens-input - fix params passed to inputkumavis2018-05-221-48/+53 | * | | | | | | | | | | | | | | | | | test - e2e - ignore react 'unknown props dataset' warningskumavis2018-05-221-2/+5 | * | | | | | | | | | | | | | | | | | test - e2e - check for console errors after each testkumavis2018-05-221-1/+17 | | |_|_|_|_|_|_|_|_|_|_|/ / / / / / | |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4308 from MetaMask/i4232-addtokenkumavis2018-05-2352-1086/+1442 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | | Update input field border on focusAlexander Tseung2018-05-221-1/+3 | * | | | | | | | | | | | | | | | | | Fix testsAlexander Tseung2018-05-213-41/+50 | * | | | | | | | | | | | | | | | | | Update designs for Add Token screenAlexander Tseung2018-05-2050-1056/+1401 * | | | | | | | | | | | | | | | | | | Merge pull request #4338 from MetaMask/ci-job-screens-enhanceThomas Huang2018-05-232-95/+131 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|/ / / / / / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | ci - screens - continue screenshots through account creation + export accountkumavis2018-05-222-95/+131 |/ / / / / / / / / / / / / / / / / / * | | | | | | | | | | | | | | | | | Reveal get filtered tx list (#4332)Frankie2018-05-223-46/+1 * | | | | | | | | | | | | | | | | | Merge pull request #4297 from MetaMask/ci-publish-releaseThomas Huang2018-05-223-7/+56 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|_|_|_|_|_|_|_|_|_|/ / / / / / |/| | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Merge branch 'develop' into ci-publish-releasekumavis2018-05-2234-14106/+1855 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | | ci - add docs publish to job-publish-releasekumavis2018-05-192-0/+10 | * | | | | | | | | | | | | | | | | | docs - jsdoc - fix syntaxkumavis2018-05-191-1/+1 | * | | | | | | | | | | | | | | | | | ci - add prep-docs jobkumavis2018-05-191-0/+18 | * | | | | | | | | | | | | | | | | | ci - add job-publish-releasekumavis2018-05-191-0/+21 | * | | | | | | | | | | | | | | | | | ci - rename job-publish to job-publish-prereleasekumavis2018-05-191-2/+2 | * | | | | | | | | | | | | | | | | | ci - clean - whitespace fixkumavis2018-05-191-4/+3 | | |_|_|_|_|_|_|_|_|/ / / / / / / / | |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4295 from MetaMask/kumavis-patch-3Frankie2018-05-221-1/+2 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|/ / / / / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | token-util - warn via loglevel on token lookup failurekumavis2018-05-191-1/+2 | |/ / / / / / / / / / / / / / / / * | | | | | | | | | | | | | | | | Merge pull request #4319 from MetaMask/ci-test-depsFrankie2018-05-221-2/+1 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | CI - remove node security test as blocker for buildskumavis2018-05-221-2/+1 | | |_|_|_|_|_|_|_|_|/ / / / / / / | |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Merge pull request #4328 from MetaMask/i4325-yarnignoreFrankie2018-05-221-13432/+0 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ It tried to get away, but justice must be served.Kevin Serrano2018-05-225-10/+7 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |/ / / / / / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4326 from MetaMask/Jabher-developFrankie2018-05-223-6/+6 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ Merge branch 'develop' of https://github.com/Jabher/metamask-extension into J...kumavis2018-05-223-6/+6 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | | |_|_|_|_|_|_|_|_|_|_|_|/ / / / / / | |/| | | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | bump extensionizer version to 1.0.1 (see https://github.com/MetaMask/extensio...jabher2018-05-083-6/+6 | | | |_|_|_|_|_|_|_|_|/ / / / / / / | | |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4329 from MetaMask/Trigalti-developKevin Serrano2018-05-221-1/+2 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ Merge branch 'develop' of https://github.com/Trigalti/metamask-extension into...kumavis2018-05-221-1/+2 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | | |/ / / / / / / / / / / / / / / / / | |/| | | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Added trailing comma for eslintsimon2018-05-181-1/+1 | | * | | | | | | | | | | | | | | | | Added adyen.com to blacklisted domains because postMessages are blocking car...simon2018-05-181-1/+2 | | | |_|_|/ / / / / / / / / / / / / | | |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4316 from MetaMask/fix-signature-requestkumavis2018-05-221-2/+0 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | | Fix signature request header textAlexander Tseung2018-05-211-2/+0 | | |_|_|_|_|/ / / / / / / / / / / / | |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4273 from brunobar79/fix-new-ui-popup-headerkumavis2018-05-221-2/+0 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | | remove fix header heightBruno2018-05-171-2/+0 | | | | | | * | | | | | | | | | | | | Please, this is my third PR already, stop adding extra baggage. Also, remove...Kevin Serrano2018-05-221-13432/+0 | |_|_|_|_|/ / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | | Merge pull request #4240 from MetaMask/EnhancePortGuidekumavis2018-05-221-1/+12 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|/ / / / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Enhance guide to porting to new platformDan Finlay2018-05-121-1/+12 | | |_|_|_|_|_|_|_|_|_|_|/ / / / / | |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Merge pull request #4034 from whymarrh/account-nicknameskumavis2018-05-2222-114/+332 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|_|_|_|/ / / / / / / / / / / |/| | | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | Fix migration 026 to produce the correct shape for state.identitiesWhymarrh Whitby2018-05-182-3/+10 | * | | | | | | | | | | | | | | | Update MetaMaskController vault restoration test for new KC apiWhymarrh Whitby2018-05-171-1/+1 | * | | | | | | | | | | | | | | | Update eth-keyring-controller dependencyWhymarrh Whitby2018-05-172-194/+1363 | * | | | | | | | | | | | | | | | Add migration to move identities from KeyringControllerWhymarrh Whitby2018-05-173-0/+82 | * | | | | | | | | | | | | | | | Add test case for PreferencesController#setAccountLabelWhymarrh Whitby2018-05-171-0/+21 | * | | | | | | | | | | | | | | | Add PreferencesController#setAddresses to update idsWhymarrh Whitby2018-05-173-8/+66 | * | | | | | | | | | | | | | | | Update AddressBookController to read from preferences storeWhymarrh Whitby2018-05-173-35/+21 | * | | | | | | | | | | | | | | | Move setAccountLabel into PreferencesControllerWhymarrh Whitby2018-05-1714-58/+122 | | |_|_|/ / / / / / / / / / / / | |/| | | | | | | | | | | | | | * | | | | | | | | | | | | | | | Merge pull request #4278 from MetaMask/e2e-testskumavis2018-05-224-366/+83 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|_|/ / / / / / / / / / / / |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | Adjustments for previous PRThomas2018-05-171-4/+4 | * | | | | | | | | | | | | | | Testing timeoutsThomas2018-05-172-200/+1369 | * | | | | | | | | | | | | | | Merge branch 'develop' into e2e-testsThomas2018-05-1534-823/+1172 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | | | |_|_|_|_|_|_|_|_|/ / / / / | | |/| | | | | | | | | | | | | | * | | | | | | | | | | | | | | Merge e2e tests into oneThomas2018-05-154-361/+79 * | | | | | | | | | | | | | | | Merge pull request #4199 from MetaMask/i3487-provider-errorsDan Finlay2018-05-194-182/+1420 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|/ / / / / / / / / / / / / |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | Add new json-rpc-engine middleware for improved error handlingbitpshr2018-05-144-182/+1420 * | | | | | | | | | | | | | | | Merge pull request #4266 from MetaMask/send-screen-detailed-QA-checklistkumavis2018-05-171-0/+96 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|_|_|/ / / / / / / / / / / |/| | | | | | | | | | | | | | | | * | | | | | | | | | | | | | | Adds description to send-screen-QA-checklist.mdDan2018-05-161-1/+7 | * | | | | | | | | | | | | | | Adds detailed QA checklist for the New UI send screen.Dan2018-05-161-0/+90 | | |_|/ / / / / / / / / / / / | |/| | | | | | | | | | | | | * | | | | | | | | | | | | | | Merge pull request #4235 from scsaba/transaction-history-timestampskumavis2018-05-175-74/+143 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ \ \ \ Merge branch 'develop' of github.com:MetaMask/metamask-extension into scsaba-...kumavis2018-05-1755-3285/+2945 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | |/ / / / / / / / / / / / / / / |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | Merge pull request #4146 from MetaMask/sentry-error-like2kumavis2018-05-171-17/+25 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | sentry - add helper to fully rewrite all error messageskumavis2018-05-011-17/+25 * | | | | | | | | | | | | | | | | Merge pull request #4255 from MetaMask/i4233-dropdownskumavis2018-05-175-21/+58 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | | | | Fix account and network dropdowns in confirm screenAlexander Tseung2018-05-155-21/+58 | | |_|_|/ / / / / / / / / / / / / | |/| | | | | | | | | | | | | | | * | | | | | | | | | | | | | | | | Merge pull request #4155 from MetaMask/network-controller-remove-setNetworkEn...kumavis2018-05-17