aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/emu/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11/emu/Makefile b/x11/emu/Makefile
index 409f3a900e59..63733ac3dfb1 100644
--- a/x11/emu/Makefile
+++ b/x11/emu/Makefile
@@ -15,11 +15,17 @@ MASTER_SITE_SUBDIR= applications
MAINTAINER= ports@FreeBSD.org
COMMENT= A terminal emulator for the X Window System
+.if defined(PACKAGE_BUILDING)
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
+.endif
+
+BROKEN= Missing dependency
+
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/emu
-.if !defined(DISPLAY) || ${DISPLAY} == ""
-IGNORE= Requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X.
+.if (!defined(DISPLAY) || ${DISPLAY} == "") && !defined(PACKAGE_BUILDING)
+IGNORE= requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X
.endif
MAN1= emu.1