aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-applets/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 534a88ddbd08..b31397639bd5 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -30,6 +30,7 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USES= pathfix
USE_GNOME= gnomeprefix intlhack gnomepanel gnomedocutils libgnomekbd
+WANT_GNOME= yes
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mixer-applet \
@@ -59,6 +60,8 @@ PLIST_SUB+= COMMANDER="" OLDCOMMANDER="@comment "
PLIST_SUB+= COMMANDER="@comment " OLDCOMMANDER=""
.endif
+.include <bsd.port.pre.mk>
+
.if ( exists(${pygnomedesktop_DETECT}) ) || \
( ( ${HAVE_GNOME:Mpygnomedesktop}!="" ) && ${ARCH}!="sparc64" )
USE_PYTHON= yes
@@ -69,8 +72,6 @@ PLIST_SUB+= PYTHON=""
PLIST_SUB+= PYTHON="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
CFLAGS+= -fPIC
PLIST_SUB= BATTERY="@comment "