From 47a070e007a9f840273e10dd7074475f923ddf4c Mon Sep 17 00:00:00 2001
From: crees <crees@FreeBSD.org>
Date: Sat, 8 Sep 2012 10:10:19 +0000
Subject: All hail the new stable branch of Music Player Daemon; 0.17

Changes:

Anton Khirnov (1):
      update: properly skip symlinks in path that is to be updated.

Dan McGee (1):
      Use g_message and not g_debug when removing song

Jonathan Neuschaefer (1):
      decoder/audiofile: fix compiler warnings with libaudiofile 0.3.3

Max Kellermann (17):
      output/winmm: remove pointless NULL check
      pcm_buffer: pcm_buffer_get() never returns NULL
      decoder_api: check state before emitting initial seek command
      test/read_tags: call g_thread_init()
      test/run_decoder: initialize GThread
      decoder/ffmpeg: read the "year" tag
      text_input_stream: detect end-of-file
      event_pipe, test: explicitly ignore write() return value
      output/osx: use the fifo_buffer library instead of rolling own
      uri: remove g_basename() call from uri_get_suffix()
      directory: use strrchr() instead of g_basename()
      output/jack: workaround for libjack1 crash bug
      output/jack: check for connection failure before starting playback
      test/test_vorbis_encoder: program to debug the vorbis encoder
      encoder/vorbis: generate end-of-stream packet before tag
      encoder_plugin: add state assertions
      encoder/vorbis: generate end-of-stream packet when playback ends
---
 audio/musicpd/Makefile                            | 20 +++++++++-----------
 audio/musicpd/distinfo                            |  4 ++--
 audio/musicpd/files/patch-src_output_ao__plugin.c | 12 ------------
 audio/musicpd/pkg-plist                           |  1 +
 4 files changed, 12 insertions(+), 25 deletions(-)
 delete mode 100644 audio/musicpd/files/patch-src_output_ao__plugin.c

diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 2e9f1871dd3a..8d894bda1769 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -1,13 +1,7 @@
-# New ports collection Makefile for:	Music Player Daemon
-# Date created:				Thu Oct 02 2003
-# Whom:					Mark Reidel <ports@mark.reidel.info>
-#
 # $FreeBSD$
-#
 
 PORTNAME=	musicpd
-PORTVERSION=	0.16.8
-PORTREVISION=	2
+PORTVERSION=	0.17
 CATEGORIES=	audio ipv6
 MASTER_SITES=	SF/${PORTNAME}/mpd/${PORTVERSION}
 DISTNAME=	mpd-${PORTVERSION}
@@ -20,6 +14,7 @@ LIB_DEPENDS+=	mad.2:${PORTSDIR}/audio/libmad \
 
 LICENSE=	GPLv2
 
+USE_STAGE=	yes
 USE_GMAKE=	yes
 USE_BZIP2=	yes
 GNU_CONFIGURE=	yes
@@ -34,7 +29,7 @@ CFLAGS+=	-I${PREFIX}/include
 MAN1=		${PORTNAME}.1
 MAN5=		${MPDCONF}.5
 
-DOCSDIR?=	${PREFIX}/share/doc/mpd
+DOCSDIR?=	${PREFIX}/share/doc/musicpd
 PORTDOCS=	AUTHORS README COPYING NEWS UPGRADING
 
 SUB_FILES=	pkg-message
@@ -54,7 +49,10 @@ MPDCONF?=	musicpd.conf
 USERS=	${MPDUSER}
 GROUPS=	${MPDGROUP}
 
-PLIST_SUB=	MPDCONF=${MPDCONF}
+PLIST_SUB=	MPDCONF=${MPDCONF} \
+		MPDUSER=${MPDUSER} \
+		MPDDIR=${MPDDIR}   \
+		MPDGROUP=${MPDGROUP}
 SUB_LIST+=	MPDDIR=${MPDDIR} \
 		MPDCONF=${MPDCONF}
 
@@ -255,7 +253,7 @@ do-install:
 	@${INSTALL_MAN} ${WRKSRC}/doc/mpd.1 ${MAN1PREFIX}/man/man1/${PORTNAME}.1
 	@${INSTALL_MAN} ${WRKSRC}/doc/mpd.conf.5 \
 		${MAN5PREFIX}/man/man5/${MPDCONF}.5
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
 	@${MKDIR} ${DOCSDIR}
 .   for doc in ${PORTDOCS}
 	@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/
@@ -269,7 +267,7 @@ post-install:
 			${PREFIX}/etc/${MPDCONF} ; \
 	fi
 	@${MKDIR} ${MPDDIR}
-	@${CHOWN} -R ${MPDUSER}:${MPDGROUP} ${MPDDIR}
+	@${INSTALL} -d -o ${MPDUSER} -g ${MPDGROUP} ${MPDDIR}
 	@${ECHO_MSG}
 	@${CAT} ${PKGMESSAGE}
 	@${ECHO_MSG}
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index 9d884524c056..bca96ef8e6a7 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpd-0.16.8.tar.bz2) = 35183ae4a706391f5d739e4378b74f516952adda09a260fecfd531a58b0fff17
-SIZE (mpd-0.16.8.tar.bz2) = 491170
+SHA256 (mpd-0.17.tar.bz2) = 3151ad270530ec3408d65d884bcc776cd08f92040ee4aecb96e90b6145ad5867
+SIZE (mpd-0.17.tar.bz2) = 556624
diff --git a/audio/musicpd/files/patch-src_output_ao__plugin.c b/audio/musicpd/files/patch-src_output_ao__plugin.c
deleted file mode 100644
index 77a75d12d1c4..000000000000
--- a/audio/musicpd/files/patch-src_output_ao__plugin.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- src/output/ao_plugin.c.orig	2011-02-05 21:03:39.032765668 +0000
-+++ src/output/ao_plugin.c	2011-02-05 21:04:11.006777588 +0000
-@@ -188,6 +188,7 @@
- 		break;
- 	}
- 
-+	memset(&format, 0, sizeof(format));
- 	format.rate = audio_format->sample_rate;
- 	format.byte_format = AO_FMT_NATIVE;
- 	format.channels = audio_format->channels;
diff --git a/audio/musicpd/pkg-plist b/audio/musicpd/pkg-plist
index b58558b26c76..f9f0794eafc4 100644
--- a/audio/musicpd/pkg-plist
+++ b/audio/musicpd/pkg-plist
@@ -2,3 +2,4 @@ bin/musicpd
 @unexec if cmp -s %D/etc/%%MPDCONF%%.sample %D/etc/%%MPDCONF%%; then rm -f %D/etc/%%MPDCONF%%; fi
 etc/%%MPDCONF%%.sample
 @exec if [ ! -f %D/etc/%%MPDCONF%% ] ; then cp -p %D/%F %B/%%MPDCONF%%; fi
+@exec install -d -o %%MPDUSER%% -g %%MPDGROUP%% %%MPDDIR%%
-- 
cgit