From 5e474e8e840549af2a65a8f7fc1dbf3d527adb4a Mon Sep 17 00:00:00 2001
From: thierry <thierry@FreeBSD.org>
Date: Mon, 22 Nov 2004 16:45:26 +0000
Subject: - update devel/pear-PEAR to 1.3.3.1; - install pear script as pear2.

PR:		ports/73995
Submitted by:	maintainer.
---
 devel/pear-PEAR/Makefile                         | 10 ++++++++--
 devel/pear-PEAR/Makefile.common                  |  4 ++++
 devel/pear-PEAR/distinfo                         |  4 ++--
 devel/pear-PEAR/files/patch-scripts::pearcmd.php | 19 +++++++++++++++++++
 devel/pear-PEAR/pkg-deinstall                    | 11 ++++++++++-
 devel/pear-PEAR/pkg-install                      |  9 ++++++++-
 6 files changed, 51 insertions(+), 6 deletions(-)
 create mode 100644 devel/pear-PEAR/files/patch-scripts::pearcmd.php

diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
index 722e6a66d833..5ab0149ad1c7 100644
--- a/devel/pear-PEAR/Makefile
+++ b/devel/pear-PEAR/Makefile
@@ -6,7 +6,7 @@
 #
 
 PORTNAME=	PEAR
-PORTVERSION=	1.3.3
+PORTVERSION=	1.3.3.1
 CATEGORIES=	devel www pear
 
 MAINTAINER=	antonio@php.net
@@ -25,8 +25,14 @@ FILES=		PEAR.php System.php package.dtd template.spec OS/Guess.php 		\
 		PEAR/Autoloader.php PEAR/Command.php PEAR/Common.php PEAR/Config.php 	\
 		PEAR/Dependency.php PEAR/Downloader.php PEAR/Exception.php 		\
 		PEAR/ErrorStack.php PEAR/Builder.php PEAR/Installer.php 		\
-		PEAR/Packager.php PEAR/Registry.php PEAR/Remote.php
+		PEAR/Packager.php PEAR/Registry.php PEAR/Remote.php PEAR/RunTest.php
+SCRIPTFILES=	pear2
 
 .include <bsd.port.pre.mk>
+
+post-patch:
+	@${SED} "s|@pear_version@|${PORTVERSION}|g" \
+		${WRKSRC}/scripts/pearcmd.php > ${WRKSRC}/pear-${SCRIPTFILES}
+
 .include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
 .include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR/Makefile.common b/devel/pear-PEAR/Makefile.common
index 9a36971f7eca..90b8c9200b42 100644
--- a/devel/pear-PEAR/Makefile.common
+++ b/devel/pear-PEAR/Makefile.common
@@ -7,6 +7,8 @@ PKGNAMEPREFIX=	pear-
 EXTRACT_SUFX=	.tgz
 DIST_SUBDIR=	PEAR
 
+USE_REINPLACE=	yes
+
 .if !defined(USE_PHPIZE)
 NO_BUILD=	yes
 .endif
@@ -210,6 +212,8 @@ do-install-scriptfiles: do-install-scriptfiles-msg
 .  for file in ${SCRIPTFILES}
 	@${CP} ${WRKSRC}/pear-${file} ${WRKSRC}/${file}
 	@${REINPLACE_CMD} -e "s|@php_bin@|${SCRIPTFILESDIR}/php|g" ${WRKSRC}/${file}
+	@${REINPLACE_CMD} -e "s|@php_dir@|${PREFIX}/lib/php|g" ${WRKSRC}/${file}
+	@${REINPLACE_CMD} -e "s|@include_path@|${PREFIX}/${LPEARDIR}|g" ${WRKSRC}/${file}
 	@${INSTALL_SCRIPT} ${WRKSRC}/${file} ${SCRIPTFILESDIR}/${file}
 .  endfor
 . endif
diff --git a/devel/pear-PEAR/distinfo b/devel/pear-PEAR/distinfo
index 8994b6703e08..6836e5536f9e 100644
--- a/devel/pear-PEAR/distinfo
+++ b/devel/pear-PEAR/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/PEAR-1.3.3.tgz) = da8794961ff5649734928a8816fb2c66
-SIZE (PEAR/PEAR-1.3.3.tgz) = 103320
+MD5 (PEAR/PEAR-1.3.3.1.tgz) = 02a82aebb5df17c0e5e8bc0e23013b54
+SIZE (PEAR/PEAR-1.3.3.1.tgz) = 106079
diff --git a/devel/pear-PEAR/files/patch-scripts::pearcmd.php b/devel/pear-PEAR/files/patch-scripts::pearcmd.php
new file mode 100644
index 000000000000..a1d9d264bbd3
--- /dev/null
+++ b/devel/pear-PEAR/files/patch-scripts::pearcmd.php
@@ -0,0 +1,19 @@
+--- scripts/pearcmd.php.orig	Thu Oct 28 14:37:56 2004
++++ scripts/pearcmd.php	Thu Nov 11 11:21:39 2004
+@@ -1,3 +1,4 @@
++#!@php_bin@ -n -q -dsafe_mode=0 -doutput_buffering=1
+ <?php
+ //
+ // +----------------------------------------------------------------------+
+@@ -24,8 +25,10 @@
+ /**
+  * @nodep Gtk
+  */
++dl('pcre.so');
++dl('xml.so');
+ if ('@include_path@' != '@'.'include_path'.'@') {
+-    ini_set('include_path', '@include_path@');
++    ini_set('include_path', '@include_path@:@include_path@/bootstrap');
+ }
+ ini_set('allow_url_fopen', true);
+ if (!ini_get('safe_mode')) {
diff --git a/devel/pear-PEAR/pkg-deinstall b/devel/pear-PEAR/pkg-deinstall
index 79df94e800f9..c0cbc6c195fc 100644
--- a/devel/pear-PEAR/pkg-deinstall
+++ b/devel/pear-PEAR/pkg-deinstall
@@ -10,4 +10,13 @@ fi
 PKG_NAME=${1%%-[0-9._]*}
 PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
 
-${PKG_PREFIX}/bin/pear uninstall -r -n ${PACKAGE} || true
+PEAR=${PKG_PREFIX}/bin/pear
+PEAR2=${PKG_PREFIX}/bin/pear2
+
+if [ ${PKG_NAME} = "pear-PEAR" ]; then
+	PEAR_INSTALLER=${PEAR}
+else
+	PEAR_INSTALLER=${PEAR2}
+fi
+
+${PEAR_INSTALLER} uninstall -r -n ${PACKAGE} || true
diff --git a/devel/pear-PEAR/pkg-install b/devel/pear-PEAR/pkg-install
index f622fdfce650..811a6112141c 100644
--- a/devel/pear-PEAR/pkg-install
+++ b/devel/pear-PEAR/pkg-install
@@ -6,9 +6,16 @@
 
 PREFIX=${PKG_PREFIX:-/usr/local}
 PEAR=${PREFIX}/bin/pear
+PEAR2=${PREFIX}/bin/pear2
 PKGREGDIR=${PREFIX}/share/pear/packages/$1
 
+if [ -f "${PEAR2}" ]; then
+	PEAR_INSTALLER=${PEAR2}
+else
+	PEAR_INSTALLER=${PEAR}
+fi
+
 [ "x$1" = "x" ] && exit 1
 if [ "x$2" = "xPOST-INSTALL" ]; then
-	${PEAR} install -r -f ${PKGREGDIR}/package.xml
+	${PEAR_INSTALLER} install -r -f ${PKGREGDIR}/package.xml
 fi
-- 
cgit