From e41660da24df4a6f78555795413de261fecb0c25 Mon Sep 17 00:00:00 2001
From: pgollucci <pgollucci@FreeBSD.org>
Date: Mon, 27 Dec 2010 15:52:11 +0000
Subject: - new version of py-MySQLdb installs only the .egg 'zipped' so
 mysql.so   is no longer present to test for.

Approved by:    itectu (portmgr, via irc)
---
 databases/mydbf2mysql/Makefile    | 2 +-
 databases/py-sqlobject/Makefile   | 2 +-
 deskutils/gbirthday/Makefile      | 2 +-
 devel/viewvc/Makefile             | 2 +-
 irc/py-gozerbot/Makefile          | 2 +-
 mail/py-ppolicy/Makefile          | 2 +-
 net-im/jabber-pyicq/Makefile      | 2 +-
 www/roundup/Makefile              | 2 +-
 www/session2/Makefile             | 2 +-
 www/zope-mysqluserfolder/Makefile | 2 +-
 www/zope-zmysqlda/Makefile        | 2 +-
 11 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/databases/mydbf2mysql/Makefile b/databases/mydbf2mysql/Makefile
index 9fec8468c9d0..8af74f75ab9b 100644
--- a/databases/mydbf2mysql/Makefile
+++ b/databases/mydbf2mysql/Makefile
@@ -14,7 +14,7 @@ DISTNAME=	MyDBF2MySQL-${PORTVERSION}
 MAINTAINER=	andrey.polyakov@unix.net
 COMMENT=	Flexible tool for DBF import into MySQL
 
-RUN_DEPENDS+=	py26-MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
 RUN_DEPENDS+=	ydbf=0.0.1:${PORTSDIR}/devel/py-ydbf
 
 USE_PYTHON=	2.6+
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index 14f4340c9ce3..ba0491710513 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -36,7 +36,7 @@ OPTIONSFILE=	${PORT_DBDIR}/py-${PORTNAME}/options
 
 .include <bsd.port.pre.mk>
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 .if defined(WITH_PGSQL)
diff --git a/deskutils/gbirthday/Makefile b/deskutils/gbirthday/Makefile
index ff4d8d486305..17da7fd05f64 100644
--- a/deskutils/gbirthday/Makefile
+++ b/deskutils/gbirthday/Makefile
@@ -45,7 +45,7 @@ RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
 .endif
 
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 .if defined(WITH_NOTIFY)
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 6e562f7ef03d..6f4693fda195 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -66,7 +66,7 @@ RUN_DEPENDS+=	${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi3
 # It catalogs every commit in the CVS or Subversion repository into a SQL database.
 # In fact, the databases are 100% compatible.
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_LIBDIR}/site-packages/_mysql.so:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}-MySQLdb>=0::${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 pre-everything::
diff --git a/irc/py-gozerbot/Makefile b/irc/py-gozerbot/Makefile
index 028ffb0f7a8e..eb2d83bfad6e 100644
--- a/irc/py-gozerbot/Makefile
+++ b/irc/py-gozerbot/Makefile
@@ -42,7 +42,7 @@ post-install:
 .include <bsd.port.pre.mk>
 
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 .if defined(WITH_XMPP)
diff --git a/mail/py-ppolicy/Makefile b/mail/py-ppolicy/Makefile
index c50e90e4a09f..5ed5da5c7501 100644
--- a/mail/py-ppolicy/Makefile
+++ b/mail/py-ppolicy/Makefile
@@ -37,7 +37,7 @@ OPTIONS=	GeoIP "Use GeoIP support" On \
 RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/GeoIP.so:${PORTSDIR}/net/py-GeoIP
 .endif
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 .if defined(WITH_LDAP)
 RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}ldap2>=2.3.1:${PORTSDIR}/net/py-ldap2
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index f796ca35c6ef..5a22e0169fbc 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -84,7 +84,7 @@ RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twis
 .endif
 
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 SUB_LIST+=	JABBER_USER=${JABBER_USER}
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 526370cc1f73..5219b4f05dff 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -36,7 +36,7 @@ RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psy
 .endif
 
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 .endif
 
 .if !defined(NO_INSTALL_MANPAGES)
diff --git a/www/session2/Makefile b/www/session2/Makefile
index 233496068cce..989b783d75e0 100644
--- a/www/session2/Makefile
+++ b/www/session2/Makefile
@@ -26,7 +26,7 @@ OPTIONS+=	POSTGRESQL "psycopg support" on
 .include <bsd.port.pre.mk>
 
 .if defined(WITH_MYSQL)
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+=	${PYHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 BROKEN=		bad dependency line
 .endif
 
diff --git a/www/zope-mysqluserfolder/Makefile b/www/zope-mysqluserfolder/Makefile
index bf0d74fd8a55..cfb43f9941c7 100644
--- a/www/zope-mysqluserfolder/Makefile
+++ b/www/zope-mysqluserfolder/Makefile
@@ -15,7 +15,7 @@ DISTNAME=	${ZOPEPRODUCTNAME}-${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A Zope user folder which uses MySQL database to store user information
 
-RUN_DEPENDS=	${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 
 NO_PACKAGE=	Double python dependency
 USE_PYTHON=	yes
diff --git a/www/zope-zmysqlda/Makefile b/www/zope-zmysqlda/Makefile
index 1522bec2748b..9d864167b7d5 100644
--- a/www/zope-zmysqlda/Makefile
+++ b/www/zope-zmysqlda/Makefile
@@ -18,7 +18,7 @@ DISTNAME=	${ZOPEPRODUCTNAME}-${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	MySQL Database Adapter for the Zope web application framework
 
-RUN_DEPENDS=	${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
 
 NO_PACKAGE=	Double python dependency
 USE_PYTHON=	yes
-- 
cgit