From 4f8e31ecef91ccb1560dd3a17896401dcd9b3cf8 Mon Sep 17 00:00:00 2001
From: trevor <trevor@FreeBSD.org>
Date: Thu, 5 Feb 2004 20:38:07 +0000
Subject: Use PLIST_FILES.

Reviewed by:	marcus
---
 archivers/9e/Makefile          | 2 ++
 archivers/9e/pkg-plist         | 1 -
 archivers/cabextract/Makefile  | 1 +
 archivers/cabextract/pkg-plist | 1 -
 archivers/hffzip/Makefile      | 1 +
 archivers/hffzip/pkg-plist     | 1 -
 archivers/jzip.org/Makefile    | 1 +
 archivers/jzip.org/pkg-plist   | 1 -
 archivers/lzop/Makefile        | 1 +
 archivers/lzop/pkg-plist       | 1 -
 archivers/nomarch/Makefile     | 1 +
 archivers/nomarch/pkg-plist    | 1 -
 archivers/nulib/Makefile       | 1 +
 archivers/nulib/pkg-plist      | 1 -
 archivers/parchive/Makefile    | 1 +
 archivers/parchive/pkg-plist   | 1 -
 archivers/ppunpack/Makefile    | 1 +
 archivers/ppunpack/pkg-plist   | 1 -
 archivers/sectar/Makefile      | 1 +
 archivers/sectar/pkg-plist     | 1 -
 archivers/tardy/Makefile       | 1 +
 archivers/tardy/pkg-plist      | 1 -
 archivers/undms/Makefile       | 1 +
 archivers/undms/pkg-plist      | 1 -
 archivers/unlzx/Makefile       | 1 +
 archivers/unlzx/pkg-plist      | 1 -
 archivers/untar/Makefile       | 1 +
 archivers/untar/pkg-plist      | 1 -
 28 files changed, 15 insertions(+), 14 deletions(-)
 delete mode 100644 archivers/9e/pkg-plist
 delete mode 100644 archivers/cabextract/pkg-plist
 delete mode 100644 archivers/hffzip/pkg-plist
 delete mode 100644 archivers/jzip.org/pkg-plist
 delete mode 100644 archivers/lzop/pkg-plist
 delete mode 100644 archivers/nomarch/pkg-plist
 delete mode 100644 archivers/nulib/pkg-plist
 delete mode 100644 archivers/parchive/pkg-plist
 delete mode 100644 archivers/ppunpack/pkg-plist
 delete mode 100644 archivers/sectar/pkg-plist
 delete mode 100644 archivers/tardy/pkg-plist
 delete mode 100644 archivers/undms/pkg-plist
 delete mode 100644 archivers/unlzx/pkg-plist
 delete mode 100644 archivers/untar/pkg-plist

(limited to 'archivers')

diff --git a/archivers/9e/Makefile b/archivers/9e/Makefile
index a600474d06b8..d6e4f891ff08 100644
--- a/archivers/9e/Makefile
+++ b/archivers/9e/Makefile
@@ -14,6 +14,8 @@ DISTNAME=	9e
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Explode Plan9 archives
 
+PLIST_FILES=	bin/9e
+
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/9e ${PREFIX}/bin
 
diff --git a/archivers/9e/pkg-plist b/archivers/9e/pkg-plist
deleted file mode 100644
index 34afe4bfad25..000000000000
--- a/archivers/9e/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/9e
diff --git a/archivers/cabextract/Makefile b/archivers/cabextract/Makefile
index 32a0f9fad2d3..fc833a61dd1c 100644
--- a/archivers/cabextract/Makefile
+++ b/archivers/cabextract/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES=	http://www.kyz.uklinux.net/downloads/
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A program to extract Microsoft cabinet (.CAB) files
 
+PLIST_FILES=	bin/cabextract
 USE_GETOPT_LONG=yes
 GNU_CONFIGURE=	yes
 
diff --git a/archivers/cabextract/pkg-plist b/archivers/cabextract/pkg-plist
deleted file mode 100644
index 8636d036641b..000000000000
--- a/archivers/cabextract/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/cabextract
diff --git a/archivers/hffzip/Makefile b/archivers/hffzip/Makefile
index cd6523387c32..e01afc112099 100644
--- a/archivers/hffzip/Makefile
+++ b/archivers/hffzip/Makefile
@@ -14,6 +14,7 @@ DISTNAME=	${PORTNAME}${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	File compressor based on Huffman coding
 
+PLIST_FILES=	bin/hffzip
 WRKSRC=		${WRKDIR}/${PORTNAME}
 
 do-install:
diff --git a/archivers/hffzip/pkg-plist b/archivers/hffzip/pkg-plist
deleted file mode 100644
index 648ff602d3e2..000000000000
--- a/archivers/hffzip/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/hffzip
diff --git a/archivers/jzip.org/Makefile b/archivers/jzip.org/Makefile
index 2b661a255ab4..982a0a31e1db 100644
--- a/archivers/jzip.org/Makefile
+++ b/archivers/jzip.org/Makefile
@@ -16,6 +16,7 @@ DISTNAME=	${PORTNAME}${PORTVERSION}.src
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A WinZip like program written in java
 
+PLIST_FILES=	share/java/classes/jzip.org.jar
 USE_ZIP=	yes
 USE_JAVA=	1.2+
 NEED_JAVAC=	yes
diff --git a/archivers/jzip.org/pkg-plist b/archivers/jzip.org/pkg-plist
deleted file mode 100644
index 6a3a4476d356..000000000000
--- a/archivers/jzip.org/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-share/java/classes/jzip.org.jar
diff --git a/archivers/lzop/Makefile b/archivers/lzop/Makefile
index 7a4688334ec4..bd11f6006d60 100644
--- a/archivers/lzop/Makefile
+++ b/archivers/lzop/Makefile
@@ -21,5 +21,6 @@ CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
 
 MAN1=		lzop.1
+PLIST_FILES=	bin/lzop
 
 .include <bsd.port.mk>
diff --git a/archivers/lzop/pkg-plist b/archivers/lzop/pkg-plist
deleted file mode 100644
index 3199c4ec7237..000000000000
--- a/archivers/lzop/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/lzop
diff --git a/archivers/nomarch/Makefile b/archivers/nomarch/Makefile
index 528a95d26d17..5c6885c217c0 100644
--- a/archivers/nomarch/Makefile
+++ b/archivers/nomarch/Makefile
@@ -21,6 +21,7 @@ MAKE_ENV=	CPPFLAGS="${CPPFLAGS}" \
 		LDFLAGS="${LDFLAGS}"
 
 MAN1=	nomarch.1
+PLIST_FILES=	bin/nomarch
 
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/nomarch ${PREFIX}/bin
diff --git a/archivers/nomarch/pkg-plist b/archivers/nomarch/pkg-plist
deleted file mode 100644
index 8af8e1c382ce..000000000000
--- a/archivers/nomarch/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/nomarch
diff --git a/archivers/nulib/Makefile b/archivers/nulib/Makefile
index cd7d7bee4dd4..546c9d256deb 100644
--- a/archivers/nulib/Makefile
+++ b/archivers/nulib/Makefile
@@ -18,6 +18,7 @@ COMMENT=	NuFX archive utility
 
 WRKSRC=		${WRKDIR}/nulib
 MAN1=		nulib.1
+PLIST_FILES=	bin/nulib
 
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/nulib ${PREFIX}/bin/nulib
diff --git a/archivers/nulib/pkg-plist b/archivers/nulib/pkg-plist
deleted file mode 100644
index 0c9ed4c6a852..000000000000
--- a/archivers/nulib/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/nulib
diff --git a/archivers/parchive/Makefile b/archivers/parchive/Makefile
index dfd15fc5f70c..b3be790762e7 100644
--- a/archivers/parchive/Makefile
+++ b/archivers/parchive/Makefile
@@ -16,6 +16,7 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Parity Archiver - makes multiple parity volumes from a set of files
 
 MAKEFILE=	${FILESDIR}/Makefile
+PLIST_FILES=	bin/parchive
 WRKSRC=		${WRKDIR}/par-cmdline
 
 .include <bsd.port.mk>
diff --git a/archivers/parchive/pkg-plist b/archivers/parchive/pkg-plist
deleted file mode 100644
index 353e9e831825..000000000000
--- a/archivers/parchive/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/parchive
diff --git a/archivers/ppunpack/Makefile b/archivers/ppunpack/Makefile
index 78b606232392..d8dab4ade727 100644
--- a/archivers/ppunpack/Makefile
+++ b/archivers/ppunpack/Makefile
@@ -21,6 +21,7 @@ NO_CDROM=	${RESTRICTED}
 
 WRKSRC=		${WRKDIR}/PPUnpack
 MAKE_ARGS=	CC="${CC}" COPTS="${CFLAGS}"
+PLIST_FILES=	bin/ppunpack
 ALL_TARGET=	ppunpack
 
 do-install:
diff --git a/archivers/ppunpack/pkg-plist b/archivers/ppunpack/pkg-plist
deleted file mode 100644
index f29febd4826c..000000000000
--- a/archivers/ppunpack/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/ppunpack
diff --git a/archivers/sectar/Makefile b/archivers/sectar/Makefile
index 292199480420..ca7267fdaa66 100644
--- a/archivers/sectar/Makefile
+++ b/archivers/sectar/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR=	star
 MAINTAINER=		ports@FreeBSD.org
 COMMENT=		A program to create encrypted tar archives
 
+PLIST_FILES=	bin/sectar
 USE_GETOPT_LONG=	yes
 USE_LIBTOOL=		yes
 
diff --git a/archivers/sectar/pkg-plist b/archivers/sectar/pkg-plist
deleted file mode 100644
index f0e748a2aec3..000000000000
--- a/archivers/sectar/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/sectar
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index d77609f3c326..096fe0c16950 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -17,5 +17,6 @@ COMMENT=	Manipulate the file headers in tar archive files in various ways
 GNU_CONFIGURE=	yes
 
 MAN1=	tardy.1
+PLIST_FILES=	bin/tardy
 
 .include <bsd.port.mk>
diff --git a/archivers/tardy/pkg-plist b/archivers/tardy/pkg-plist
deleted file mode 100644
index e297caf6dd58..000000000000
--- a/archivers/tardy/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/tardy
diff --git a/archivers/undms/Makefile b/archivers/undms/Makefile
index 0a8d0c06d3d8..4d4f4477c874 100644
--- a/archivers/undms/Makefile
+++ b/archivers/undms/Makefile
@@ -17,6 +17,7 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Converts .dms Amiga disk images to uncompressed .adf images
 
 NO_WRKSUBDIR=	yes
+PLIST_FILES=	bin/undms
 
 do-extract:
 	${MKDIR} ${WRKDIR}
diff --git a/archivers/undms/pkg-plist b/archivers/undms/pkg-plist
deleted file mode 100644
index a145a16aa938..000000000000
--- a/archivers/undms/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/undms
diff --git a/archivers/unlzx/Makefile b/archivers/unlzx/Makefile
index aaf11c9ccb42..5e22083c9445 100644
--- a/archivers/unlzx/Makefile
+++ b/archivers/unlzx/Makefile
@@ -17,6 +17,7 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Extracts .lzx archives from Amiga systems
 
 NO_WRKSUBDIR=		yes
+PLIST_FILES=	bin/unlzx
 
 do-extract:
 	${MKDIR} ${WRKDIR}
diff --git a/archivers/unlzx/pkg-plist b/archivers/unlzx/pkg-plist
deleted file mode 100644
index bd0f51a69e66..000000000000
--- a/archivers/unlzx/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/unlzx
diff --git a/archivers/untar/Makefile b/archivers/untar/Makefile
index e2b2b7461130..08d30338d3c2 100644
--- a/archivers/untar/Makefile
+++ b/archivers/untar/Makefile
@@ -19,6 +19,7 @@ COMMENT=	Lists/Extracts files from a "*.tgz" or "*.gz" archive
 
 NO_WRKSUBDIR=	yes
 NO_INSTALL_MANPAGES=		yes
+PLIST_FILES=	bin/untar
 
 PROG=	untar
 
diff --git a/archivers/untar/pkg-plist b/archivers/untar/pkg-plist
deleted file mode 100644
index bd02a6988539..000000000000
--- a/archivers/untar/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/untar
-- 
cgit