From e55721efb2e4651c692cf84369e55e6de78ba4ba Mon Sep 17 00:00:00 2001
From: vd <vd@FreeBSD.org>
Date: Wed, 29 Jul 2009 08:37:28 +0000
Subject: Add a new port databases/embedded_innodb:

Standalone version of the MySQL storage engine InnoDB.
---
 databases/Makefile                  |  1 +
 databases/embedded_innodb/Makefile  | 20 ++++++++++++++++++++
 databases/embedded_innodb/distinfo  |  3 +++
 databases/embedded_innodb/pkg-descr | 15 +++++++++++++++
 databases/embedded_innodb/pkg-plist | 23 +++++++++++++++++++++++
 5 files changed, 62 insertions(+)
 create mode 100644 databases/embedded_innodb/Makefile
 create mode 100644 databases/embedded_innodb/distinfo
 create mode 100644 databases/embedded_innodb/pkg-descr
 create mode 100644 databases/embedded_innodb/pkg-plist

(limited to 'databases')

diff --git a/databases/Makefile b/databases/Makefile
index 4b2605b2b7ca..d9feddf8da09 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -48,6 +48,7 @@
     SUBDIR += dbtool
     SUBDIR += dbview
     SUBDIR += edb
+    SUBDIR += embedded_innodb
     SUBDIR += emma
     SUBDIR += erlang-mysql
     SUBDIR += erserver
diff --git a/databases/embedded_innodb/Makefile b/databases/embedded_innodb/Makefile
new file mode 100644
index 000000000000..78ce8118a32d
--- /dev/null
+++ b/databases/embedded_innodb/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for:	Embedded InnoDB
+# Date created:				10 June 2009
+# Whom:					Vasil Dimov <vd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	embedded_innodb
+PORTVERSION=	1.0.3.5325
+CATEGORIES=	databases
+MASTER_SITES=	http://www.innodb.com/download/embedded_innodb/
+
+MAINTAINER=	vd@FreeBSD.org
+COMMENT=	Standalone version of the MySQL storage engine InnoDB
+
+GNU_CONFIGURE=	yes
+
+USE_LDCONFIG=	yes
+
+.include <bsd.port.mk>
diff --git a/databases/embedded_innodb/distinfo b/databases/embedded_innodb/distinfo
new file mode 100644
index 000000000000..09eac41b7255
--- /dev/null
+++ b/databases/embedded_innodb/distinfo
@@ -0,0 +1,3 @@
+MD5 (embedded_innodb-1.0.3.5325.tar.gz) = d14c88109af2c5dc5be1e5d4055a51bc
+SHA256 (embedded_innodb-1.0.3.5325.tar.gz) = 994ce8fbd52e5065018e0a216cca774277addb0cb105b402713ee87ab7ee1329
+SIZE (embedded_innodb-1.0.3.5325.tar.gz) = 1487609
diff --git a/databases/embedded_innodb/pkg-descr b/databases/embedded_innodb/pkg-descr
new file mode 100644
index 000000000000..9bfb53d49ea6
--- /dev/null
+++ b/databases/embedded_innodb/pkg-descr
@@ -0,0 +1,15 @@
+This is the standalone version of the MySQL storage engine InnoDB.
+
+Made for application developers, device makers and ISVs, Embedded InnoDB
+provides all the features of InnoDB in an embeddable form, without the
+overhead of the MySQL server.
+
+Embedded InnoDB is used independently of MySQL. It is designed to be linked
+directly into application programs, and provides highly efficient, low-level
+database management services, not using SQL.
+
+Embedded InnoDB provides concurrency control, sophisticated indexing and crash
+recovery. It is used via non-SQL, ISAM-like API for creating and querying
+tables and executing other data management functions.
+
+WWW: http://www.innodb.com/products/embedded-innodb/
diff --git a/databases/embedded_innodb/pkg-plist b/databases/embedded_innodb/pkg-plist
new file mode 100644
index 000000000000..d9c9b07dba51
--- /dev/null
+++ b/databases/embedded_innodb/pkg-plist
@@ -0,0 +1,23 @@
+include/embedded_innodb-1.0/innodb.h
+lib/libinnodb.a
+lib/libinnodb.la
+lib/libinnodb.so
+lib/libinnodb.so.2
+share/embedded_innodb-1.0/examples/COPYING
+share/embedded_innodb-1.0/examples/Makefile.examples
+share/embedded_innodb-1.0/examples/README
+share/embedded_innodb-1.0/examples/ib_cfg.c
+share/embedded_innodb-1.0/examples/ib_cursor.c
+share/embedded_innodb-1.0/examples/ib_logger.c
+share/embedded_innodb-1.0/examples/ib_mt_stress.c
+share/embedded_innodb-1.0/examples/ib_perf1.c
+share/embedded_innodb-1.0/examples/ib_test1.c
+share/embedded_innodb-1.0/examples/ib_test2.c
+share/embedded_innodb-1.0/examples/ib_test3.c
+share/embedded_innodb-1.0/examples/ib_test5.c
+share/embedded_innodb-1.0/examples/ib_types.c
+share/embedded_innodb-1.0/examples/test0aux.c
+share/embedded_innodb-1.0/examples/test0aux.h
+@dirrm include/embedded_innodb-1.0
+@dirrm share/embedded_innodb-1.0/examples
+@dirrm share/embedded_innodb-1.0
-- 
cgit