From 12e61726256290c04db8ba31c48e78e3dc8e29c6 Mon Sep 17 00:00:00 2001
From: nectar
Date: Mon, 24 Mar 2003 13:33:28 +0000
Subject: Update 1.2.6 -> 1.2.8
PR: ports/50031
Supersedes: ports/44498, ports/46189, ports/47134, ports/48071,
ports/48096, ports/48966
Submitted by: Randy Philipp
---
ftp/proftpd/Makefile | 28 +++++++++--------
ftp/proftpd/distinfo | 2 +-
ftp/proftpd/files/patch-aa | 35 +++++++++------------
ftp/proftpd/files/patch-ah | 12 ++++----
ftp/proftpd/files/patch-ai | 11 -------
ftp/proftpd/files/patch-aj | 11 -------
ftp/proftpd/files/patch-configure | 12 ++++++++
ftp/proftpd/files/patch-doc::Configuration.html | 18 +++++++++++
ftp/proftpd/files/patch-module::mod_auth_pam.c | 11 +++++++
ftp/proftpd/files/patch-pam | 41 -------------------------
ftp/proftpd/pkg-plist | 1 +
11 files changed, 79 insertions(+), 103 deletions(-)
delete mode 100644 ftp/proftpd/files/patch-ai
delete mode 100644 ftp/proftpd/files/patch-aj
create mode 100644 ftp/proftpd/files/patch-configure
create mode 100644 ftp/proftpd/files/patch-doc::Configuration.html
create mode 100644 ftp/proftpd/files/patch-module::mod_auth_pam.c
delete mode 100644 ftp/proftpd/files/patch-pam
(limited to 'ftp/proftpd')
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index d439d9f115ef..5cfb9b310c20 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -6,24 +6,26 @@
#
PORTNAME= proftpd
-PORTVERSION= 1.2.6
+PORTVERSION= 1.2.8
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.net/distrib/source/ \
ftp://ftp.stikman.com/pub/proftpd/source/ \
ftp://ftp.dataguard.no/pub/proftpd/distrib/source/ \
ftp://ftp.club-internet.fr/pub/mirrors/ftp.proftpd.org/distrib/source/
-DISTNAME= ${PORTNAME}-1.2.6
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= mharo@FreeBSD.org
COMMENT= Highly configurable ftp daemon
-MAN1= ftpcount.1 ftpwho.1
+MAN1= ftpcount.1 ftpwho.1 ftptop.1
MAN5= xferlog.5
MAN8= proftpd.8 ftpshut.8
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_BZIP2= YES
+USE_BZIP2= yes
+# WANT_AUTOCONF_VER=213
+# USE_AUTOCONF= yes
CONFIGURE_ARGS= --localstatedir=/var/run \
--disable-sendfile
@@ -60,7 +62,7 @@ LIBDIRS:=${LIBDIRS}:${PREFIX}/lib/mysql
POSTGRESQL_PORT?= databases/postgresql7
MODULES:=${MODULES}:mod_sql:mod_sql_postgres
LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include/pgsql
+INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
.endif
@@ -91,24 +93,26 @@ post-configure:
-e 's:/usr/bin:${PREFIX}/bin:' \
< ${WRKSRC}/src/proftpd.8.pre_sed > ${WRKSRC}/src/proftpd.8
- @${MV} ${WRKSRC}/src/ftpshut.8 ${WRKSRC}/src/ftpshut.8.pre_sed
+ @${MV} ${WRKSRC}/utils/ftpshut.8 ${WRKSRC}/utils/ftpshut.8.pre_sed
@${SED} -e 's:/usr/sbin:${PREFIX}/sbin:' \
-e 's:/etc:/var/run:' \
- < ${WRKSRC}/src/ftpshut.8.pre_sed > ${WRKSRC}/src/ftpshut.8
+ < ${WRKSRC}/utils/ftpshut.8.pre_sed > ${WRKSRC}/utils/ftpshut.8
- @${MV} ${WRKSRC}/src/ftpcount.1 ${WRKSRC}/src/ftpcount.1.pre_sed
+ @${MV} ${WRKSRC}/utils/ftpcount.1 ${WRKSRC}/utils/ftpcount.1.pre_sed
@${SED} -e 's:/usr/bin:${PREFIX}/bin:' \
- < ${WRKSRC}/src/ftpcount.1.pre_sed > ${WRKSRC}/src/ftpcount.1
+ < ${WRKSRC}/utils/ftpcount.1.pre_sed > ${WRKSRC}/utils/ftpcount.1
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ftpcount ${PREFIX}/bin/ftpcount
@${INSTALL_PROGRAM} ${WRKSRC}/ftpwho ${PREFIX}/bin/ftpwho
+ @${INSTALL_PROGRAM} ${WRKSRC}/ftptop ${PREFIX}/bin/ftptop
@${INSTALL_PROGRAM} ${WRKSRC}/proftpd ${PREFIX}/libexec/proftpd
@${INSTALL_PROGRAM} ${WRKSRC}/ftpshut ${PREFIX}/sbin/ftpshut
- @${INSTALL_MAN} ${WRKSRC}/src/ftpcount.1 ${PREFIX}/man/man1/ftpcount.1
- @${INSTALL_MAN} ${WRKSRC}/src/ftpwho.1 ${PREFIX}/man/man1/ftpwho.1
+ @${INSTALL_MAN} ${WRKSRC}/utils/ftpcount.1 ${PREFIX}/man/man1/ftpcount.1
+ @${INSTALL_MAN} ${WRKSRC}/utils/ftpwho.1 ${PREFIX}/man/man1/ftpwho.1
+ @${INSTALL_MAN} ${WRKSRC}/utils/ftptop.1 ${PREFIX}/man/man1/ftptop.1
@${INSTALL_MAN} ${WRKSRC}/src/xferlog.5 ${PREFIX}/man/man5/xferlog.5
- @${INSTALL_MAN} ${WRKSRC}/src/ftpshut.8 ${PREFIX}/man/man8/ftpshut.8
+ @${INSTALL_MAN} ${WRKSRC}/utils/ftpshut.8 ${PREFIX}/man/man8/ftpshut.8
@${INSTALL_MAN} ${WRKSRC}/src/proftpd.8 ${PREFIX}/man/man8/proftpd.8
@${INSTALL_DATA} \
${WRKSRC}/sample-configurations/basic.conf ${PREFIX}/etc/proftpd.conf.default
diff --git a/ftp/proftpd/distinfo b/ftp/proftpd/distinfo
index e18349be67dd..9ca3d2969b87 100644
--- a/ftp/proftpd/distinfo
+++ b/ftp/proftpd/distinfo
@@ -1 +1 @@
-MD5 (proftpd-1.2.6.tar.bz2) = 17551a5281a86fbc7857e31a723d5599
+MD5 (proftpd-1.2.8.tar.bz2) = 35e669cb085879eea21c6db9e7af2040
diff --git a/ftp/proftpd/files/patch-aa b/ftp/proftpd/files/patch-aa
index 0a2a1b785e2c..9b91108061d1 100644
--- a/ftp/proftpd/files/patch-aa
+++ b/ftp/proftpd/files/patch-aa
@@ -1,5 +1,5 @@
---- sample-configurations/basic.conf.old Sun Mar 4 15:08:09 2001
-+++ sample-configurations/basic.conf Sun Mar 4 15:13:29 2001
+--- ./sample-configurations/basic.conf.orig Tue Feb 18 03:16:20 2003
++++ ./sample-configurations/basic.conf Thu Mar 13 11:54:35 2003
@@ -1,3 +1,7 @@
+#
+# To have more informations about Proftpd configuration
@@ -8,14 +8,14 @@
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
-@@ -30,24 +34,36 @@
- AllowOverwrite on
-
+@@ -37,23 +41,29 @@
--# A basic anonymous configuration, no upload directories.
+ # A basic anonymous configuration, no upload directories. If you do not
+ # want anonymous users, simply delete this entire section.
-
- User ftp
- Group ftp
+-
- # We want clients to be able to login with "anonymous" as well as "ftp"
- UserAlias anonymous ftp
-
@@ -31,28 +31,23 @@
-
- DenyAll
-
+-
+#########################################################################
+# #
+# Uncomment lines with only one # to allow basic anonymous access #
+# #
+#########################################################################
-+### A basic anonymous configuration, no upload directories.
-+#
-+# User ftp
-+# Group ftp
++
++#
++# User ftp
++# Group ftp
++
+ ### We want clients to be able to login with "anonymous" as well as "ftp"
+ # UserAlias anonymous ftp
+
+ ### Limit the maximum number of anonymous logins
+ # MaxClients 10
+
-+ ### It is wise when making an 'ftp' user that you either block its
-+ ### ability to login either via /etc/login.access or my giving it
-+ ### an invalid shell.
-+ ### Uncomment this if the 'ftp' user you made has an invalid shell
-+
-+ # RequireValidShell off
-+
+ ### We want 'welcome.msg' displayed at login, and '.message' displayed
+ ### in each newly chdired directory.
+ # DisplayLogin welcome.msg
@@ -60,8 +55,6 @@
+
+ ### Limit WRITE everywhere in the anonymous chroot
+ #
-+ # DenyAll
++ # DenyAll
+ #
-
--
-+#
++#
diff --git a/ftp/proftpd/files/patch-ah b/ftp/proftpd/files/patch-ah
index 0de104b4408b..b859648d8cf3 100644
--- a/ftp/proftpd/files/patch-ah
+++ b/ftp/proftpd/files/patch-ah
@@ -1,9 +1,9 @@
---- modules/mod_unixpw.c.orig Thu Sep 30 20:33:47 1999
-+++ modules/mod_unixpw.c Sat Nov 13 13:15:26 1999
-@@ -42,6 +42,7 @@
- #include
- #endif
- #ifdef HAVE_PROT_H
+--- modules/mod_auth_unix.c.orig Thu Mar 13 14:00:00 2003
++++ modules/mod_auth_unix.c Thu Mar 13 14:04:45 2003
+@@ -58,6 +58,7 @@
+ #endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
+
+ #if defined(HAVE_PROT_H) || defined(COMSEC)
+#include
#include
#endif
diff --git a/ftp/proftpd/files/patch-ai b/ftp/proftpd/files/patch-ai
deleted file mode 100644
index 418c0c058178..000000000000
--- a/ftp/proftpd/files/patch-ai
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/mod_ratio.c.orig Sun Oct 20 13:49:21 2002
-+++ contrib/mod_ratio.c Sun Oct 20 13:50:11 2002
-@@ -606,7 +606,7 @@
- add_response(R_214,
- "Bytes: %s Down: %imb Up: %imb CR: %i Mbytes",
- stats.btext, (stats.bretr / 1024), (stats.bstor / 1024),
-- (stats.bytes / 1024), stats.bytes);
-+ (stats.bytes / 1024));
- return HANDLED(cmd);
- }
-
diff --git a/ftp/proftpd/files/patch-aj b/ftp/proftpd/files/patch-aj
deleted file mode 100644
index 36d670539f78..000000000000
--- a/ftp/proftpd/files/patch-aj
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/glibc-glob.h.orig Sun Oct 20 13:43:44 2002
-+++ include/glibc-glob.h Sun Oct 20 13:48:38 2002
-@@ -50,7 +50,7 @@
- #endif
-
- /* We need `size_t' for the following definitions. */
--#ifndef __size_t
-+#if !defined(__size_t) && !defined(__FreeBSD__)
- # if defined __GNUC__ && __GNUC__ >= 2
- typedef __SIZE_TYPE__ __size_t;
- # ifdef _XOPEN_SOURCE
diff --git a/ftp/proftpd/files/patch-configure b/ftp/proftpd/files/patch-configure
new file mode 100644
index 000000000000..cac88f2bf706
--- /dev/null
+++ b/ftp/proftpd/files/patch-configure
@@ -0,0 +1,12 @@
+--- ./configure.orig Fri Mar 14 18:19:10 2003
++++ ./configure Fri Mar 14 18:19:25 2003
+@@ -11202,8 +11202,8 @@
+ #if HAVE_NETDB_H
+ #include
+ #endif
+-#include
+ #include
++#include
+
+ int
+ main ()
diff --git a/ftp/proftpd/files/patch-doc::Configuration.html b/ftp/proftpd/files/patch-doc::Configuration.html
new file mode 100644
index 000000000000..400699d4f8f1
--- /dev/null
+++ b/ftp/proftpd/files/patch-doc::Configuration.html
@@ -0,0 +1,18 @@
+--- ./doc/Configuration.html.orig Wed Jan 29 12:27:24 2003
++++ ./doc/Configuration.html Sat Mar 15 11:34:14 2003
+@@ -4226,7 +4226,7 @@
+ >ftp
ftpd