From 084268b65b6a4ba8cd9a2c193b165516b7a70bfe Mon Sep 17 00:00:00 2001
From: eadler <eadler@FreeBSD.org>
Date: Thu, 28 Mar 2013 03:28:30 +0000
Subject: Mechanically convert unmaintained ports which use "gnomehack" to use
 "pathfix" instead.

---
 games/glife/Makefile             | 9 +++------
 games/gnmm/Makefile              | 9 +++------
 games/gno3dtet/Makefile          | 9 +++------
 games/gnomeattacks/Makefile      | 9 +++------
 games/gnomebreakout/Makefile     | 9 +++------
 games/gnomechess/Makefile        | 9 +++------
 games/gnomememoryblocks/Makefile | 9 +++------
 games/gnomermind/Makefile        | 9 +++------
 games/gnomesudoku/Makefile       | 9 +++------
 games/gretools/Makefile          | 3 ++-
 games/gtetrinet/Makefile         | 8 +++-----
 games/gtktetcolor/Makefile       | 9 +++------
 games/monkeybubble/Makefile      | 9 +++------
 games/mudmagic/Makefile          | 7 ++-----
 games/stepmania-devel/Makefile   | 3 ++-
 games/teg/Makefile               | 9 +++------
 games/wargus/Makefile            | 7 ++-----
 games/xpuyopuyo/Makefile         | 7 ++-----
 18 files changed, 49 insertions(+), 94 deletions(-)

(limited to 'games')

diff --git a/games/glife/Makefile b/games/glife/Makefile
index bbe8b81e2b4b..2934bc679223 100644
--- a/games/glife/Makefile
+++ b/games/glife/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	glife
-# Date created:				18th May 2000
-# Whom:					Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	glife
 PORTVERSION=	0.2.1
@@ -16,7 +12,8 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Conway's Game of Life for GNOME
 
 GNU_CONFIGURE=	yes
-USE_GNOME=	gnomeprefix gnomehack libglade
+USES=        pathfix
+USE_GNOME=	gnomeprefix libglade
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
 
diff --git a/games/gnmm/Makefile b/games/gnmm/Makefile
index 965be03fde11..9bda7a2b67a8 100644
--- a/games/gnmm/Makefile
+++ b/games/gnmm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnmm
-# Date created:				19 January 2003
-# Whom:					Simon Barner <barner@gmx.de>
-#
+# Created by: Simon Barner <barner@gmx.de>
 # $FreeBSD$
-#
 
 PORTNAME=	gnmm
 PORTVERSION=	0.1.2
@@ -18,7 +14,8 @@ COMMENT=	A "nine mens' morris" implementation for the GNOME Desktop Environment
 USE_GETTEXT=	yes
 USE_ICONV=	yes
 USE_GMAKE=	yes
-USE_GNOME=	gnomeprefix gnomehack gnomelibs gdkpixbuf
+USES=        pathfix
+USE_GNOME=	gnomeprefix gnomelibs gdkpixbuf
 
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS=	"--with-libiconv-prefix=${LOCALBASE}"
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 37a29625780a..f677ac57fe6a 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gno3dtet
-# Date created:		21 Dec 1999
-# Whom:			Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
 # $FreeBSD$
-#
 
 PORTNAME=	gno3dtet
 PORTVERSION=	1.96.1
@@ -17,7 +13,8 @@ COMMENT=	GNOME version of the classic 3D-ified T*tris
 
 EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
 
-USE_GNOME=	gnomehack gnomeprefix intlhack libgnomeui librsvg2
+USES=        pathfix
+USE_GNOME=	gnomeprefix intlhack libgnomeui librsvg2
 USE_GMAKE=	yes
 USE_AUTOTOOLS=	autoheader automake aclocal autoconf
 ACLOCAL_ARGS=	-I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
diff --git a/games/gnomeattacks/Makefile b/games/gnomeattacks/Makefile
index b844d391ac9d..0eff7267b2a3 100644
--- a/games/gnomeattacks/Makefile
+++ b/games/gnomeattacks/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnomeattacks
-# Date created:				01 July 2003
-# Whom:					Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomeattacks
 PORTVERSION=	0.3
@@ -16,7 +12,8 @@ COMMENT=	GNOME 2 game featuring a bizarre flying GNOME logo
 
 GNU_CONFIGURE=	yes
 USE_GMAKE=	yes
-USE_GNOME=	gnomehack gnomeprefix gnomevfs2 libgnomeui
+USES=        pathfix
+USE_GNOME=	gnomeprefix gnomevfs2 libgnomeui
 CONFIGURE_ENV=	LIBS="-L${LOCALBASE}/lib"
 CPPFLAGS+=	-I${LOCALBASE}/include
 
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index 6a68ed58f4cd..455e1a12ff6e 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnomebreakout
-# Date created:				01 Sep 2000
-# Whom:					Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomebreakout
 PORTVERSION=	0.5.3
@@ -15,7 +11,8 @@ DISTNAME=	gnome-breakout-${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	GNOME version of the classic breakout game
 
-USE_GNOME=	gnomehack gnomeprefix libgnomeui
+USES=        pathfix
+USE_GNOME=	gnomeprefix libgnomeui
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
diff --git a/games/gnomechess/Makefile b/games/gnomechess/Makefile
index cab50d6147ee..9d4c38934b71 100644
--- a/games/gnomechess/Makefile
+++ b/games/gnomechess/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnomechess
-# Date created:				29 January 2000
-# Whom:					Jeremy Lea <reg@shale.csir.co.za>
-#
+# Created by: Jeremy Lea <reg@shale.csir.co.za>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomechess
 PORTVERSION=	0.3.3
@@ -19,7 +15,8 @@ COMMENT=	A GUI chess front-end to crafy, for the GNOME Desktop Environment
 BUILD_DEPENDS=	crafty:${PORTSDIR}/games/crafty
 RUN_DEPENDS=	crafty:${PORTSDIR}/games/crafty
 
-USE_GNOME=	gnomecanvas gnomehack gnomeprefix libglade
+USES=        pathfix
+USE_GNOME=	gnomecanvas gnomeprefix libglade
 USE_GMAKE=	yes
 INSTALLS_OMF=	yes
 GNU_CONFIGURE=	yes
diff --git a/games/gnomememoryblocks/Makefile b/games/gnomememoryblocks/Makefile
index 3f1b44527ad6..7f0c57354127 100644
--- a/games/gnomememoryblocks/Makefile
+++ b/games/gnomememoryblocks/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnomememoryblocks
-# Date created:				10th July 2000
-# Whom:					Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomememoryblocks
 PORTVERSION=	0.2
@@ -16,7 +12,8 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Memory Blocks game for GNOME
 
 USE_GETTEXT=	yes
-USE_GNOME=	gnomeprefix gnomehack gnomelibs gdkpixbuf
+USES=        pathfix
+USE_GNOME=	gnomeprefix gnomelibs gdkpixbuf
 USE_AUTOTOOLS=	libtool
 GNU_CONFIGURE=	yes
 CONFIGURE_ENV=	LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gnomermind/Makefile b/games/gnomermind/Makefile
index 403bd794c407..485369571626 100644
--- a/games/gnomermind/Makefile
+++ b/games/gnomermind/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnomermind
-# Date created:				11 April 2001
-# Whom:					Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomermind
 PORTVERSION=	1.0.1
@@ -15,7 +11,8 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A puzzle game for Gnome, loosely based on the classic MasterMind game
 
 USE_BZIP2=	yes
-USE_GNOME=	gdkpixbuf gnomehack gnomelibs gnomeprefix
+USES=        pathfix
+USE_GNOME=	gdkpixbuf gnomelibs gnomeprefix
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
diff --git a/games/gnomesudoku/Makefile b/games/gnomesudoku/Makefile
index ebd70ab18992..7c1322bc0a60 100644
--- a/games/gnomesudoku/Makefile
+++ b/games/gnomesudoku/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gnome-sudoku
-# Date created:				2005-09-12
-# Whom:					Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gnomesudoku
 PORTVERSION=	0.6.0
@@ -28,7 +24,8 @@ MAKE_ENV+=	DISPLAY="localhost:1001"
 
 USE_PYTHON=	2.5+
 USE_PYDISTUTILS=yes
-USE_GNOME=	gnomehack gnomeprefix pygnome2 pygnomedesktop
+USES=        pathfix
+USE_GNOME=	gnomeprefix pygnome2 pygnomedesktop
 
 PYDISTUTILS_PKGNAME=	gnome-sudoku
 
diff --git a/games/gretools/Makefile b/games/gretools/Makefile
index 440f1c4e7d16..c84adb8c4205 100644
--- a/games/gretools/Makefile
+++ b/games/gretools/Makefile
@@ -13,7 +13,8 @@ COMMENT=	GNOME vocabulary builder
 
 LICENSE=	GPLv2
 
-USE_GNOME=	gnomehack gnomeprefix pygnome2
+USES=        pathfix
+USE_GNOME=	gnomeprefix pygnome2
 USE_PYTHON=	yes
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index b81e8d352648..fe8b0a0f5fdf 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for:	gtetrinet
-# Date created:				27 Feb 2000
-# Whom:					Dan Papasian <bugg@bugg.strangled.net>
-#
+# Created by: Dan Papasian <bugg@bugg.strangled.net>
 # $FreeBSD$
 
 PORTNAME=	gtetrinet
@@ -16,7 +13,8 @@ COMMENT=	Version of the popular TetriNET multiplayer Tetris clone
 
 USE_GETTEXT=	yes
 USE_BZIP2=	yes
-USE_GNOME=	esound gnomehack gnomeprefix libgnomeui
+USES=        pathfix
+USE_GNOME=	esound gnomeprefix libgnomeui
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/games/gtktetcolor/Makefile b/games/gtktetcolor/Makefile
index fbb97f2db29b..2ef9128f81c7 100644
--- a/games/gtktetcolor/Makefile
+++ b/games/gtktetcolor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	gtktetcolor
-# Date created:				17 August 2000
-# Whom:					Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	gtktetcolor
 PORTVERSION=	0.6.4
@@ -18,7 +14,8 @@ COMMENT=	Game for GNOME that resembles well-known Tetris and Columns
 LICENSE=	GPLv2 GPLv3
 LICENSE_COMB=	dual
 
-USE_GNOME=	gnomehack gnomeprefix intlhack libgnomeui
+USES=        pathfix
+USE_GNOME=	gnomeprefix intlhack libgnomeui
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
 MAKE_JOBS_SAFE=	yes
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 6de843b35a4f..4020cdd374fa 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	monkeybubble
-# Date created:				06 October 2003
-# Whom:					Adam Weinberger
-#
+# Created by: Adam Weinberger
 # $FreeBSD$
-#
 
 PORTNAME=	monkeybubble
 PORTVERSION=	0.4.0
@@ -15,7 +11,8 @@ DISTNAME=	monkey-bubble-${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	GTK2 Puzzle Bobble clone with monkeys
 
-USE_GNOME=	gnomedocutils gnomehack gnomeprefix intlhack \
+USES=        pathfix
+USE_GNOME=	gnomedocutils gnomeprefix intlhack \
 		librsvg2 libgnomeui
 USE_GSTREAMER=	yes
 USE_GMAKE=	yes
diff --git a/games/mudmagic/Makefile b/games/mudmagic/Makefile
index 29809379412b..6843289d2844 100644
--- a/games/mudmagic/Makefile
+++ b/games/mudmagic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	mudmagic
-# Date created:		2006-09-21
-# Whom:			trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
 # $FreeBSD$
-#
 
 PORTNAME=	mudmagic
 PORTVERSION=	1.9
@@ -20,6 +16,7 @@ LIB_DEPENDS=	curl.6:${PORTSDIR}/ftp/curl \
 		expat:${PORTSDIR}/textproc/expat2 \
 		sqlite3.8:${PORTSDIR}/databases/sqlite3
 
+USES=        pathfix
 USE_GNOME=	gtk20 libglade2 libxml2 gnomehack
 GNU_CONFIGURE=	yes
 USE_GMAKE=	yes
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 951290bbe8f7..480bbd2fec9f 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -28,7 +28,8 @@ PROJECTHOST=	sm-ssc
 USE_BZIP2=	yes
 USE_XORG=	x11 xau xdmcp xext xrandr xrender xtst
 USE_GL=		gl glu
-USE_GNOME=	gnomehack gtk20
+USES=        pathfix
+USE_GNOME=	gtk20
 USE_PERL5_BUILD=yes
 USE_ICONV=	yes
 GNU_CONFIGURE=	yes
diff --git a/games/teg/Makefile b/games/teg/Makefile
index acf6e00bf6ae..9bbadae4710f 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	teg
-# Date created:				31 October 2000
-# Whom:					Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	teg
 PORTVERSION=	0.11.2
@@ -14,7 +10,8 @@ MASTER_SITES=	SF
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A turn-based strategy game for GNOME
 
-USE_GNOME=	gnomehack gnomeprefix intlhack libgnomeui
+USES=        pathfix
+USE_GNOME=	gnomeprefix intlhack libgnomeui
 USE_GMAKE=	yes
 USE_AUTOTOOLS=	libtool
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 21b0ff117331..468afd265b8d 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	wargus
-# Date created:			1 Jul 2004
-# Whom:				Travis Poppe <tlp@liquidx.org>
-#
+# Created by: Travis Poppe <tlp@liquidx.org>
 # $FreeBSD$
-#
 
 PORTNAME=	wargus
 PORTVERSION=	2.2.5.5
@@ -22,6 +18,7 @@ RUN_DEPENDS=	stratagus:${PORTSDIR}/games/stratagus
 LICENSE=	GPLv2
 NOT_FOR_ARCHS=	sparc64
 USE_GMAKE=	yes
+USES=        pathfix
 USE_GNOME=	gtk20 gnomehack
 WRKSRC=		${WRKDIR}/${PORTNAME}-${PORTVERSION}
 SUB_FILES=	${PORTNAME} pkg-message
diff --git a/games/xpuyopuyo/Makefile b/games/xpuyopuyo/Makefile
index 390cac99eff7..df6154dd6d3f 100644
--- a/games/xpuyopuyo/Makefile
+++ b/games/xpuyopuyo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for:	xpuyopuyo
-# Date created:		19 Sep 1999
-# Whom:			Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
-#
+# Created by: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
 # $FreeBSD$
-#
 
 PORTNAME=	xpuyopuyo
 PORTVERSION=	0.9.8
@@ -34,6 +30,7 @@ CONFIGURE_ARGS+=--with-libmikmod-prefix=${LOCALBASE}
 .endif
 
 .if ${HAVE_GNOME:Mgnomelibs}!=""
+USES=        pathfix
 USE_GNOME+=	gnomelibs gnomehack
 PKGNAMESUFFIX=	-gnome
 .else
-- 
cgit