| Commit message (Collapse) | Author | Age | Files | Lines |
| |
|
|
|
|
| |
Trim headers
|
|
|
|
|
|
|
|
|
|
| |
I'm not sure if the submitter of ports/179224 didn't even test his patch or
if the distfile was re-rolled in a bizarre way.
Anyway, fix distfile and also cd into the correct directories to actually
build the port.
PR: ports/179790
|
| |
|
|
|
|
|
|
|
|
|
|
|
| |
. remove shlib ABI version from LIB_DEPENDS;
. introduce EXAMPLE option (do not install examples to DOCSDIR);
. bump PORTREVISION;
. get use of PLIST_FILES, PORTDOCS and PORTEXAMPLES at Makefile;
. get rid of pkg-plist;
. trim Makefile heades;
. remove acticle from COMMENT;
. simplify install commands.
|
|
|
|
|
|
|
|
| |
. introduce EXAMPLES option (do not install examples to DOCSDIR);
. bump PORTREVISION;
. make use of PLIST_FILES, PORTDOCS and PORTEXAMPLES at Makefile;
. get rid of pkg-plist;
. simpify install commands.
|
|
|
|
|
|
|
|
|
|
|
| |
. mute mdir commands and unmute install commands;
. do not use mkdir for parent directories (mkdir implies "-p");
. introduce EXAMPLE option (do not install examples to DOCSDIR);
. bump PORTREVISION;
. make use of PLIST_FILES, PORTDOCS and PORTEXAMPLES at Makefile;
. get rid of pkg-plist;
. use standard DOCSDIR and EXAMPLESDIR (instead of a PREFIX/foo/bar path);
. trim Makefile headers.
|
|
|
|
|
|
|
|
| |
. pet portlint: use {} instaed of () at variable;
. use PLIST_FILES, PORTDATA and PORTDOCS at Makefile;
. get rid of pkg-plist;
. remove article from COMMENT;
. trim Makefile headers.
|
|
|
|
|
|
|
|
|
| |
. mute mkdir;
. use PLIST_FILES and PORTDOCS at Makefile;
. remove pkg-plist;
. trim Makefile headers;
. remove article from COMMENT;
. pet portlint -- use opne space after WWW: at pkg-descr.
|
| |
|
|
|
|
|
|
| |
. use PORTDOCS at Makefile (thus simplify pkg-plist);
. use plain install instead of a .for loop;
. trim Makefile headers.
|
|
|
|
|
|
| |
. use PLIST_FILES, PORTDATA and PORTDOCS;
. use standard DATADIR and DOCSDIR (rather PREFIX/foo/bar);
. remove pkg-plist.
|
|
|
|
| |
. trim Makefile headers.
|
|
|
|
|
|
| |
. bump PORTREVISION;
. NOPORTDOCS -> PORT_OPTIONS:MDOCS;
. trim Makefile headers.
|
|
|
|
|
|
|
|
| |
. use f instead of file for a variable (portlint warns against file);
. do not mute install commands;
. remove article from COMMENT;
. trim Makefile headers;
. pet portlint: use one space after WWW: at pkg-descr.
|
| |
|
|
|
|
|
|
|
| |
. use PORTDOCS and PORTDATA at makefile;
. mute mkdirs;
. add padding to PKGMESSAGE;
. remove article from COMMENT.
|
|
|
|
|
| |
. use PORTEXAMPLES at Makefile;
. trim Makefile headers.
|
|
|
|
|
|
| |
. bump PORTREVISION;
. trim article from COMMENT;
. trim Makefile headers.
|
|
|
|
| |
. bump PORTREVISION.
|
|
|
|
| |
. remove the indefinite article from COMMENT.
|
|
|
|
|
| |
. use PLIST_FILES and PORTDOCS;
. remove pkg-plist (4 lines).
|
|
|
|
|
| |
. remove LICENSE_FILE for a standard license (GPLv2);
. trim Makefile headers.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
===================================================================
--- Makefile (revision 321238)
+++ Makefile (working copy)
@@ -1,9 +1,5 @@
-# New ports collection makefile for: seqio
-# Date created: 17 August 2001
-# Whom: Tony Maher
-#
+# Created by: Tony Maher
# $FreeBSD$
-#
PORTNAME= seqio
PORTVERSION= 1.2.2
@@ -13,38 +9,32 @@
DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A set of C functions which can read/write biological sequence files
+COMMENT= Set of C functions which can read/write biological sequence files
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
EXAMPLES= example1.c example2.c example3.c example4.c seqio.c \
seqio.h Makefile
PROGRAMS= fmtseq grepseq idxseq typeseq wcseq
+PLIST_FILES+= ${PROGRAMS:S,^,bin/,}
+PORTEXAMPLES= *
+PORTDOCS= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
do-install:
- cd ${WRKSRC}; \
- for file in ${PROGRAMS}; do \
- ${INSTALL_PROGRAM} $$file ${PREFIX}/bin; \
- done
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}; \
- for file in ${EXAMPLES}; do \
- ${INSTALL_DATA} $$file ${EXAMPLESDIR}; \
- done
+ ${INSTALL_PROGRAM} ${PROGRAMS:S,^,${WRKSRC}/,} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR}/html
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/bioseq.txt ${DOCSDIR}
- cd ${WRKSRC}/doc; \
- for file in *.doc; do \
- ${INSTALL_DATA} $$file ${DOCSDIR}; \
- done
- cd ${WRKSRC}/html; \
- for file in *.html; do \
- ${INSTALL_DATA} $$file ${DOCSDIR}/html; \
- done
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.doc ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/html/*.html ${DOCSDIR}/html
.endif
.include <bsd.port.mk>
|
|
|
|
|
|
|
|
| |
. use PLIST_FILES and PORTDOCS;
. get rid of pkg-plist;
. pet portlint: use one space after WWW: at pkg-descr;
. trim Makefile headers;
. remove the indefinite article from COMMENT.
|
|
|
|
|
|
|
|
| |
- Remove depend on DB_File.pm since it part of perl distribution
PR: ports/178877
Submitted by: az
Approved by: matainer (timeout)
|
|
|
|
|
| |
PR: 179224
Submitted by: Ports Fury
|
|
|
|
|
| |
PR: 179215
Submitted by: Ports Fury
|
| |
|
|
|
|
|
| |
PR: 179061
Submitted by: Ports Fury
|
|
|
|
|
|
| |
- Trim Makefile headers
- Convert to optionsNG
- Update WWW, MASTER_SITES and COMMENT
|
|
|
|
|
| |
PR: 178590
Submitted by: Ports Fury
|
|
|
|
| |
Convert USE_READLINE by USES=readline
|
| |
|
|
|
|
|
|
|
|
|
| |
- Improve COMMENT (remove leading article, add missing space)
- Remove unneeded BSD license file
- Trim Makefile's header
- Pet portlint (move LICENSE section earlier, change tab to space in WWW link)
Changes: http://sourceforge.net/p/staden/news/2013/03/iolib-1130-released/
|
|
|
|
|
| |
PR: ports/171932
Reported by: Jinsong Zhao <jszhao yeah net>
|
|
|
|
|
| |
PR: 178031
Submitted by: Ports Fury
|
| |
|
|
|
|
|
|
| |
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig while here
Reviewed by: bapt, kwm
|
| |
|
|
|
|
|
| |
PR: 178032
Submitted by: Ports Fury
|
|
|
|
| |
Approved by: wen (maintainer, implicit)
|
|
|
|
| |
Approved by: portmgr (bapt)
|
| |
|
|
|
|
|
| |
- Fix COMMENT
- Trim header
|
|
|
|
|
| |
PR: 177257
Submitted by: Ports Fury
|
|
|
|
| |
Reported by: pointyhat http://pointyhat.freebsd.org/errorlogs/i386-errorlogs/a.8.20130324140101.pointyhat/dotter-20021204.log
|
|
|
|
|
| |
PR: 177261
Submitted by: ports fury
|
|
|
|
|
|
|
| |
- while here clean up some ports from CMAKE_VERBOSE, which is intended
for users
Approved by: portmgr (miwi)
|
|
|
|
| |
Obtained from: miwi@
|
|
|
|
|
|
|
| |
- trim historical header
- tighten COMMENT
Approved by: portmgr (miwi)
|
|
|
|
|
| |
2: bump revision.
3: document UPDATING.
|
|
|
|
|
|
| |
- trim historical header
Approved by: portmgr (miwi)
|
|
|
|
|
|
|
|
| |
- trim historical header
- fix mixture of DOCS/EXAMPLES -> EXAMPLES
- add shared description for GLUT to bodm
Approved by: portmgr (miwi)
|
|
|
|
|
|
|
| |
- trim historical header
- tighten COMMENT
Approved by: portmgr (miwi)
|
|
|
|
|
|
|
| |
- trim historical header
- use tabs in favor of spaces
Approved by: portmgr (miwi)
|
|
|
|
|
| |
PR: 176544
Submitted by: Ports Fury
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
It brings bison as a build dependency in case it is set the following way:
USES= bison or USES= bison:build
it brings bison as a run dependency in case it is set the following way:
USES= bison:run
it brings bison both as a run and build dependency in case it the set the following way:
USES= bison:both
While here trim some headers
Convert some USE_GNOME= gnomehack to USES= pathfix
|
|
|
|
| |
While here pet Makefile headers.
|
| |
|
| |
|
|
|
|
|
| |
PR: 176552
Submitted by: Ports Fury
|
|
|
|
| |
Reported by: QAT
|
|
|
|
|
| |
PR: ports/173387
Submitted by: Hannes Hauswedell
|
|
|
|
|
|
|
| |
- Capitalize names (Perl) in COMMENT
PR: ports/176003 [1]
Submitted by: Gea-Suan Lin <gslin@gslin.org>
|
| |
|
|
|
|
|
| |
PR: 175034
Submitted by: Ports Fury
|
|
|
|
| |
- Changelog: http://cpansearch.perl.org/src/TFRAYNER/Bio-MAGETAB-1.27/Changes
|
|
|
|
|
| |
PR: ports/175014
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
|
|
|
|
|
| |
Submitted by: trevor
With hat: portmgr
|
|
|
|
| |
- Changelog: http://cpansearch.perl.org/src/LDS/Bio-Graphics-2.32/Changes
|
| |
|
|
|
|
|
| |
PR: ports/172499
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
|
|
|
|
|
|
|
|
|
|
| |
* rephrase Comment field or use port ${COMMENT} if appropriate
* adjust Icon field according to the Desktop Entry Specification
* update Categories field: remove deprecated category Application;
set main category, if missing
- Remove indefinite article and/or rephrase COMMENT
- Trim Makefile header
- Other minor changes
|
|
|
|
| |
Approved by: pav (previous maintainer)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
project, and some cleanups:
- use optionsNG
- update commands in pkg-install.in
- improve %%AMD64%% comment handling
- convert Makefile header
- remove unused variable SIMAP_URL
Bump PORTREVISION
PR: ports/174748
Submitted by: myself
Approved by: maintainer (pav@)
|
|
|
|
| |
lang/perl5.8 and lang/5.10 will be removed from ports tree soon.
|
|
|
|
| |
Changes: http://cpansearch.perl.org/src/RBUELS/Bio-GFF3-1.5/Changes
|
| |
|
|
|
|
| |
- Trim Makefile header
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
- Update openbabel to 2.3.2
- Switch to CMake build system
- Add PYTHON and CAIRO options
- Don't rename babel binary, mark conflict with ancient biology/babel
science/py-openbabel:
- Merge py-openbabel to openbabel
other:
- chase openbabel update
|
|
|
|
|
|
|
| |
instead given that jar files are just zip files, remove hardcoded do extract
target.
Reported by: linimon, matthew
|
|
|
|
| |
suppress any reference to JAVA_VERSION= 1.5+ (part2)
|
|
|
|
| |
suppress any reference to USE_JAVA= 1.5+ (part1)
|
|
|
|
|
|
|
|
|
| |
- Switch to PLIST_FILES
- Add option for GTK2 support
PR: ports/174174
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Feature safe: yes
|
|
|
|
|
|
| |
Changes: http://search.cpan.org/dist/Bio-Graphics/Changes
Feature safe: yes
|
|
|
|
|
| |
Reported by: portscout
Feature safe: yes
|
|
|
|
| |
Feature safe: yes
|
|
|
|
|
|
|
|
|
|
|
| |
- Add MAKE_JOBS_SAFE
- Convert to optionsng
- Trim Makefile header
PR: ports/171971
Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com>
Approved by: beat (mentor)
Feature safe: yes
|
|
|
|
|
|
|
|
|
|
| |
- Add MAKE_JOBS_UNSAFE
- Convert to optionsng
PR: ports/171970
Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com>
Approved by: beat (mentor)
Feature safe: yes
|
|
|
|
|
|
|
|
|
|
|
| |
2012-11-26 benchmarks/xengine: No more public distfiles
2012-11-26 biology/belvu: No more public distfiles
2012-11-26 multimedia/kaffeine-mozilla: No more public distfiles
2012-11-26 www/gnustep-ticker: Abandonware
2012-11-26 net/tryst-examples: Abandonware
2012-11-26 net/tryst: Abandonware
Feature safe: yes
|
|
|
|
|
|
|
|
|
| |
- Update pkg-descr
PR: 172497
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Feature safe: yes
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
- Mark MAKE_JOBS_SAFE
- Make dependency on print/pdflib optional
- Switch to PLIST_FILES
While here:
- Add missing deps
- Add desktop entry
PR: ports/172498
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Feature safe: yes
|
|
|
|
|
|
| |
PR: ports/172218
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Feature safe: yes
|
|
|
|
| |
Feature safe: yes
|
|
|
|
|
|
|
| |
Changes: http://cpansearch.perl.org/src/RBUELS/Bio-GFF3-1.4/Changes
- Trim Makefile headers
Feature safe: yes
|
|
|
|
|
|
| |
- Reset maintainer to perl@
Feature safe: yes
|
|
|
|
|
|
|
| |
public distfiles are available, or for which are -devel version with a more
recent stable version for long
Feature safe: yes
|
|
|
|
|
|
|
|
|
|
| |
2012-10-20 chinese/stardict-dict-zh_TW: No more public distfiles
2012-10-20 chinese/stardict-dict-zh_CN: No more public distfiles
2012-10-20 chinese/mingunittf: No more public distfiles
2012-10-20 chinese/dfsongsd: No more public distfiles
2012-10-20 biology/dna-qc: No more public distfiles
Feature safe: yes
|
|
|
|
|
|
| |
Changes: http://cpansearch.perl.org/src/TFRAYNER/Bio-MAGETAB-1.26/Changes
Feature safe: yes
|
|
|
|
| |
Feature safe: yes
|
|
|
|
| |
- Trim Makefile headers
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
| |
PLINK is a free, open-source whole genome association analysis toolset.
PLINK/SEQ is an open-source C/C++ library for working with human
genetic variation data.
PR: ports/171918 [1]
PR: ports/171922 [2]
Submitted by: Jason Bacon <jwbacon at tds.net>
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
while here:
- convert Makefile header into two-line format
- update COMMENT (indefinite article removed)
- change USE_PYTHON to just -2.7
- remove py-reportlab from BUILD_DEPENDS and kick PYTHON_SITELIBDIR from there
- tab -> space change in pkg-descr:WWW
PR: 171115
Submitted by: wen
Approved by: Mauricio Herrera Cuadra <mauricio at arareko dot net> (maintainer)
|
| |
|
|
|
|
|
| |
- Mute MKDIRs, remove trailing dot from RESTRICTED, drop leading indefinite
article from COMMENT where appropriate
|
| |
|
|
|
|
| |
distilator
|
|
|
|
|
|
| |
available on sparc64.
Hat: portmgr
|
| |
|
|
|
|
|
| |
PR: ports/169920
Approved by: Fernan Aguero <fernan@iib.unsam.edu.ar> (maintainer)
|
|
|
|
|
|
| |
PR: ports/169920
Submitted by: "Reed A. Cartwright" <cartwright@asu.edu>
Approved by: maintainer (timeout, 21 days)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
developed in years and has been dropped from the MESA 8.0 distribution.
Freeglut is a rewrite of glut and is actively developed and is used by
many linux distributions instead of libglut.
Bump all ports that directly depend on libglut because of the shlib version
change.
There are some extra items in this patch.
*) Because freeglut doesn't have the same dependancies as libglut, some ports
need extra dependencies added to USE_XORG to make them build.
*) Mark graphics/f90gl broken, f90gl depends on a header that is only shipped
with libglut.
*) Remove option for libglut/freeglut selection in games/cake, only freeglut
remains now.
*) While here fix a png related build issue games/vegastrike.
Thanks to miwi for running the exp-run.
Approved by: portmgr (miwi)
Collaboration with: zeising@
Obtained from: xorg-dev staging area.
|
|
|
|
| |
Approved by: portmgr@ (implicit)
|
| |
|
| |
|
|
|
|
| |
Approved by: maintainer
|
|
|
|
|
|
|
| |
- Add LICENSE
- Remove WRKSRC
Changes: http://search.cpan.org/dist/Bio-MAGETAB/Changes
|
|
|
|
| |
Approved by: portmgr@ (bapt@)
|
|
|
|
| |
Approved by: portmgr@ (bapt@)
|
| |
|
|
|
|
| |
The X11BASE variable is long gone, however these ports were not updated.
|
|
|
|
| |
Changes: http://search.cpan.org/dist/Bio-Graphics/Changes
|
|
|
|
|
|
|
|
|
|
|
| |
Remove file:
files/patch-Makefile.in
files/patch-configure
files/patch-src__control__defaults.h
pkg-plist
PR: ports/168994
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
|
|
|
|
|
| |
PR: ports/168993
Submitted by: KATO Tsuguru <tkato432@yahoo.com>
|
|
|
|
|
| |
- Add TEST_DEPENDS
- Sort PLIST
|
|
|
|
|
|
|
|
| |
RUN_DEPENDS=${BUILD_DEPENDS} to use := which portlint has warned
about for a while.
PR: ports/168208
Approved by: portmgr (miwi)
|
|
|
|
| |
Submitted by: maintainer via private email
|
|
|
|
|
|
|
|
|
|
|
| |
and data structures for the analysis of sequences with the
focus on biological data. The library is licensed under the
3-clause BSD license except the applications which are GPL.
WWW: http://www.seqan.de/
PR: 167571
Submitted by: Hannes <h2+fbsdports@fsfe.org>
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
| |
- Add BUILD_DEPENDS
|
|
|
|
| |
Changes: http://search.cpan.org/dist/Bio-GFF3/Changes
|
|
|
|
| |
ChangeLog: http://cpansearch.perl.org/src/LDS/Bio-Graphics-2.28/Changes
|
|
|
|
|
|
|
| |
- Add LICENSE (Artistic 1 & GPL 1)
- Add TEST_DEPENDS
Changes: http://search.cpan.org/dist/Bio-GFF3/Changes
|
| |
|
|
|
|
|
|
| |
- Reset maintainer to perl@
Feature safe: yes
|
|
|
|
|
|
|
|
|
| |
Note: devel/p5-B-Size and devel/p5-Devel-Arena
where intentionally not restored.
PR: ports/165605
Approved by: portmgr (bapt)
Feature safe: yes (I sure hope so)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200
- Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk
- Other minor cleanups
RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS}
PR: ports/165605
Submitted by: pgollucci (myself)
Approved by: portmgr (linimon)
Exp Run by: linimon
Tested by: make index
|
|
|
|
|
|
| |
PR: ports/165582
Submitted by: wen@ (myself)
Approved by: Mauricio Herrera Cuadra <mauricio@arareko.net> (maintainer, via email)
|
| |
|
| |
|
|
|
|
|
|
|
|
| |
- Add LICENSE
- Support PLIST_FILES
PR: 164985
Submitted by: Ports Fury
|
| |
|
|
|
|
|
|
| |
- Sort TEST_DEPENDS, MAN1, MAN3 and PLIST
Changes: http://search.cpan.org/dist/Bio-NEXUS/doc/changes.txt
|
|
|
|
| |
Changes: http://search.cpan.org/dist/Bio-Graphics/Changes
|
|
|
|
| |
Changes: http://search.cpan.org/dist/Bio-MAGETAB/Changes
|
| |
|
| |
|
|
|
|
|
|
| |
gcc: AdFrameworkFunctions.m: Objective-C compiler not installed on this system
Reported by: pointyhat
|
|
|
|
|
|
| |
PR: 163172
Submitted by: Jan Beich <jbeich@tormail.net>
Approved by: maintainer timeout
|
|
|
|
|
|
|
|
|
|
| |
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are
currently broken. This is a temporary measure until we organically stop using
:= or someone(s) spend a lot of time changing all the ports over.
Explicit duplication > := > = and this just moves ports one step to the left
Approved by: portmgr
|