ithub.com/freebsd/freebsd-ports-graphics)
aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ftrace
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-01-29 22:19:26 +0800
committersf <sf@FreeBSD.org>2001-01-29 22:19:26 +0800
commit96d84df982f0e650c070ea7f90a94be453680abc (patch)
tree414a3a30cd67a326758572cf72356e2333976ccd /sysutils/ftrace
parent58d053b0e2a17fe339192b1689b4b7ecd52229e8 (diff)
downloadfreebsd-ports-graphics-96d84df982f0e650c070ea7f90a94be453680abc.tar.gz
freebsd-ports-graphics-96d84df982f0e650c070ea7f90a94be453680abc.tar.zst
freebsd-ports-graphics-96d84df982f0e650c070ea7f90a94be453680abc.zip
update to 0.9a.
PR: 24229 Submitted by: maintainer honor CFLAGS.
Diffstat (limited to 'sysutils/ftrace')
-rw-r--r--sysutils/ftrace/Makefile4
-rw-r--r--sysutils/ftrace/distinfo2
-rw-r--r--sysutils/ftrace/files/patch-aa29
-rw-r--r--sysutils/ftrace/files/patch-ab19
-rw-r--r--sysutils/ftrace/files/patch-ac32
-rw-r--r--sysutils/ftrace/pkg-plist5
6 files changed, 67 insertions, 24 deletions
diff --git a/sysutils/ftrace/Makefile b/sysutils/ftrace/Makefile
index 79713b2e8ac..af0c57e391c 100644
--- a/sysutils/ftrace/Makefile
+++ b/sysutils/ftrace/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ftrace
-PORTVERSION= 0.9
+PORTVERSION= 0.9a
CATEGORIES= sysutils
MASTER_SITES= http://software.senko.net/pub/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,4 +15,6 @@ MAINTAINER= greid@ukug.uk.freebsd.org
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+GNU_CONFIGURE= yes
+
.include <bsd.port.mk>
diff --git a/sysutils/ftrace/distinfo b/sysutils/ftrace/distinfo
index 471230eeee4..409d431d697 100644
--- a/sysutils/ftrace/distinfo
+++ b/sysutils/ftrace/distinfo
@@ -1 +1 @@
-MD5 (ftrace_0.9.tar.gz) = b2a479f2eec86ec24fd02a6723afe303
+MD5 (ftrace_0.9a.tar.gz) = 850a9344b87d94a3d52c46479591b9c8
diff --git a/sysutils/ftrace/files/patch-aa b/sysutils/ftrace/files/patch-aa
index fac013c8970..89a58b951fb 100644
--- a/sysutils/ftrace/files/patch-aa
+++ b/sysutils/ftrace/files/patch-aa
@@ -1,16 +1,15 @@
---- Makefile.orig Fri Jan 5 18:40:20 2001
-+++ Makefile Sat Jan 6 14:11:10 2001
-@@ -1,11 +1,10 @@
--PREFIX = /usr/local
- BINDIR = $(PREFIX)/bin
- LIBDIR = $(PREFIX)/lib
+--- configure.orig Wed Jan 10 17:34:44 2001
++++ configure Wed Jan 10 17:35:26 2001
+@@ -632,6 +632,12 @@
+ program_prefix=${target_alias}-
- CC = gcc
- LD = ld
--CFLAGS = -Wall -O3 -DPIC -fPIC -D_REENTRANT
--LDFLAGS = -shared -ldl
-+CFLAGS += -Wall -O3 -DPIC -fPIC -D_REENTRANT
-+LDFLAGS = -shared
- OBJS = ftrace.o
-
- .PHONY: all clean install
+ case "$host" in
++ *-freebsd*)
++ cat >> confdefs.h <<\EOF
++#define LINUX_GLIBC 1
++EOF
++ LDSHARED=-shared
++ ;;
+ *-linux*)
+ cat >> confdefs.h <<\EOF
+ #define LINUX_GLIBC 1
diff --git a/sysutils/ftrace/files/patch-ab b/sysutils/ftrace/files/patch-ab
index 39ce06b0fba..bc7ca2b3e1f 100644
--- a/sysutils/ftrace/files/patch-ab
+++ b/sysutils/ftrace/files/patch-ab
@@ -1,8 +1,13 @@
---- ftrace.orig Sat Jan 6 14:11:37 2001
-+++ ftrace Sat Jan 6 14:11:24 2001
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
+--- ftrace.c.orig Wed Jan 10 17:38:16 2001
++++ ftrace.c Wed Jan 10 17:36:28 2001
+@@ -10,9 +10,10 @@
+ #include <errno.h>
+ #include <unistd.h>
+ #include <string.h>
++#include <sys/types.h>
- if [ "$1" = "-i" ]; then
- export FTRACEIGNOREME=1
+ #ifdef LINUX_GLIBC
+-typedef __off64_t off64_t;
++typedef off_t off64_t;
+ #define _GNU_SOURCE
+ #endif /* LINUX_GLIBC */
diff --git a/sysutils/ftrace/files/patch-ac b/sysutils/ftrace/files/patch-ac
new file mode 100644