From 3ad75a4581c2f69fb2331ab72fee36ff8af166ba Mon Sep 17 00:00:00 2001
From: ade <ade@FreeBSD.org>
Date: Wed, 15 Sep 2010 18:35:24 +0000
Subject: Autotools update.   Read ports/UPDATING 20100915 for details.

Approved by:	portmgr (for Mk/bsd.port.mk part)
Tested by:	Multiple -exp runs
---
 lang/php52/Makefile                       | 7 ++++++-
 lang/php52/files/patch-scripts::phpize.in | 4 ++--
 2 files changed, 8 insertions(+), 3 deletions(-)

(limited to 'lang/php52')

diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index d26d65b89b2a..c8e651f6b948 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -7,6 +7,7 @@
 
 PORTNAME=	php52
 PORTVERSION=	5.2.14
+PORTREVISION=	1
 CATEGORIES?=	lang devel www
 MASTER_SITES=	${MASTER_SITE_PHP}
 MASTER_SITE_SUBDIR=	distributions
@@ -20,7 +21,7 @@ LATEST_LINK=	${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
 USE_BZIP2=	yes
 MAKE_JOBS_SAFE=	yes
 .if !defined(PKGNAMESUFFIX)
-USE_AUTOTOOLS=	autoconf:262
+USE_AUTOTOOLS=	autoconf:267
 
 CONFIGURE_ARGS=	\
 		--with-layout=GNU \
@@ -189,7 +190,11 @@ post-patch:
 		${WRKSRC}/sapi/cgi/config9.m4
 .endif
 
+# Work around issues with newer (>=2.64) autoconf
 pre-configure:
+	@${REINPLACE_CMD} -E 's:^((m4_)?divert)[(]([0-9]*)[)]:\1(600\3):' \
+		${WRKSRC}/configure.in `${FIND} ${WRKSRC} -name '*.m4'`
+	@${RM} ${WRKSRC}/configure
 	@${CAT} ${WRKSRC}/acinclude.m4 ${WRKSRC}/build/libtool.m4 > ${WRKSRC}/aclocal.m4
 
 post-build:
diff --git a/lang/php52/files/patch-scripts::phpize.in b/lang/php52/files/patch-scripts::phpize.in
index 8d3afdbecc08..bbac86ce30ef 100644
--- a/lang/php52/files/patch-scripts::phpize.in
+++ b/lang/php52/files/patch-scripts::phpize.in
@@ -6,8 +6,8 @@
  {
 -  test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf
 -  test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader
-+  test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.62
-+  test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.62
++  test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.67
++  test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.67
    
    if test ! -x "`$php_shtool path $PHP_AUTOCONF`"; then
      cat <<EOF
-- 
cgit