From 79c3ac81e82fba101ce34956c5de634b8ed032d0 Mon Sep 17 00:00:00 2001
From: mat <mat@FreeBSD.org>
Date: Mon, 9 Jul 2018 08:40:17 +0000
Subject: Remove all := from BUILD_DEPENDS, here are never needed.

While there, cleanup, and sort depends.

When build and run dependencies are the same, there are three ways to
avoid duplicating the list while not adding the framework added
BUILD_DEPENDS to the RUN_DEPENDS.  In order of preference, they are:

1) use RUN_DEPENDS to set BUILD_DEPENDS:

BUILD_DEPENDS=	${RUN_DEPENDS}
RUN_DEPENDS=	foo:bar/baz

2) create another variable and use it:

MY_DEPENDS= foo:bar/baz
BUILD_DEPENDS=	${MY_DEPENDS}
RUN_DEPENDS=	${MY_DEPENDS}

3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation:

BUILD_DEPENDS=	foo:bar/baz
RUN_DEPENDS:=	${BUILD_DEPENDS}

Sponsored by:	Absolight
---
 lang/p5-Pugs-Compiler-Rule/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'lang')

diff --git a/lang/p5-Pugs-Compiler-Rule/Makefile b/lang/p5-Pugs-Compiler-Rule/Makefile
index 4fb88b4130d1..83e15aa62033 100644
--- a/lang/p5-Pugs-Compiler-Rule/Makefile
+++ b/lang/p5-Pugs-Compiler-Rule/Makefile
@@ -12,11 +12,11 @@ PKGNAMEPREFIX=	p5-
 MAINTAINER=	perl@FreeBSD.org
 COMMENT=	Compiler for Perl 6 Rules
 
+BUILD_DEPENDS=	${RUN_DEPENDS}
 RUN_DEPENDS=	p5-Cache-Cache>=1.05:devel/p5-Cache-Cache \
 		p5-PadWalker>=1.0:devel/p5-PadWalker \
 		p5-Parse-Yapp>=0:devel/p5-Parse-Yapp \
 		p5-YAML-Syck>=0.60:textproc/p5-YAML-Syck
-BUILD_DEPENDS:=	${RUN_DEPENDS}
 TEST_DEPENDS=	p5-File-Slurp>0:devel/p5-File-Slurp
 
 USES=		perl5
-- 
cgit