From 40457a44b3940f6711a7b98fbf3e17eb085ca54c Mon Sep 17 00:00:00 2001
From: sahil <sahil@FreeBSD.org>
Date: Mon, 17 May 2010 23:51:50 +0000
Subject: spmfilter-spamassassin is a plugin for spmfilter that enables
 spmfilter to spam-check emails with the help of the daemonized version of
 Spamassassin (spamd). The major goal of this plugin is to provide an easy way
 for spam-checking messages.

WWW: http://www.spmfilter.org/

PR:		ports/146161
Submitted by:	Axel Steiner <ast at treibsand.com>
Approved by:	wxs@ (mentor)
---
 mail/Makefile                         |  1 +
 mail/spmfilter-spamassassin/Makefile  | 47 +++++++++++++++++++++++++++++++++++
 mail/spmfilter-spamassassin/distinfo  |  3 +++
 mail/spmfilter-spamassassin/pkg-descr |  6 +++++
 mail/spmfilter-spamassassin/pkg-plist |  5 ++++
 5 files changed, 62 insertions(+)
 create mode 100644 mail/spmfilter-spamassassin/Makefile
 create mode 100644 mail/spmfilter-spamassassin/distinfo
 create mode 100644 mail/spmfilter-spamassassin/pkg-descr
 create mode 100644 mail/spmfilter-spamassassin/pkg-plist

(limited to 'mail')

diff --git a/mail/Makefile b/mail/Makefile
index 2da1970783f4..766b89cfe44f 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -646,6 +646,7 @@
     SUBDIR += spamstats
     SUBDIR += spfval
     SUBDIR += spmfilter
+    SUBDIR += spmfilter-spamassassin
     SUBDIR += spruce
     SUBDIR += sqlgrey
     SUBDIR += squirrelmail
diff --git a/mail/spmfilter-spamassassin/Makefile b/mail/spmfilter-spamassassin/Makefile
new file mode 100644
index 000000000000..bf72169765e5
--- /dev/null
+++ b/mail/spmfilter-spamassassin/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for:	spmfilter-spamassassin
+# Date created:				2010-04-29
+# Whom:					Axel Steiner <ast@treibsand.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	spmfilter-spamassassin
+PORTVERSION=	0.1
+CATEGORIES=	mail
+MASTER_SITES=	http://www.spmfilter.org/attachments/download/58/
+
+MAINTAINER=	ast@treibsand.com
+COMMENT=	Spamassassin plugin for spmfilter
+
+BUILD_DEPENDS=	spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+RUN_DEPENDS=	spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+
+USE_CMAKE=	yes
+CMAKE_ARGS+=	-DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
+		-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
+
+USE_LDCONFIG=	${PREFIX}/lib/spmfilter
+
+OPTIONS=	DEBUG	"Enable Debugging"	off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+CMAKE_USE_PTHREAD=	yes
+.endif
+
+.if defined(WITH_DEBUG)
+CMAKE_ARGS+=	-DENABLE_DEBUG=TRUE
+.endif
+
+MAN1=		${PORTNAME}.1 \
+		smf-spamq.1 \
+		smf-spamctl.1
+
+MANCOMPRESSED=	yes
+
+post-patch:
+	@${REINPLACE_CMD} -e 's|share/man|man|' \
+		${WRKSRC}/cmake/Modules/SMFMacros.cmake
+
+.include <bsd.port.post.mk>
diff --git a/mail/spmfilter-spamassassin/distinfo b/mail/spmfilter-spamassassin/distinfo
new file mode 100644
index 000000000000..eb371da9b111
--- /dev/null
+++ b/mail/spmfilter-spamassassin/distinfo
@@ -0,0 +1,3 @@
+MD5 (spmfilter-spamassassin-0.1.tar.gz) = 139e605703d9e6f7dfe767c8a17d81c6
+SHA256 (spmfilter-spamassassin-0.1.tar.gz) = 7e7053314e4b2efbad5a3f8493017769bfc6ed1ae727af5699ade677cd977e86
+SIZE (spmfilter-spamassassin-0.1.tar.gz) = 10384
diff --git a/mail/spmfilter-spamassassin/pkg-descr b/mail/spmfilter-spamassassin/pkg-descr
new file mode 100644
index 000000000000..9ad428041e5f
--- /dev/null
+++ b/mail/spmfilter-spamassassin/pkg-descr
@@ -0,0 +1,6 @@
+spmfilter-spamassassin is a plugin for spmfilter that enables spmfilter to 
+spam-check emails with the help of the daemonized version of Spamassassin 
+(spamd). The major goal of this plugin is to provide an easy way for 
+spam-checking messages.
+
+WWW: http://www.spmfilter.org/
diff --git a/mail/spmfilter-spamassassin/pkg-plist b/mail/spmfilter-spamassassin/pkg-plist
new file mode 100644
index 000000000000..7b490b2a2279
--- /dev/null
+++ b/mail/spmfilter-spamassassin/pkg-plist
@@ -0,0 +1,5 @@
+bin/smf-spamq
+bin/smf-spamctl
+lib/spmfilter/libspamassassin.so
+lib/spmfilter/libspamassassin.so.0.1
+@dirrmtry lib/spmfilter
-- 
cgit