From 9debac461b7729b783ca5a0f5e46461ddac07173 Mon Sep 17 00:00:00 2001
From: mat <mat@FreeBSD.org>
Date: Wed, 26 Nov 2014 13:08:24 +0000
Subject: Change the way Perl modules are installed, update the default Perl to
 5.18.

Before, we had:

  site_perl :           lib/perl5/site_perl/5.18
  site_perl/perl_arch : lib/perl5/site_perl/5.18/mach
  perl_man3 :           lib/perl5/5.18/man/man3

Now we have:

  site_perl : lib/perl5/site_perl
  site_arch : lib/perl5/site_perl/mach/5.18
  perl_man3 : lib/perl5/site_perl/man/man3

Modules without any .so will be installed at the same place regardless of the
Perl version, minimizing the upgrade when the major Perl version is changed.
It uses a version dependent directory for modules with compiled bits.

As PERL_ARCH is no longer needed in plists, it has been removed from
PLIST_SUB.

The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now
always removed, as is perllocal.pod.

The old site_perl and site_perl/arch directories have been kept in the
default Perl @INC for all Perl ports, and will be phased out as these old
Perl versions expire.

PR:		194969
Differential Revision:	https://reviews.freebsd.org/D1019
Exp-run by:	antoine
Reviewed by:	perl@
Approved by:	portmgr
---
 misc/p5-Bot-Training/Makefile  | 2 +-
 misc/p5-Bot-Training/pkg-plist | 5 -----
 2 files changed, 1 insertion(+), 6 deletions(-)

(limited to 'misc/p5-Bot-Training')

diff --git a/misc/p5-Bot-Training/Makefile b/misc/p5-Bot-Training/Makefile
index 8540434ce8bb..4d1e53a29d63 100644
--- a/misc/p5-Bot-Training/Makefile
+++ b/misc/p5-Bot-Training/Makefile
@@ -3,7 +3,7 @@
 
 PORTNAME=	Bot-Training
 PORTVERSION=	0.04
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	misc perl5
 MASTER_SITES=	CPAN
 MASTER_SITE_SUBDIR=	CPAN:AVAR
diff --git a/misc/p5-Bot-Training/pkg-plist b/misc/p5-Bot-Training/pkg-plist
index 7b0b7601bc88..b1107a75cade 100644
--- a/misc/p5-Bot-Training/pkg-plist
+++ b/misc/p5-Bot-Training/pkg-plist
@@ -1,10 +1,5 @@
 bin/bot-training
 %%SITE_PERL%%/Bot/Training.pm
 %%SITE_PERL%%/Bot/Training/Plugin.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot/Training/.packlist
 %%PERL5_MAN3%%/Bot::Training.3.gz
 man/man1/bot-training.1.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot/Training
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot
-@dirrmtry %%SITE_PERL%%/Bot/Training
-@dirrmtry %%SITE_PERL%%/Bot
-- 
cgit