From 9cf6e6e063d1a65e0c4e5b403dbcc8d913a6e3b7 Mon Sep 17 00:00:00 2001
From: nox <nox@FreeBSD.org>
Date: Thu, 3 Oct 2013 18:18:01 +0000
Subject: - Invoke configure seperately as gmake apparently no longer picks up 
  the generated config.mak properly otherwise, breaking the build again   with
 clang. - Fix passing of conditional configure args in the process. - Bump
 PORTREVISION.

---
 multimedia/vdr-plugin-xineliboutput/Makefile | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

(limited to 'multimedia')

diff --git a/multimedia/vdr-plugin-xineliboutput/Makefile b/multimedia/vdr-plugin-xineliboutput/Makefile
index 1ead04373c88..0d18859fa374 100644
--- a/multimedia/vdr-plugin-xineliboutput/Makefile
+++ b/multimedia/vdr-plugin-xineliboutput/Makefile
@@ -3,7 +3,7 @@
 
 PORTNAME=	vdr-plugin-xineliboutput
 PORTVERSION=	1.0.90s20120511
-PORTREVISION=	6
+PORTREVISION=	7
 CATEGORIES=	multimedia
 MASTER_SITES=	SF:release \
 		LOCAL:snapshot
@@ -30,27 +30,27 @@ WRKSRC=		${WRKDIR}/vdr-${PLUGIN}
 
 OPTIONS_DEFINE=	LIBBLURAY LIBEXTRACTOR
 
+HAS_CONFIGURE=	yes
 NO_STAGE=	yes
+
 .include	"${.CURDIR}/../vdr/Makefile.plugins"
 
 .include <bsd.port.pre.mk>
 
+CONFIGURE_ARGS+=	--cc="${CC}" --cxx="${CXX}" --add-cflags=-I$(VDRDIR)
+
 .if ${PORT_OPTIONS:MLIBEXTRACTOR}
 LIB_DEPENDS+=	extractor:${PORTSDIR}/textproc/libextractor
-CONFIGURE_OPTS+=	--enable-libextractor
 .else
-CONFIGURE_OPTS+=	--disable-libextractor
+CONFIGURE_ARGS+=	--disable-libextractor
 .endif
 
 .if ${PORT_OPTIONS:MLIBBLURAY}
-CONFIGURE_OPTS+=	--enable-libbluray
 LIB_DEPENDS+=	bluray:${PORTSDIR}/multimedia/libbluray
 .else
-CONFIGURE_OPTS+=	--disable-libbluray
+CONFIGURE_ARGS+=	--disable-libbluray
 .endif
 
-MAKE_ARGS+=	CONFIGURE_OPTS="${CONFIGURE_OPTS}"
-
 post-patch: post-patch-plugin
 # clang doesn't know -MG
 	${TOUCH} -t 200001010000 ${WRKSRC}/nosignal_720x576.c \
-- 
cgit