From a7982fad6986deaf5b858b468b4be6cc0b8dfea3 Mon Sep 17 00:00:00 2001
From: obrien <obrien@FreeBSD.org>
Date: Sat, 10 Jan 1998 18:31:24 +0000
Subject: Automatically handle more cases, change name of sample file.

---
 security/tcp_wrapper/Makefile                      |  7 ++-
 .../tcp_wrapper/files/inetd.conf.wrapped.sample    | 71 ++++++++++++++++++++++
 2 files changed, 76 insertions(+), 2 deletions(-)
 create mode 100644 security/tcp_wrapper/files/inetd.conf.wrapped.sample

(limited to 'security/tcp_wrapper')

diff --git a/security/tcp_wrapper/Makefile b/security/tcp_wrapper/Makefile
index 15e16a74bdb2..5971b7390f27 100644
--- a/security/tcp_wrapper/Makefile
+++ b/security/tcp_wrapper/Makefile
@@ -3,7 +3,7 @@
 # Date created:		27 Oct 1994
 # Whom:			torstenb
 #
-# $Id: Makefile,v 1.16 1997/07/04 19:54:25 ache Exp $
+# $Id: Makefile,v 1.17 1998/01/10 18:24:14 obrien Exp $
 #
 
 DISTNAME=       tcp_wrappers_7.6
@@ -24,8 +24,11 @@ post-install:
 
 update:
 	@cd ${FILESDIR} ; co -f $(CVSROOT)/src/etc/inetd.conf,v
-	@${SED} 's:/usr/libexec/[a-zA-Z]*:${PREFIX}/libexec/tcpd:g'  \
+	@${SED} -e 's:/usr/libexec/[a-zA-Z]*:${PREFIX}/libexec/tcpd:g'  \
+		-e 's:/usr/local/libexec/[a-zA-Z]*:${PREFIX}/libexec/tcpd:g'  \
+		-e 's:/usr/local/sbin/[a-zA-Z]*:${PREFIX}/libexec/tcpd:g'  \
 		< ${FILESDIR}/inetd.conf  > ${FILESDIR}/inetd.conf.wrapped.sample
 	@${RM} -f ${FILESDIR}/inetd.conf
+	@${ECHO} "Now manually fixup deamon paths from the /usr/local tree."
 
 .include <bsd.port.mk>
diff --git a/security/tcp_wrapper/files/inetd.conf.wrapped.sample b/security/tcp_wrapper/files/inetd.conf.wrapped.sample
new file mode 100644
index 000000000000..05068f037815
--- /dev/null
+++ b/security/tcp_wrapper/files/inetd.conf.wrapped.sample
@@ -0,0 +1,71 @@
+#
+# Internet server configuration database
+#
+#	@(#)inetd.conf	5.4 (Berkeley) 6/30/90
+#
+ftp	stream	tcp	nowait	root	/usr/local/libexec/tcpd	ftpd -l
+telnet	stream	tcp	nowait	root	/usr/local/libexec/tcpd	telnetd
+shell	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rshd
+login	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rlogind
+finger	stream	tcp	nowait	nobody	/usr/local/libexec/tcpd	fingerd -s
+#exec	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rexecd
+#uucpd	stream	tcp	nowait	root	/usr/local/libexec/tcpd	uucpd
+#nntp	stream	tcp	nowait	usenet	/usr/local/libexec/tcpd	nntpd
+comsat	dgram	udp	wait	root	/usr/local/libexec/tcpd	comsat
+ntalk	dgram	udp	wait	root	/usr/local/libexec/tcpd	ntalkd
+#tftp	dgram	udp	wait	nobody	/usr/local/libexec/tcpd	tftpd /tftpboot
+#bootps	dgram	udp	wait	root	/usr/local/libexec/tcpd	bootpd
+#
+# "Small servers" -- used to be standard on, but we're more conservative
+# about things due to Internet security concerns.  Only turn on what you
+# need.
+#
+#daytime stream	tcp	nowait	root	internal
+#daytime dgram	udp	wait	root	internal
+#time	stream	tcp	nowait	root	internal
+#time	 dgram	udp	wait	root	internal
+#echo	stream	tcp	nowait	root	internal
+#echo	dgram	udp	wait	root	internal
+#discard stream	tcp	nowait	root	internal
+#discard dgram	udp	wait	root	internal
+#chargen stream	tcp	nowait	root	internal
+#chargen dgram	udp	wait	root	internal
+#
+# Kerberos authenticated services
+#
+#klogin	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rlogind -k
+#eklogin stream	tcp	nowait	root	/usr/local/libexec/tcpd	rlogind -k -x
+#kshell	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rshd -k
+#rkinit	stream	tcp	nowait	root	/usr/local/libexec/tcpd	rkinitd
+#
+# Services run ONLY on the Kerberos server
+#
+#krbupdate stream tcp	nowait	root	/usr/local/libexec/tcpd	registerd
+#kpasswd   stream tcp	nowait	root	/usr/local/libexec/tcpd	kpasswdd
+#
+# RPC based services (you MUST have portmapper running to use these)
+#
+#rstatd/1-3	dgram rpc/udp wait root	/usr/local/libexec/tcpd.rstatd	 rpc.rstatd
+#rusersd/1-2	dgram rpc/udp wait root	/usr/local/libexec/tcpd.rusersd rpc.rusersd
+#walld/1	dgram rpc/udp wait root	/usr/local/libexec/tcpd.rwalld	 rpc.rwalld
+#pcnfsd/1-2	dgram rpc/udp wait root	/usr/local/libexec/tcpd.pcnfsd	 rpc.pcnfsd	
+#rquotad/1	dgram rpc/udp wait root	/usr/local/libexec/tcpd.rquotad rpc.rquotad
+#sprayd/1	dgram rpc/udp wait root	/usr/local/libexec/tcpd.sprayd	 rpc.sprayd
+#
+# example entry for the optional pop3 server
+#
+#pop3	stream	tcp	nowait	root	/usr/local/libexec/tcpd	/usr/local/libexec/popper
+#
+# example entry for the optional imap4 server
+#
+#imap4	stream	tcp	nowait	root	/usr/local/libexec/tcpd	/usr/local/libexec/imapd
+#
+# example entry for the optional ident server
+#
+#ident	stream	tcp	wait	root	/usr/local/libexec/tcpd	/usr/local/sbin/identd -w -t120
+#
+# Enable the following two entries to enable samba startup from inetd
+# (from the Samba documentation).
+#
+#netbios-ssn stream tcp nowait root /usr/local/libexec/tcpd /usr/local/sbin/smbd 
+#netbios-ns dgram udp wait root /usr/local/libexec/tcpd /usr/local/sbin/nmbd 
-- 
cgit