From 824d379041551b33bcb7cc714e2f68b33df6cc35 Mon Sep 17 00:00:00 2001
From: kevlo <kevlo@FreeBSD.org>
Date: Thu, 13 Jul 2000 15:12:38 +0000
Subject: Initial import of p5-GnuPG-Interface. p5-GnuPG-Interface is the Perl
 module for interfacing with GnuPG.

PR: 19801
Submitted by: Trevor Johnson <trevor@jpj.net>
---
 security/Makefile                       |  1 +
 security/p5-GnuPG-Interface/Makefile    | 38 +++++++++++++++++++++++++++++++++
 security/p5-GnuPG-Interface/distinfo    |  1 +
 security/p5-GnuPG-Interface/pkg-comment |  1 +
 security/p5-GnuPG-Interface/pkg-descr   |  4 ++++
 security/p5-GnuPG-Interface/pkg-plist   | 37 ++++++++++++++++++++++++++++++++
 6 files changed, 82 insertions(+)
 create mode 100644 security/p5-GnuPG-Interface/Makefile
 create mode 100644 security/p5-GnuPG-Interface/distinfo
 create mode 100644 security/p5-GnuPG-Interface/pkg-comment
 create mode 100644 security/p5-GnuPG-Interface/pkg-descr
 create mode 100644 security/p5-GnuPG-Interface/pkg-plist

(limited to 'security')

diff --git a/security/Makefile b/security/Makefile
index 8a53780dc83d..9cd3423a9540 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -61,6 +61,7 @@
     SUBDIR += p5-Crypt-DES
     SUBDIR += p5-Crypt-IDEA
     SUBDIR += p5-Digest-MD5
+    SUBDIR += p5-GnuPG-Interface
     SUBDIR += p5-MD5
     SUBDIR += p5-Net-SSLeay
     SUBDIR += p5-PGP
diff --git a/security/p5-GnuPG-Interface/Makefile b/security/p5-GnuPG-Interface/Makefile
new file mode 100644
index 000000000000..0cb8843aadeb
--- /dev/null
+++ b/security/p5-GnuPG-Interface/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for:   p5-GnuPG-Interface
+# Date created:                                2000-07-09
+# Whom:                                        Trevor Johnson <trevor@jpj.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	GnuPG-Interface
+PORTVERSION=    0.09
+CATEGORIES=	security perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	GnuPG
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	trevor@jpj.net
+
+RUN_DEPENDS=	gpg:${PORTSDIR}/security/gnupg \
+		${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+
+USE_PERL5=	yes
+
+MAN3=	GnuPG::Handles.3 \
+	GnuPG::SecretKey.3 \
+	GnuPG::Interface.3 \
+	GnuPG::Signature.3 \
+	GnuPG::SubKey.3 \
+	GnuPG::Fingerprint.3 \
+	GnuPG::PublicKey.3 \
+	GnuPG::Key.3 \
+	GnuPG::UserId.3 \
+	GnuPG::Options.3
+
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+	@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-GnuPG-Interface/distinfo b/security/p5-GnuPG-Interface/distinfo
new file mode 100644
index 000000000000..3363bc5500d6
--- /dev/null
+++ b/security/p5-GnuPG-Interface/distinfo
@@ -0,0 +1 @@
+MD5 (GnuPG-Interface-0.09.tar.gz) = 98f9543ae7f8320b9e2bd44c81abb6a5
diff --git a/security/p5-GnuPG-Interface/pkg-comment b/security/p5-GnuPG-Interface/pkg-comment
new file mode 100644
index 000000000000..3f2752309f70
--- /dev/null
+++ b/security/p5-GnuPG-Interface/pkg-comment
@@ -0,0 +1 @@
+Perl module for interfacing with GnuPG
diff --git a/security/p5-GnuPG-Interface/pkg-descr b/security/p5-GnuPG-Interface/pkg-descr
new file mode 100644
index 000000000000..5a7ea68f3260
--- /dev/null
+++ b/security/p5-GnuPG-Interface/pkg-descr
@@ -0,0 +1,4 @@
+This is a Perl module for interfacing with GnuPG.
+
+Trevor Johnson
+trevor@jpj.net
diff --git a/security/p5-GnuPG-Interface/pkg-plist b/security/p5-GnuPG-Interface/pkg-plist
new file mode 100644
index 000000000000..71133c76cdfe
--- /dev/null
+++ b/security/p5-GnuPG-Interface/pkg-plist
@@ -0,0 +1,37 @@
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Fingerprint.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Handles.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Interface.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Key.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Options.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/PublicKey.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/SecretKey.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Signature.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/SubKey.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/UserId.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/clearsign.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/decrypt.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/detach_sign.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/encrypt.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/encrypt_symmetrically.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/export_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/get_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/get_public_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/get_public_keys_with_sigs.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/get_secret_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/import_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/list_public_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/list_secret_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/list_sigs.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/recv_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/send_keys.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/sign.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/sign_and_encrypt.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/test_default_key_passphrase.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface/verify.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GnuPG/Interface/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/GnuPG
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG/Interface
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/GnuPG
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GnuPG/Interface
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GnuPG
-- 
cgit