From 5cc9328814fb9b8e64ff3588af7e6031c1d3514b Mon Sep 17 00:00:00 2001
From: marcus <marcus@FreeBSD.org>
Date: Fri, 9 Jul 2004 17:43:11 +0000
Subject: Apply a big libtool patch to allow porters to use the libtool
 installed by the libtoolX ports instead of the one included with each port. 
 Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool
 instead of the included version.  To restore previous behavior, use the new
 macro, USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool
 version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:		63944
Based on work by:eik and marcus
Approved by:	ade (autotools maintainer)
Tested by:	kris on pointyhat
Bound to be hidden problems:	You bet
---
 textproc/libxslt/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'textproc/libxslt/Makefile')

diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index fe94da55282e..70932d6b1b35 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -18,7 +18,7 @@ COMMENT?=	The XSLT C library for GNOME
 
 USE_BZIP2=	yes
 USE_GMAKE=	yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
 INSTALLS_SHLIB=	yes
 USE_GNOME?=	gnomehack lthack gnometarget libxml2
 USE_REINPLACE=	yes
-- 
cgit