From ce018ac9be7743cfed3dcef6cc91bb070cef0022 Mon Sep 17 00:00:00 2001
From: alane <alane@FreeBSD.org>
Date: Fri, 1 Nov 2002 04:17:51 +0000
Subject: Changed MAINTAINER to my FreeBSD address.

---
 www/firefox10/Makefile | 53 ++++++++++++++++++++++++++++++++++++--------------
 1 file changed, 38 insertions(+), 15 deletions(-)

(limited to 'www/firefox10')

diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 130a48cb3b10..227b008f88ed 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -2,7 +2,7 @@
 #
 # New ports collection makefile for:	phoenix
 # Date created:			2002/10/21
-# Whom:				Alan Eldridge <ports@geeksrus.net>
+# Whom:				Alan Eldridge <AlanE@FreeBSD.org>
 #
 # $FreeBSD$
 #
@@ -19,46 +19,69 @@ LIB_DEPENDS=	gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
 		jpeg.9:${PORTSDIR}/graphics/jpeg \
 		png.5:${PORTSDIR}/graphics/png \
 		mng.1:${PORTSDIR}/graphics/libmng \
-		freetype.9:${PORTSDIR}/print/freetype2
-#Xft2.2:${PORTSDIR}/x11-fonts/Xft
+		freetype.9:${PORTSDIR}/print/freetype2 \
+		IDL.2:${PORTSDIR}/devel/ORBit \
+		Xft2.2:${PORTSDIR}/x11-fonts/Xft
+
 BUILD_DEPENDS=	zip:${PORTSDIR}/archivers/zip \
-		freetype-config:${PORTSDIR}/print/freetype2 \
-		perl5.8.0:${PORTSDIR}/lang/perl5.8
+		freetype-config:${PORTSDIR}/print/freetype2
 
-PREFIX=		${X11BASE}/lib/${PORTNAME}
+USE_X_PREFIX=		yes
 
 USE_BZIP2=		yes
 USE_GMAKE=		yes
+USE_REINPLACE=		yes
 #USE_AUTOCONF_VER=	213
 GNU_CONFIGURE=		yes
+
+USE_GNOMENG=		yes
+USE_GNOME=		gtk12 ORBit
+
 CFLAGS+=		${PTHREAD_CFLAGS}
 LIBS+=			${PTHREAD_LIBS}
+.if defined(OPTIMIZE)
+CFLAGS+=		-O2
+.endif # defined(OPTIMIZE)
+
 NO_MTREE=		yes
 WRKSRC=			${WRKDIR}/mozilla
+LOCAL_PREFIX=		${PREFIX}/lib/${PORTNAME}
 
 .include <bsd.port.pre.mk>
 
+SITE_PERL?=	${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
+PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
+
+.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+BUILD_DEPENDS+=	${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS=	${BUILD_DEPENDS}
+.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+
 .if ${OSVERSION} > 500038
 BROKEN=	"on -CURRENT, can only be used with local files"
 .endif
 
-.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
-.undef NO_IGNORE
-BROKEN=	This port requires Perl 5.8.0 because of File::Spec issues. \
-	Make sure to run 'use.perl port' after installing it or you \
-	will still get this message.
-.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
-
 post-extract:
 	${SED} -e 's|@CFLAGS@|${CFLAGS}|'		\
 		-e 's|@LIBS@|${LIBS}|'			\
 		-e 's|@X11BASE@|${X11BASE}|'		\
 		-e 's|@LOCALBASE@|${LOCALBASE}|'	\
+		-e 's|@PREFIX@|${LOCAL_PREFIX}|'	\
 		<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
 
+# fix for Xft (thanks to marcus@)
+post-patch:
+	cd ${WRKSRC}/gfx/src/gtk;				\
+	${REINPLACE_CMD} -e 's|X11/Xft/Xft\.h|X11/Xft/Xft2.h|g'	\
+		nsDrawingSurfaceGTK.cpp	nsFontMetricsXft.h
+
 post-install:
-	${LN} -s ${PREFIX}/bin/phoenix ${X11BASE}/bin/phoenix
-	${LN} -s ${PREFIX}/bin/mozilla-config ${X11BASE}/bin/phoenix-config
+	${LN} -s ${LOCAL_PREFIX}/bin/phoenix \
+		${PREFIX}/bin/phoenix
+	${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
+		${PREFIX}/bin/phoenix-config
 
 .include <bsd.port.post.mk>
 
-- 
cgit