From d0f1a8ffa95d4bab839858fcc84df21500db8330 Mon Sep 17 00:00:00 2001
From: joe <joe@FreeBSD.org>
Date: Fri, 29 Mar 2002 10:54:20 +0000
Subject: Add an http web crawler to the ports.

---
 www/Makefile              |  1 +
 www/larbin/Makefile       | 47 +++++++++++++++++++++++++++++++++++++++++++++++
 www/larbin/distinfo       |  1 +
 www/larbin/files/patch-aa |  8 ++++++++
 www/larbin/pkg-comment    |  1 +
 www/larbin/pkg-descr      | 20 ++++++++++++++++++++
 www/larbin/pkg-plist      | 10 ++++++++++
 7 files changed, 88 insertions(+)
 create mode 100644 www/larbin/Makefile
 create mode 100644 www/larbin/distinfo
 create mode 100644 www/larbin/files/patch-aa
 create mode 100644 www/larbin/pkg-comment
 create mode 100644 www/larbin/pkg-descr
 create mode 100644 www/larbin/pkg-plist

(limited to 'www')

diff --git a/www/Makefile b/www/Makefile
index f57efc744d8a..c3dd2466d70f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -115,6 +115,7 @@
     SUBDIR += kannel
     SUBDIR += knowledgekit
     SUBDIR += kwebwatch
+    SUBDIR += larbin
     SUBDIR += libghttp
     SUBDIR += libwww
     SUBDIR += libxpg4-ns
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
new file mode 100644
index 000000000000..3e07c70f6bbd
--- /dev/null
+++ b/www/larbin/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: 	larbin
+# Date Created:		26 March 2002
+# Whom:			Hiten Pandya <hiten@uk.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	larbin
+PORTVERSION=	2.6.1
+CATEGORIES=	www
+MASTER_SITES=	ftp://ftp.sourceforge.net/pub/sourceforge/larbin/
+
+MAINTAINER=	hiten@uk.FreeBSD.org
+
+USE_GMAKE=	yes
+GNU_CONFIGURE=	yes
+
+PATCH_WRKSRC=	${WRKSRC}/src
+
+do-install:
+	@${INSTALL_PROGRAM} ${WRKSRC}/larbin ${PREFIX}/bin/
+	@${INSTALL_DATA} ${WRKSRC}/larbin.conf ${PREFIX}/etc/larbin.conf.sample
+	@${MKDIR} ${PREFIX}/share/larbin
+	@${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/larbin/
+
+pre-configure: config-message
+
+config-message:
+	@${ECHO} "====================================================================="
+	@${ECHO} ""
+	@${ECHO} "Make sure you have a look at the larbin documentation available at:"
+	@${ECHO} "  http://larbin.sourceforge.net/custom-eng.html."
+	@${ECHO} ""
+	@${ECHO} "====================================================================="
+
+post-install:
+	@${ECHO} "====================================================================="
+	@${ECHO} ""
+	@${ECHO} "You must invoke larbin with the name of the configuration file, e.g:"
+	@${ECHO} "larbin -c config-file"
+	@${ECHO} ""
+	@${ECHO} "Documentation: ${PREFIX}/share/larbin"
+	@${ECHO} "Sample Configuration file: ${PREFIX}/etc/larbin.conf.sample"
+	@${ECHO} ""
+	@${ECHO} "====================================================================="
+
+.include <bsd.port.mk>
diff --git a/www/larbin/distinfo b/www/larbin/distinfo
new file mode 100644
index 000000000000..8e9dad6ac0c5
--- /dev/null
+++ b/www/larbin/distinfo
@@ -0,0 +1 @@
+MD5 (larbin-2.6.1.tar.gz) = cdbb7932dc0e8c0ad6417bff971b93f0
diff --git a/www/larbin/files/patch-aa b/www/larbin/files/patch-aa
new file mode 100644
index 000000000000..c5160875851f
--- /dev/null
+++ b/www/larbin/files/patch-aa
@@ -0,0 +1,8 @@
+--- larbin.make~	Mon Mar  4 11:47:28 2002
++++ larbin.make	Tue Mar 26 21:17:01 2002
+@@ -37,5 +37,3 @@
+ 
+ prof-in: CPPFLAGS += -pg -DPROF
+ prof-in: redo-in
+-
+--include .depend
diff --git a/www/larbin/pkg-comment b/www/larbin/pkg-comment
new file mode 100644
index 000000000000..af502f5fe36c
--- /dev/null
+++ b/www/larbin/pkg-comment
@@ -0,0 +1 @@
+A powerful HTTP crawler with an easy interface
diff --git a/www/larbin/pkg-descr b/www/larbin/pkg-descr
new file mode 100644
index 000000000000..7f95d1f309e8
--- /dev/null
+++ b/www/larbin/pkg-descr
@@ -0,0 +1,20 @@
+Larbin is a powerful web crawler (also called [web] robot, spider...).  It
+is intended to fetch a large number of web pages to fill the database of a
+search engine.  With a network fast enough, Larbin is able to fetch more than
+100 million pages on a standard PC.
+
+Larbin was initially developed for the XYLEME project in the VERSO team at
+INRIA.  The goal of Larbin was to go and fetch XML pages on the web to fill
+the database of an xml-oriented search engine.
+
+The following can be done with Larbin:
+
+	o A crawler for a search engine
+	o A crawler for a specialized search enginer (xml, images, mp3...)
+	o Statistics on the web (about servers or page contents)
+
+Larbin is created by: Sebastien Ailleret
+
+WWW: http://larbin.sourceforge.net
+WWW: http://www.sourceforge.net/projects/larbin
+WWW: http://www.ailleret.com
diff --git a/www/larbin/pkg-plist b/www/larbin/pkg-plist
new file mode 100644
index 000000000000..8b07e74c0896
--- /dev/null
+++ b/www/larbin/pkg-plist
@@ -0,0 +1,10 @@
+bin/larbin
+etc/larbin.conf.sample
+share/larbin/custom-eng.html
+share/larbin/download.html
+share/larbin/index-eng.html
+share/larbin/index.html
+share/larbin/l-en.jpg
+share/larbin/l-fr.jpg
+share/larbin/use-eng.html
+@dirrm share/larbin
-- 
cgit 

/td></tr>
<tr><td class='sub'>FreeBSD GNOME current development ports (https://github.com/freebsd/freebsd-ports-gnome)</td><td class='sub right'></td></tr></table>
<table class='tabs'><tr><td>
<a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/about/'>about</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/'>summary</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/refs/?id=654532ea55761027243740a1cb4b1b58fac78923'>refs</a><a class='active' href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java/jakarta-commons-pool/pkg-descr'>log</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/tree/java/jakarta-commons-pool/pkg-descr?id=654532ea55761027243740a1cb4b1b58fac78923'>tree</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/java/jakarta-commons-pool/pkg-descr?id=654532ea55761027243740a1cb4b1b58fac78923'>commit</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/diff/java/jakarta-commons-pool/pkg-descr?id=654532ea55761027243740a1cb4b1b58fac78923'>diff</a><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/stats/java/jakarta-commons-pool/pkg-descr'>stats</a></td><td class='form'><form class='right' method='get' action='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java/jakarta-commons-pool/pkg-descr'>
<input type='hidden' name='id' value='654532ea55761027243740a1cb4b1b58fac78923'/><select name='qt'>
<option value='grep'>log msg</option>
<option value='author'>author</option>
<option value='committer'>committer</option>
<option value='range'>range</option>
</select>
<input class='txt' type='search' size='10' name='q' value=''/>
<input type='submit' value='search'/>
</form>
</td></tr></table>
<div class='path'>path: <a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/?id=654532ea55761027243740a1cb4b1b58fac78923'>root</a>/<a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java?id=654532ea55761027243740a1cb4b1b58fac78923'>java</a>/<a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java/jakarta-commons-pool?id=654532ea55761027243740a1cb4b1b58fac78923'>jakarta-commons-pool</a>/<a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java/jakarta-commons-pool/pkg-descr?id=654532ea55761027243740a1cb4b1b58fac78923'>pkg-descr</a></div><div class='content'><table class='list nowrap'><tr class='nohover'><th></th><th class='left'>Commit message (<a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/log/java/jakarta-commons-pool/pkg-descr?id=654532ea55761027243740a1cb4b1b58fac78923&amp;showmsg=1'>Expand</a>)</th><th class='left'>Author</th><th class='left'>Age</th><th class='left'>Files</th><th class='left'>Lines</th></tr>
<tr><td class='commitgraph'>* </td><td><a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/java/jakarta-commons-pool/pkg-descr?id=eaaea5fd0294a90775504fc63590fccbc88d9037'>Add slash to WWW tag.</a></td><td>osa</td><td><span title='2003-10-08 17:51:45 +0800'>2003-10-08</span></td><td>1</td><td><span class='deletions'>-1</span>/<span class='insertions'>+1</span></td></tr>