From d580e8aa85f6c754681443742699cb344fd34220 Mon Sep 17 00:00:00 2001
From: anholt <anholt@FreeBSD.org>
Date: Tue, 11 Mar 2003 23:38:11 +0000
Subject: Update XFree86 ports, including linux_dri, to 4.3.0.  Set IGNORE= in
 dri-devel for being outdated.  Thank you to all the testers and people who
 submitted patches for this update.

Approved by:	portmgr
---
 x11-servers/XFree86-4-NestServer/Makefile          | 19 +++----
 x11-servers/XFree86-4-NestServer/distinfo          |  5 +-
 x11-servers/XFree86-4-NestServer/scripts/configure | 64 ++++++++++------------
 3 files changed, 41 insertions(+), 47 deletions(-)

(limited to 'x11-servers/XFree86-4-NestServer')

diff --git a/x11-servers/XFree86-4-NestServer/Makefile b/x11-servers/XFree86-4-NestServer/Makefile
index f45b95594e4b..ff2a9be2e59f 100644
--- a/x11-servers/XFree86-4-NestServer/Makefile
+++ b/x11-servers/XFree86-4-NestServer/Makefile
@@ -6,24 +6,23 @@
 #
 
 PORTNAME=	NestServer
-PORTVERSION=	4.2.1
-PORTREVISION=	1
+PORTVERSION=	4.3.0
 CATEGORIES=	x11-servers
 MASTER_SITES=	${MASTER_SITE_XFREE:S/$/:x/} \
 		${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR=	4.2.0/:x \
+MASTER_SITE_SUBDIR=	${PORTVERSION}/:x \
 			anholt/:local
 PKGNAMEPREFIX=	XFree86-
-DISTFILES=	X420src-1.tgz:x \
+DISTFILES=	X430src-1.tgz:x \
+		X430src-2.tgz:x \
+		X430src-3.tgz:x \
 		Wraphelp2.gz:local
-EXTRACT_ONLY=	X420src-1.tgz
-
-PATCH_SITES=		${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR=	anholt/patches-4.2.0/
-PATCHFILES=		4.2.0-4.2.1-1-freebsd.patch.gz
+EXTRACT_ONLY=	X430src-1.tgz \
+		X430src-2.tgz \
+		X430src-3.tgz
 
 MAINTAINER=	anholt@freebsd.org
-COMMENT=	XFree86-4 Xnest server
+COMMENT=	XFree86-4 nested X server
 
 XFREE86_VERSION=	4
 USE_IMAKE=		YES
diff --git a/x11-servers/XFree86-4-NestServer/distinfo b/x11-servers/XFree86-4-NestServer/distinfo
index fde56e7c7696..86966f90fbd3 100644
--- a/x11-servers/XFree86-4-NestServer/distinfo
+++ b/x11-servers/XFree86-4-NestServer/distinfo
@@ -1,3 +1,4 @@
-MD5 (xc/X420src-1.tgz) = ad43a8e9e39703322005cd6f7145b77f
+MD5 (xc/X430src-1.tgz) = 4f241a4f867363f40efa2b00dca292af
+MD5 (xc/X430src-2.tgz) = 844c2ee908d21dbf8911fd13115bf8b4
+MD5 (xc/X430src-3.tgz) = b82a0443e1b7bf860e4343e6b6766cb6
 MD5 (xc/Wraphelp2.gz) = bd1910492087442288d885412e2e5535
-MD5 (xc/4.2.0-4.2.1-1-freebsd.patch.gz) = 1d4c49d7f354b307b7961e6d8e6c4274
diff --git a/x11-servers/XFree86-4-NestServer/scripts/configure b/x11-servers/XFree86-4-NestServer/scripts/configure
index c81f36f4df1b..8fc815ae2bc3 100644
--- a/x11-servers/XFree86-4-NestServer/scripts/configure
+++ b/x11-servers/XFree86-4-NestServer/scripts/configure
@@ -1,14 +1,11 @@
 #!/bin/sh
 
 # This script does the following:
-# (1) cp current xf86site.def (it is created by the imake-4 port) 
+# (1) cp xf86site.def, installed by imake-4 port,
 #       to ${WRKDIR}/xc/config/cf.
-#     this means this port uses imake-4's config for defaults.
-# (2) Generate temporal config for compiling.
-#     Some configs, such as `ForceNormalLib', `FreeBSDBuildXprog', are
-#     used locally for compiling this port, so these configs will be generated
-#     by this script. These configs will be stored to the `host.def' file,
-#     but this host.def will never be installed.
+#     this provides settings for the ports system.
+# (2) Create a host.def for this specific port, using 
+#     host.def as a base.
 
 ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
 DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
@@ -16,18 +13,17 @@ ORIGHOSTDEF=$PREFIX/lib/X11/config/host.def
 LOCALDEF=$WRKDIR/.config
 HOSTDEF=$WRKDIR/xc/config/cf/host.def
 
-configure () {
-    # Use original host.def as initial config file
-    rm -f $LOCALDEF
-    grep -v '#define.*ProjectRoot' $ORIGHOSTDEF >> $LOCALDEF
-    echo "#define ProjectRoot $PREFIX" >> $LOCALDEF
+# Use original host.def as initial config file
+rm -f $LOCALDEF
+grep -v '#define.*ProjectRoot' $ORIGHOSTDEF	>> $LOCALDEF
+echo "#define ProjectRoot $PREFIX"		>> $LOCALDEF
 
-    if [ X$InstallFSConfig = "X" ]; then
-	InstallFSConfig=YES
-    fi
+# This is also defined in xf86site.def, but doesn't get
+# picked up for some reason.
+echo "#define NothingOutsideProjectRoot YES"	>> $LOCALDEF
 
-    # disable some configs: there are not used this ports
-    for i in BuildFonts \
+# disable some options
+for i in BuildFonts \
 	Build75DpiFonts \
 	Build100DpiFonts \
 	BuildSpeedoFonts \
@@ -42,25 +38,23 @@ configure () {
 	LibHeaders \
 	ForceNormalLib \
 	XTrueTypeInstallCConvHeaders
-    do \
-	echo "#define $i NO" >> $LOCALDEF
-    done
-    echo "#define BuildServer YES" >> $LOCALDEF
-    echo "#define XnestServer YES" >> $LOCALDEF
-    echo "#define BuildServersOnly YES" >> $LOCALDEF
-    echo "#define UseInstalledPrograms YES" >> $LOCALDEF
-    echo "#define FreeBSDCC	${CC}" >> $LOCALDEF
-    echo "#define FreeBSDCXX	${CXX}" >> $LOCALDEF
-    echo "#define FreeBSDCFLAGS	${CFLAGS}" >> $LOCALDEF
+do \
+	echo "#define $i NO"			>> $LOCALDEF
+done
 
-    # Copy ORIGDEF to DESTDEF
-    rm -f $DESTDEF
-    cp -f $ORIGDEF $DESTDEF
+echo "#define BuildServer YES"			>> $LOCALDEF
+echo "#define XnestServer YES"			>> $LOCALDEF
+echo "#define BuildServersOnly YES"		>> $LOCALDEF
+echo "#define UseInstalledPrograms YES"		>> $LOCALDEF
+echo "#define FreeBSDCC	${CC}"			>> $LOCALDEF
+echo "#define FreeBSDCXX ${CXX}"		>> $LOCALDEF
+echo "#define FreeBSDCFLAGS ${CFLAGS}"		>> $LOCALDEF
 
-    # copy generated config to host.def
-    cp -f $LOCALDEF $HOSTDEF
-}
+# Copy ORIGDEF to DESTDEF
+rm -f $DESTDEF
+cp -f $ORIGDEF $DESTDEF
+
+# copy generated config to host.def
+cp -f $LOCALDEF $HOSTDEF
 
-cp ${X11BASE}/lib/X11/config/version.def ${WRKSRC}/config/cf
-configure
 exit 0
-- 
cgit