aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-04-28 03:46:06 +0800
committerjbeich <jbeich@FreeBSD.org>2018-04-28 03:46:06 +0800
commit13c898e0778b5583e1ec2394d413dda1beaf0ab6 (patch)
treeba8b1ec25d58325f883c091156d3d4b84b30b026
parent37710751fb11901bd0fd21b0b6754a14114c4324 (diff)
downloadfreebsd-ports-graphics-13c898e0778b5583e1ec2394d413dda1beaf0ab6.tar.gz
freebsd-ports-graphics-13c898e0778b5583e1ec2394d413dda1beaf0ab6.tar.zst
freebsd-ports-graphics-13c898e0778b5583e1ec2394d413dda1beaf0ab6.zip
Adjust __cxa_thread_atexit conditional
-rw-r--r--databases/mysql80-server/Makefile5
-rw-r--r--devel/opendht/Makefile8
-rw-r--r--sysutils/freefilesync/Makefile8
3 files changed, 16 insertions, 5 deletions
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index bf7cbc24e37..63aa1531c03 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -81,7 +81,6 @@ PLIST_SUB= MY_DBDIR=${MY_DBDIR} \
# MySQL-Server part
.if !defined(CLIENT_ONLY)
USES+= mysql:80
-IGNORE_FreeBSD_10= "FreeBSD 10.0 doesn't have _cxa_thread_atexit() implemeneted in libc, it has been implemented since 11
CONFLICTS_INSTALL= mysql8[1-9]-server-* \
mysql[0-79][0-9]-server-* \
@@ -141,6 +140,10 @@ FEDERATED_SUB_LIST_OFF+= FEDER=""
.include <bsd.port.options.mk>
+.if !defined(CLIENT_ONLY) && ${OPSYS} == FreeBSD && ${OSVERSION} < 1003506
+BROKEN= no __cxa_thread_atexit() support in FreeBSD libc < 10.4
+.endif
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
.else
diff --git a/devel/opendht/Makefile b/devel/opendht/Makefile
index 4a90255d02e..48aec0bc325 100644
--- a/devel/opendht/Makefile
+++ b/devel/opendht/Makefile
@@ -11,8 +11,6 @@ COMMENT= Lightweight Distributed Hash Table implementation
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_10= Missing __cxa_thread_atexit
-
LIB_DEPENDS= libargon2.so:security/libargon2 \
libmsgpackc.so:devel/msgpack \
libnettle.so:security/nettle \
@@ -42,4 +40,10 @@ PROXY_SERVER_LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp \
PORTDOCS= *
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1003506
+BROKEN= no __cxa_thread_atexit() support in FreeBSD libc < 10.4
+.endif
+
.include <bsd.port.mk>
diff --git a/sysutils/freefilesync/Makefile b/sysutils/freefilesync/Makefile
index 437d27c8ccb..c6a7f8cd4ff 100644
--- a/sysutils/freefilesync/Makefile
+++ b/sysutils/freefilesync/Makefile
@@ -15,8 +15,6 @@ COMMENT= Backup software to synchronize files and folders
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/License.txt
-IGNORE_FreeBSD_10= FreeBSD 10.0 doesn't have _cxa_thread_atexit() implemeneted in libc, it has been implemented since 11
-
BUILD_DEPENDS= ${LOCALBASE}/include/zenxml/xml.h:textproc/zenxml
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
@@ -41,4 +39,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|WEXITSTATUS||' ${WRKDIR}/zen/shell_execute.h
@${REINPLACE_CMD} -e 's| noexcept;|;|' ${WRKDIR}/zen/scope_guard.h
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1003506
+BROKEN= no __cxa_thread_atexit() support in FreeBSD libc < 10.4
+.endif
+
.include <bsd.port.mk>