aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-05 18:56:37 +0800
committerrakuco <rakuco@FreeBSD.org>2017-08-05 18:56:37 +0800
commit3b3fa9ef018c84491992d0b544a00d17766d1203 (patch)
tree2a6f4477c2cd459e47b43585b1bbb9393444cf20
parentc648367b19e91e1ab4b9c1b1b006cafac21a46b1 (diff)
downloadfreebsd-ports-graphics-3b3fa9ef018c84491992d0b544a00d17766d1203.tar.gz
freebsd-ports-graphics-3b3fa9ef018c84491992d0b544a00d17766d1203.tar.zst
freebsd-ports-graphics-3b3fa9ef018c84491992d0b544a00d17766d1203.zip
Explicitly build with -std=gnu++11.
This is a workaround for FreeBSD 10, whose libc++ does not have an overload for C++14's `operator delete(void*, size_t)'. Since GCC 6 uses -std=gnu++14 by default, linking fails when a dependency (such as taglib) is built with clang and lacking the overload. FreeBSD >= 11 is fine. PR: 219489 Approved by: portmgr (blanket approval)
-rw-r--r--net/mediatomb/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index e36facd7431..dba5761caff 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ENV= PTHREAD_LIBS="-lpthread"
USES= compiler:gcc-c++11-lib iconv localbase:ldflags
USE_RC_SUBR= mediatomb
+# Workaround for FreeBSD 10, whose libc++ does not have an overload for C++14's
+# `operator delete(void*, size_t)'. Since GCC 6 uses -std=gnu++14 by default,
+# linking fails when a dependency (such as taglib) is built with clang and
+# lacking the overload. FreeBSD >= 11 is fine.
+USE_CXXSTD= gnu++11
+
USERS= mediatomb
GROUPS= ${USERS}