aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasomers <asomers@FreeBSD.org>2017-06-06 11:44:36 +0800
committerasomers <asomers@FreeBSD.org>2017-06-06 11:44:36 +0800
commit68a1c4be2fda812eac24a2214cb51a7e20b69602 (patch)
tree8e6130941dbbc2fb2d24356b327ed6cf32cac531
parent5145fc4c113e427f6796f803746ad7c70e95ba2d (diff)
downloadfreebsd-ports-graphics-68a1c4be2fda812eac24a2214cb51a7e20b69602.tar.gz
freebsd-ports-graphics-68a1c4be2fda812eac24a2214cb51a7e20b69602.tar.zst
freebsd-ports-graphics-68a1c4be2fda812eac24a2214cb51a7e20b69602.zip
sysutils/docker-freebsd: add docker_flags to the rc script
Add a docker_flags variable to the rc script that can be used to pass freeform options to the docker command. I use it for the "-H" option. PR: 219795 Approved by: amutu@amutu.com (maintainer) Approved by: brd (ports)
-rw-r--r--sysutils/docker-freebsd/Makefile1
-rw-r--r--sysutils/docker-freebsd/files/docker.in3
2 files changed, 3 insertions, 1 deletions
diff --git a/sysutils/docker-freebsd/Makefile b/sysutils/docker-freebsd/Makefile
index d289ff479f8..361ca75838b 100644
--- a/sysutils/docker-freebsd/Makefile
+++ b/sysutils/docker-freebsd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= docker-freebsd
PORTVERSION= 20150625
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= amutu@amutu.com
diff --git a/sysutils/docker-freebsd/files/docker.in b/sysutils/docker-freebsd/files/docker.in
index 394e5b574de..ede1f108139 100644
--- a/sysutils/docker-freebsd/files/docker.in
+++ b/sysutils/docker-freebsd/files/docker.in
@@ -19,6 +19,7 @@ load_rc_config $name
: ${docker_dir=/usr/docker}
: ${docker_nat_pf=YES}
: ${docker_nat_iface=NONE}
+: ${docker_flags=}
docker_start()
{
@@ -36,7 +37,7 @@ docker_start()
fi
echo "Starting docker..."
- daemon -p /var/run/docker.pid ${command} -d -e jail -s zfs -g ${docker_dir} -D >/var/log/docker.log 2>/var/log/docker.log
+ daemon -p /var/run/docker.pid ${command} -d -e jail -s zfs -g ${docker_dir} -D ${docker_flags} >/var/log/docker.log 2>/var/log/docker.log
# Check for linux 64bit support and enable
kldstat | grep -q 'linux64'