aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2018-04-10 19:30:50 +0800
committermmokhi <mmokhi@FreeBSD.org>2018-04-10 19:30:50 +0800
commit6a44bb4fd3f37b1cb6d8cd4413ccf1fdcb6d82d9 (patch)
treee53349ae54603374e87e47a20960713acdb5e472
parente310a958f85c1930168ce5c6fa476cd33cf05e48 (diff)
downloadfreebsd-ports-graphics-6a44bb4fd3f37b1cb6d8cd4413ccf1fdcb6d82d9.tar.gz
freebsd-ports-graphics-6a44bb4fd3f37b1cb6d8cd4413ccf1fdcb6d82d9.tar.zst
freebsd-ports-graphics-6a44bb4fd3f37b1cb6d8cd4413ccf1fdcb6d82d9.zip
multimedia/Bento4: Add the port to the tree
Bento4 is a C++ class library and tools designed to read/write ISO-MP4 files. This format is defined in international specifications ISO/IEC: 14496-12 14496-14 14496-15 Sponsored by: Netzkommune GmbH
-rw-r--r--multimedia/Bento4/Makefile30
-rw-r--r--multimedia/Bento4/distinfo3
-rw-r--r--multimedia/Bento4/pkg-descr7
-rw-r--r--multimedia/Bento4/pkg-plist19
4 files changed, 59 insertions, 0 deletions
diff --git a/multimedia/Bento4/Makefile b/multimedia/Bento4/Makefile
new file mode 100644
index 00000000000..2eeee357a6d
--- /dev/null
+++ b/multimedia/Bento4/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= Bento4
+PORTVERSION= 1.5.1
+DISTVERSIONPREFIX=v
+DISTVERSIONSUFFIX=-622
+CATEGORIES= multimedia devel
+
+MAINTAINER= mmokhi@FreeBSD.org
+COMMENT= Full-featured MP4 format and MPEG DASH library and tools
+
+LICENSE= GPLv2
+
+USES= cmake:outsource,noninja
+
+USE_GITHUB= yes
+GH_ACCOUNT= axiomatic-systems
+
+CMAKE_BUILD_TYPE= Release
+INSTALL_TARGET= do-install
+
+do-install:
+. for prog in aac2mp4 mp42aac mp42hls mp42ts mp4compact mp4dcfpackager \
+ mp4decrypt mp4diff mp4dump mp4edit mp4encrypt mp4extract mp4fragment \
+ mp4iframeindex mp4info mp4mux mp4split mp4tag
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${prog} ${STAGEDIR}${PREFIX}/bin
+. endfor
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/libap4.a ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/multimedia/Bento4/distinfo b/multimedia/Bento4/distinfo
new file mode 100644
index 00000000000..3035b00e42a
--- /dev/null
+++ b/multimedia/Bento4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523358964
+SHA256 (axiomatic-systems-Bento4-v1.5.1-622_GH0.tar.gz) = 60492b9b644a2cfce7af3d82a6277e34d3e906221339cd54fcfae831fff0535d
+SIZE (axiomatic-systems-Bento4-v1.5.1-622_GH0.tar.gz) = 4445862
diff --git a/multimedia/Bento4/pkg-descr b/multimedia/Bento4/pkg-descr
new file mode 100644
index 00000000000..bc15ede561d
--- /dev/null
+++ b/multimedia/Bento4/pkg-descr
@@ -0,0 +1,7 @@
+Bento4 is a C++ class library and tools to read and write ISO-MP4 files.
+This format is defined in international specifications ISO/IEC 14496-12,
+14496-14 and 14496-15.
+The format is a derivative of the Apple Quicktime file format,
+so Bento4 can be used to read and write most Quicktime files as well.
+
+WWW: https://www.bento4.com
diff --git a/multimedia/Bento4/pkg-plist b/multimedia/Bento4/pkg-plist
new file mode 100644
index 00000000000..ad90b8e5eae
--- /dev/null
+++ b/multimedia/Bento4/pkg-plist
@@ -0,0 +1,19 @@
+bin/aac2mp4
+bin/mp42aac
+bin/mp42hls
+bin/mp42ts
+bin/mp4compact
+bin/mp4dcfpackager
+bin/mp4decrypt
+bin/mp4diff
+bin/mp4dump
+bin/mp4edit
+bin/mp4encrypt
+bin/mp4extract
+bin/mp4fragment
+bin/mp4iframeindex
+bin/mp4info
+bin/mp4mux
+bin/mp4split
+bin/mp4tag
+lib/libap4.a