aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-02-16 06:17:36 +0800
committerpi <pi@FreeBSD.org>2018-02-16 06:17:36 +0800
commit75b29768110abc49dcb4b7583928023a6949e64b (patch)
treef2c25febe05f33dee3b23a4f54bdd1c48a441f58
parent6965a599d56e4b5db708e9a1172d91df1c8431b4 (diff)
downloadfreebsd-ports-graphics-75b29768110abc49dcb4b7583928023a6949e64b.tar.gz
freebsd-ports-graphics-75b29768110abc49dcb4b7583928023a6949e64b.tar.zst
freebsd-ports-graphics-75b29768110abc49dcb4b7583928023a6949e64b.zip
net/quagga: update 1.2.2 -> 1.2.3
- doc/security: Security announcements for 4 issues - doc/security: Add a doc/security folder and template for announcements - doc: Add commit message template, suitable for commit.template - bgpd: remove stream_pnt use for notify data - lib/privs: Remove of CAP_NET_BROADCAST forgot to decrement array count - bgpd/security: debug print of received NOTIFY data can over-read msg array - bgpd/security: fix infinite loop on certain invalid OPEN messages - bgpd/security: Fix double free of unknown attribute - bgpd/security: invalid attr length sends NOTIFY with data overrun - zebra/redistribute: Implicit withdraw needs to be explicit if update isn't sent - doc: 'match aspath' should be 'match as-path' - bgpd: fix SIGBUS - bgpd: Fix mistake in NHT of connected IPv6 next-hops preventing route advertisements - Updated the protocol supported list - lib/command: make config file robust more robust and kinder to system - doc: Bring documentation on Zserv header up to date. - bgpd: distance comment - doc: Fix small but important logical mistake in community-list example - doc: document that changing bgp distance needs a hard clear of routes - bgpd: malformed attribute handling: don't pass on, and add missing notify - lib/filter: change add/delete callback hooks to robustly delete - Revert "lib: Fix Free Pointer dereference in lib/filter.c" - infra/buildbot: allow bots to be picked out by installed compiler. - infra/buildbot: Add bots, add JSON "env" config variable, poll all git branches - lib: ptr macro arg may need brackets in some cases - distro/systemd: add man page ref and set config file permissions - doc: Fix manpage number for ospfclient. - vtysh: Fix spelling errors in strings flagged by lintian. - doc: Tweak grammar in zebra manpage to keep lintian happy. - vtysh: print error if PAM auth does not succeed - lib/thread: get rid of the shallow-copy thread_fetch add a sane thread_main - buildbot/master: use a helper generator for make cmd string list - buildbot/master: fix the common steps - buildbot/master: Add OBSD bot, and support for environment variable config - build: AC_EGREPP_CPP actions wrong way around, worked by accident mostly. - build: Work around illumos still shipping MFH: 2018Q1 Security: CVE-2018-5378, https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-0543.txt CVE-2018-5379, https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1114.txt CVE-2018-5380, https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1550.txt CVE-2018-5381, https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1975.txt
-rw-r--r--net/quagga/Makefile6
-rw-r--r--net/quagga/distinfo6
-rw-r--r--net/quagga/files/patch-bgpd_bgp__aspath.c11
-rw-r--r--net/quagga/files/patch-bgpd_bgp__nht.c13
-rw-r--r--net/quagga/files/patch-configure12
-rw-r--r--net/quagga/files/patch-lib_command.c21
-rw-r--r--net/quagga/files/patch-vtysh_extract.pl.in4
-rw-r--r--net/quagga/pkg-plist2
8 files changed, 30 insertions, 45 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 29d7cb86022..1ab8bf88d13 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quagga
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
@@ -16,10 +15,11 @@ BUILD_DEPENDS= gawk:lang/gawk
CONFLICTS= openbgpd openospfd zebra quagga-esr frr pimd
+USES= compiler:c11 cpe gmake libtool makeinfo \
+ perl5 readline ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline compiler:c11 cpe
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/net/quagga/distinfo b/net/quagga/distinfo
index 0b6813861ca..456d8a8b196 100644
--- a/net/quagga/distinfo
+++ b/net/quagga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507052274
-SHA256 (quagga-1.2.2.tar.gz) = 522e22f2beee64e3f0c2cde3d0155f3b8103f4f6fc8abef92cb40bc3a4cc2931
-SIZE (quagga-1.2.2.tar.gz) = 2986142
+TIMESTAMP = 1517952673
+SHA256 (quagga-1.2.3.tar.gz) = ee2c0907a106902abbdcaf63b4f28c67241c4f3396989ed54da7b4976eecad31
+SIZE (quagga-1.2.3.tar.gz) = 2925444
diff --git a/net/quagga/files/patch-bgpd_bgp__aspath.c b/net/quagga/files/patch-bgpd_bgp__aspath.c
deleted file mode 100644
index c31a71a54ba..00000000000
--- a/net/quagga/files/patch-bgpd_bgp__aspath.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bgpd/bgp_aspath.c.orig 2017-10-03 14:57:10 UTC
-+++ bgpd/bgp_aspath.c
-@@ -901,7 +901,7 @@ aspath_put (struct stream *s, struct aspath *as, int u
- while ( (seg->length - written) > AS_SEGMENT_MAX)
- {
- assegment_header_put (s, seg->type, AS_SEGMENT_MAX);
-- assegment_data_put (s, seg->as, AS_SEGMENT_MAX, use32bit);
-+ assegment_data_put (s, (seg->as+written), AS_SEGMENT_MAX, use32bit);
- written += AS_SEGMENT_MAX;
- bytes += ASSEGMENT_SIZE (AS_SEGMENT_MAX, use32bit);
- }
diff --git a/net/quagga/files/patch-bgpd_bgp__nht.c b/net/quagga/files/patch-bgpd_bgp__nht.c
deleted file mode 100644
index 7b0e6110de3..00000000000
--- a/net/quagga/files/patch-bgpd_bgp__nht.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- bgpd/bgp_nht.c.orig 2017-10-03 16:57:10.000000000 +0200
-+++ bgpd/bgp_nht.c 2017-12-15 21:12:37.058505000 +0100
-@@ -409,8 +409,8 @@
- break;
- #ifdef HAVE_IPV6
- case AFI_IP6:
-- if (ri->attr->extra->mp_nexthop_len != 16
-- || IN6_IS_ADDR_LINKLOCAL (&ri->attr->extra->mp_nexthop_global))
-+ if (ri->attr->extra->mp_nexthop_len == 16
-+ && IN6_IS_ADDR_LINKLOCAL (&ri->attr->extra->mp_nexthop_global))
- return -1;
-
- p->family = AF_INET6;
diff --git a/net/quagga/files/patch-configure b/net/quagga/files/patch-configure
deleted file mode 100644
index 547b7de15c8..00000000000
--- a/net/quagga/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig 2017-10-03 14:59:10 UTC
-+++ configure
-@@ -22070,7 +22070,7 @@ fi
- fi
-
-
-
--if test "${enable_snmp}" != ""; then
-+if test "x${enable_snmp}" != "xno"; then
- if test -n "$ac_tool_prefix"; then
- # Extract the first word of "${ac_tool_prefix}net-snmp-config", so it can be a program name with args.
- set dummy ${ac_tool_prefix}net-snmp-config; ac_word=$2
diff --git a/net/quagga/files/patch-lib_command.c b/net/quagga/files/patch-lib_command.c
new file mode 100644
index 00000000000..d8600803a05
--- /dev/null
+++ b/net/quagga/files/patch-lib_command.c
@@ -0,0 +1,21 @@
+--- lib/command.c.orig 2018-02-04 17:34:34 UTC
++++ lib/command.c
+@@ -3127,15 +3127,15 @@ DEFUN (config_write_file,
+
+ if ((dupfd = dup (file_vty->wfd)) < 0)
+ {
+- vty_out (vty, "Couldn't dup fd (for fdatasync) for %s, %s (%d).%s",
++ vty_out (vty, "Couldn't dup fd (for fsync) for %s, %s (%d).%s",
+ config_file, safe_strerror(errno), errno, VTY_NEWLINE);
+ }
+
+ vty_close (file_vty);
+
+- if (fdatasync (dupfd) < 0)
++ if (fsync (dupfd) < 0)
+ {
+- vty_out (vty, "Couldn't fdatasync %s, %s (%d)!%s",
++ vty_out (vty, "Couldn't fsync %s, %s (%d)!%s",
+ config_file, safe_strerror(errno), errno, VTY_NEWLINE);
+ }
+
diff --git a/net/quagga/files/patch-vtysh_extract.pl.in b/net/quagga/files/patch-vtysh_extract.pl.in
index 44ddef59d4f..36e93abda74 100644
--- a/net/quagga/files/patch-vtysh_extract.pl.in
+++ b/net/quagga/files/patch-vtysh_extract.pl.in
@@ -1,6 +1,6 @@
---- vtysh/extract.pl.in.orig 2016-10-18 13:03:52 UTC
+--- vtysh/extract.pl.in.orig 2018-02-04 17:34:34 UTC
+++ vtysh/extract.pl.in
-@@ -69,7 +69,7 @@ my $cli_stomp = 0;
+@@ -75,7 +75,7 @@ my $cli_stomp = 0;
foreach (@ARGV) {
$file = $_;
diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist
index cb8a9ef0c4a..bec6e377a2a 100644
--- a/net/quagga/pkg-plist
+++ b/net/quagga/pkg-plist
@@ -100,7 +100,7 @@ sbin/zebra
%%ISISD%%%%EXAMPLESDIR%%/isisd.conf.sample
%%EXAMPLESDIR%%/ospf6d.conf.sample
%%EXAMPLESDIR%%/ospfd.conf.sample
-%%PIMD%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pimd.conf.sample
+%%PIMD%%%%EXAMPLESDIR%%/pimd.conf.sample
%%EXAMPLESDIR%%/ripd.conf.sample
%%EXAMPLESDIR%%/ripngd.conf.sample
%%EXAMPLESDIR%%/vtysh.conf.sample