aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-04-27 18:32:59 +0800
committertobik <tobik@FreeBSD.org>2018-04-27 18:32:59 +0800
commit7ffc000ad90786f2b179ba1b9cf7cc2f53ab2285 (patch)
tree5415d4513b4e145f69ee70412ddc6240b358ec60
parent05a102e2c3d502b750a3c503647ef3bdef208618 (diff)
downloadfreebsd-ports-graphics-7ffc000ad90786f2b179ba1b9cf7cc2f53ab2285.tar.gz
freebsd-ports-graphics-7ffc000ad90786f2b179ba1b9cf7cc2f53ab2285.tar.zst
freebsd-ports-graphics-7ffc000ad90786f2b179ba1b9cf7cc2f53ab2285.zip
New port: devel/samurai
samurai is a ninja-compatible build tool written in C99 with a focus on simplicity, speed, and portability. It implements the ninja build language through version 1.8.2 except for MSVC dependency handling (deps = msvc). It uses the same format for .ninja_log and .ninja_deps as ninja, currently version 5 and 3 respectively. It is largely feature-complete and supports most of the same options as ninja. WWW: https://github.com/michaelforney/samurai
-rw-r--r--devel/Makefile1
-rw-r--r--devel/samurai/Makefile24
-rw-r--r--devel/samurai/distinfo3
-rw-r--r--devel/samurai/pkg-descr12
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ee2562e899c..9acd7b8ba8d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5970,6 +5970,7 @@
SUBDIR += rvm
SUBDIR += sabre
SUBDIR += safe-iop
+ SUBDIR += samurai
SUBDIR += sbt
SUBDIR += scalatest
SUBDIR += scandoc
diff --git a/devel/samurai/Makefile b/devel/samurai/Makefile
new file mode 100644
index 00000000000..72be33799b6
--- /dev/null
+++ b/devel/samurai/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= samurai
+DISTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= https://github.com/michaelforney/samurai/releases/download/${DISTVERSION}/
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Ninja-compatible build tool written in C
+
+LICENSE= APACHE20 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE
+
+ALL_TARGET= samu
+PLIST_FILES= bin/samu man/man1/samu.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/samu ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/samu.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/samurai/distinfo b/devel/samurai/distinfo
new file mode 100644
index 00000000000..39e509b0a39
--- /dev/null
+++ b/devel/samurai/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524823953
+SHA256 (samurai-0.3.tar.gz) = 2a93d09a2dc97a9930d2757f2829c599d7ca339c7df61b048210c6be18d318b0
+SIZE (samurai-0.3.tar.gz) = 26450
diff --git a/devel/samurai/pkg-descr b/devel/samurai/pkg-descr
new file mode 100644
index 00000000000..256beb992fc
--- /dev/null
+++ b/devel/samurai/pkg-descr
@@ -0,0 +1,12 @@
+samurai is a ninja-compatible build tool written in C99 with a focus on
+simplicity, speed, and portability.
+
+It implements the ninja build language through version 1.8.2 except
+for MSVC dependency handling (deps = msvc). It uses the same format
+for .ninja_log and .ninja_deps as ninja, currently version 5 and 3
+respectively.
+
+It is largely feature-complete and supports most of the same options as
+ninja.
+
+WWW: https://github.com/michaelforney/samurai