aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-04-05 00:38:50 +0800
committermfechner <mfechner@FreeBSD.org>2018-04-05 00:38:50 +0800
commit86c3a082638267a82e0887e320a63f5ec6f43729 (patch)
tree6f0f4b43f7c7a00f65310c256331cacb45f7eebf
parentb7e2f5424f44f2541f391f70bd634e9491357a6b (diff)
downloadfreebsd-ports-graphics-86c3a082638267a82e0887e320a63f5ec6f43729.tar.gz
freebsd-ports-graphics-86c3a082638267a82e0887e320a63f5ec6f43729.tar.zst
freebsd-ports-graphics-86c3a082638267a82e0887e320a63f5ec6f43729.zip
Update devel/gitlab-shell to version 6.0.3 which is required fot gitlab 10.5.x.
Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D14942
-rw-r--r--devel/gitlab-shell/Makefile16
-rw-r--r--devel/gitlab-shell/distinfo6
-rw-r--r--devel/gitlab-shell/files/patch-config.yml.example13
-rw-r--r--devel/gitlab-shell/pkg-plist22
4 files changed, 23 insertions, 34 deletions
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index 4ccd8865a7e..c04409ed9dc 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= gitlab-shell
-PORTVERSION= 5.11.0
+PORTVERSION= 6.0.3
CATEGORIES= devel
-MASTER_SITES= https://gitlab.com/gitlab-org/${PORTNAME}/repository/archive.tar.gz?ref=v${PORTVERSION}&dummy=/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
LICENSE= MIT
@@ -15,17 +13,21 @@ COMMENT= GitLab Shell handles git commands for GitLab
BUILD_DEPENDS= gem:devel/ruby-gems \
go>=1.5.3:lang/go
+USE_GITLAB= yes
+GL_ACCOUNT= gitlab-org
+# Find the commit hash here: https://gitlab.com/gitlab-org/gitlab-shell/tags
+GL_COMMIT= ec2806f1f2ad10b7ec68b1835c54c11915387a6a
+
USERS= git
GROUPS= git
-post-extract:
- @${MV} ${WRKDIR}/${DISTNAME}-* ${WRKDIR}/${DISTNAME}
-
post-patch:
${MV} ${WRKSRC}/config.yml.example ${WRKSRC}/config.yml.sample
+do-build:
+ export GOCACHE=${WRKSRC}/go && ${WRKSRC}/bin/compile
+
pre-install:
- ${WRKSRC}/bin/compile
${RM} -rf ${WRKSRC}/go
${RM} -rf ${WRKSRC}/go_build
diff --git a/devel/gitlab-shell/distinfo b/devel/gitlab-shell/distinfo
index 322f8e47b85..e5c166eff2a 100644
--- a/devel/gitlab-shell/distinfo
+++ b/devel/gitlab-shell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516803476
-SHA256 (gitlab-shell-v5.11.0.tar.gz) = b63cba3452f82d719ebbc74a3cf95314d38051327dfe38def3fe6a04e56a9929
-SIZE (gitlab-shell-v5.11.0.tar.gz) = 714049
+TIMESTAMP = 1522769153
+SHA256 (gitlab-org-gitlab-shell-ec2806f1f2ad10b7ec68b1835c54c11915387a6a_GL0.tar.gz) = f68d6f6925e2d54e5ff8acac8c0b5f47ab5804492e363bb097fd3b19b7e405c2
+SIZE (gitlab-org-gitlab-shell-ec2806f1f2ad10b7ec68b1835c54c11915387a6a_GL0.tar.gz) = 782621
diff --git a/devel/gitlab-shell/files/patch-config.yml.example b/devel/gitlab-shell/files/patch-config.yml.example
index 1e950ff8886..e508ca8003d 100644
--- a/devel/gitlab-shell/files/patch-config.yml.example
+++ b/devel/gitlab-shell/files/patch-config.yml.example
@@ -1,6 +1,15 @@
---- config.yml.example.orig 2016-07-26 21:04:16 UTC
+--- config.yml.example.orig 2018-02-06 17:56:45 UTC
+++ config.yml.example
-@@ -43,7 +43,7 @@ redis:
+@@ -25,7 +25,7 @@ http_settings:
+ self_signed_cert: false
+
+ # File used as authorized_keys for gitlab user
+-auth_file: "/home/git/.ssh/authorized_keys"
++auth_file: "/usr/home/git/.ssh/authorized_keys"
+
+ # File that contains the secret key for verifying access to GitLab.
+ # Default is .gitlab_shell_secret in the gitlab-shell directory.
+@@ -37,7 +37,7 @@ auth_file: "/home/git/.ssh/authorized_ke
# Log file.
# Default is gitlab-shell.log in the root directory.
diff --git a/devel/gitlab-shell/pkg-plist b/devel/gitlab-shell/pkg-plist
index 6327d577b44..66b46874097 100644
--- a/devel/gitlab-shell/pkg-plist
+++ b/devel/gitlab-shell/pkg-plist
@@ -9,7 +9,6 @@
%%DATADIR%%/Gemfile.lock
%%DATADIR%%/Guardfile
%%DATADIR%%/LICENSE
-%%DATADIR%%/Makefile
%%DATADIR%%/README.md
%%DATADIR%%/VERSION
@(,,555) %%DATADIR%%/bin/authorized_keys
@@ -19,7 +18,6 @@
@(,,555) %%DATADIR%%/bin/gitaly-upload-pack
@(,,555) %%DATADIR%%/bin/gitaly-receive-pack
@(,,555) %%DATADIR%%/bin/gitlab-keys
-@(,,555) %%DATADIR%%/bin/gitlab-projects
@(,,555) %%DATADIR%%/bin/gitlab-shell
@(,,555) %%DATADIR%%/bin/gitlab-shell-authorized-keys-check
@(,,555) %%DATADIR%%/bin/install
@@ -38,28 +36,10 @@
%%DATADIR%%/lib/gitlab_metrics.rb
%%DATADIR%%/lib/gitlab_net.rb
%%DATADIR%%/lib/gitlab_post_receive.rb
-%%DATADIR%%/lib/gitlab_projects.rb
-%%DATADIR%%/lib/gitlab_redis.rb
-%%DATADIR%%/lib/gitlab_reference_counter.rb
%%DATADIR%%/lib/gitlab_shell.rb
%%DATADIR%%/lib/httpunix.rb
%%DATADIR%%/lib/names_helper.rb
%%DATADIR%%/lib/object_dirs_helper.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/client.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection/command_helper.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection/hiredis.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection/registry.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection/ruby.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/connection/synchrony.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/distributed.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/errors.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/hash_ring.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/pipeline.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/subscribe.rb
-%%DATADIR%%/lib/vendor/redis/lib/redis/version.rb
-%%DATADIR%%/spec/fixtures/gitlab_config_redis.yml
%%DATADIR%%/spec/gitlab_access_spec.rb
%%DATADIR%%/spec/gitlab_config_spec.rb
%%DATADIR%%/spec/gitlab_custom_hook_spec.rb
@@ -69,8 +49,6 @@
%%DATADIR%%/spec/gitlab_metrics_spec.rb
%%DATADIR%%/spec/gitlab_net_spec.rb
%%DATADIR%%/spec/gitlab_post_receive_spec.rb
-%%DATADIR%%/spec/gitlab_projects_spec.rb
-%%DATADIR%%/spec/gitlab_reference_counter_spec.rb
%%DATADIR%%/spec/gitlab_shell_authorized_keys_check_spec.rb
%%DATADIR%%/spec/gitlab_shell_spec.rb
%%DATADIR%%/spec/httpunix_spec.rb