aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2017-04-18 23:15:06 +0800
committerak <ak@FreeBSD.org>2017-04-18 23:15:06 +0800
commit8b9ddc92a3b8adbe7a4760799b3c915a6f0bb94f (patch)
tree10deab438978a080be185166041c3a8110e6725d
parente2f332dca5c8032cdb3a5ff4b31b7039063a9c6c (diff)
downloadfreebsd-ports-graphics-8b9ddc92a3b8adbe7a4760799b3c915a6f0bb94f.tar.gz
freebsd-ports-graphics-8b9ddc92a3b8adbe7a4760799b3c915a6f0bb94f.tar.zst
freebsd-ports-graphics-8b9ddc92a3b8adbe7a4760799b3c915a6f0bb94f.zip
- Remove vestiges of pkg-req support
Differential Revision: https://reviews.freebsd.org/D5 Approved by: bapt
-rw-r--r--mail/imap-uw/Makefile6
-rw-r--r--mail/imap-uw/files/pkg-req.rev (renamed from mail/imap-uw/pkg-req.rev)0
-rw-r--r--mail/imap-uw/files/pkg-req.ssl (renamed from mail/imap-uw/pkg-req.ssl)0
-rw-r--r--mail/milter-bogom/pkg-req35
-rw-r--r--mail/panda-imap/Makefile6
-rw-r--r--mail/panda-imap/files/pkg-req.rev (renamed from mail/panda-imap/pkg-req.rev)0
-rw-r--r--mail/panda-imap/files/pkg-req.ssl (renamed from mail/panda-imap/pkg-req.ssl)0
7 files changed, 6 insertions, 41 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 208c753b61c..5d3f208480a 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -72,11 +72,11 @@ post-patch:
@${RM} ${WRKSRC}/docs/imaprc.txt.bak
pre-build:
- @${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
+ @${SH} ${FILESDIR}/pkg-req.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
.if ${PORT_OPTIONS:MSSL}
- @${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h yes
+ @${SH} ${FILESDIR}/pkg-req.ssl ${LOCALBASE}/include/c-client/portrevision.h yes
.else
- @${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h no
+ @${SH} ${FILESDIR}/pkg-req.ssl ${LOCALBASE}/include/c-client/portrevision.h no
.endif
do-install:
diff --git a/mail/imap-uw/pkg-req.rev b/mail/imap-uw/files/pkg-req.rev
index 33ce1bc506f..33ce1bc506f 100644
--- a/mail/imap-uw/pkg-req.rev
+++ b/mail/imap-uw/files/pkg-req.rev
diff --git a/mail/imap-uw/pkg-req.ssl b/mail/imap-uw/files/pkg-req.ssl
index 881c5ef9049..881c5ef9049 100644
--- a/mail/imap-uw/pkg-req.ssl
+++ b/mail/imap-uw/files/pkg-req.ssl
diff --git a/mail/milter-bogom/pkg-req b/mail/milter-bogom/pkg-req
deleted file mode 100644
index d4abc371761..00000000000
--- a/mail/milter-bogom/pkg-req
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-need_milter() {
-
-echo "****************************************************************"
-echo "* You need at least the version 8.13 of sendmail compiled with *"
-echo "* milter support enabled. *"
-echo "****************************************************************"
-exit 1;
-
-}
-
-# check if we are not installing
-if [ "$2" != "INSTALL" ];
-then
- exit 0;
-fi
-
-# check if sendmail have the MILTER API
-sendmail -d0.1 -bv root 2>&1 | grep MILTER > /dev/null
-
-if [ $? != 0 ];
-then
- need_milter;
-fi
-
-# Check if sendmail is at least 8.13
-sendmail -d0.1 -bv root 2>& 1 | grep Version | awk '{ if ( $2 > "8.13" )\
-exit 0; else exit 1;}'
-
-if [ $? != 0 ];
-then
- need_milter;
-fi
-exit 0
diff --git a/mail/panda-imap/Makefile b/mail/panda-imap/Makefile
index f6431c12b1a..e81de4aa61e 100644
--- a/mail/panda-imap/Makefile
+++ b/mail/panda-imap/Makefile
@@ -69,11 +69,11 @@ post-patch:
@${RM} ${WRKSRC}/docs/imaprc.txt.bak
pre-build:
- @${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
+ @${SH} ${FILESDIR}/pkg-req.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
.if ${PORT_OPTIONS:MSSL}
- @${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h yes
+ @${SH} ${FILESDIR}/pkg-req.ssl ${LOCALBASE}/include/c-client/portrevision.h yes
.else
- @${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h no
+ @${SH} ${FILESDIR}/pkg-req.ssl ${LOCALBASE}/include/c-client/portrevision.h no
.endif
do-install:
diff --git a/mail/panda-imap/pkg-req.rev b/mail/panda-imap/files/pkg-req.rev
index 33ce1bc506f..33ce1bc506f 100644
--- a/mail/panda-imap/pkg-req.rev
+++ b/mail/panda-imap/files/pkg-req.rev
diff --git a/mail/panda-imap/pkg-req.ssl b/mail/panda-imap/files/pkg-req.ssl
index 881c5ef9049..881c5ef9049 100644
--- a/mail/panda-imap/pkg-req.ssl
+++ b/mail/panda-imap/files/pkg-req.ssl