aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-05 18:36:04 +0800
committerrakuco <rakuco@FreeBSD.org>2017-08-05 18:36:04 +0800
commitc648367b19e91e1ab4b9c1b1b006cafac21a46b1 (patch)
tree31cf3133b0ebe0c6c20d27dd327a738aa8740804
parentf2f6eea602d15183a14749b0cf24bbab2353d2cc (diff)
downloadfreebsd-ports-graphics-c648367b19e91e1ab4b9c1b1b006cafac21a46b1.tar.gz
freebsd-ports-graphics-c648367b19e91e1ab4b9c1b1b006cafac21a46b1.tar.zst
freebsd-ports-graphics-c648367b19e91e1ab4b9c1b1b006cafac21a46b1.zip
Explicitly build with -std=gnu++03.
This was the default for GCC until version 6, which switched to -std=gnu++14. This project is unmaintained upstream and it is not worth fixing the code instead of just building with the standard it's always worked with. PR: 219299 Approved by: portmgr (blanket approval)
-rw-r--r--graphics/pfstmo/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/pfstmo/Makefile b/graphics/pfstmo/Makefile
index 601ffe7af8a..bea494a63bb 100644
--- a/graphics/pfstmo/Makefile
+++ b/graphics/pfstmo/Makefile
@@ -26,5 +26,8 @@ CONFIGURE_ENV+= CPPFLAGS="${PFS_CPPFLAGS} ${DEBUG_FLAGS}" \
LDFLAGS="${PFS_LDFLAGS}"
USES= gmake pkgconfig compiler:openmp
+# GCC 6 defaults to -std=gnu++14, and the port does not build with C++11 or
+# later (bug 219299).
+USE_CXXSTD= gnu++03
.include <bsd.port.mk>