aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-02-16 06:19:06 +0800
committerpi <pi@FreeBSD.org>2018-02-16 06:19:06 +0800
commitc884ab128fca828f28ff7a3e10326689b23830e2 (patch)
tree52283bdea8af16cd77c8a8b25785f9745a66a64e
parent75b29768110abc49dcb4b7583928023a6949e64b (diff)
downloadfreebsd-ports-graphics-c884ab128fca828f28ff7a3e10326689b23830e2.tar.gz
freebsd-ports-graphics-c884ab128fca828f28ff7a3e10326689b23830e2.tar.zst
freebsd-ports-graphics-c884ab128fca828f28ff7a3e10326689b23830e2.zip
net/quagga-esr: removed, use net/quagga in version 1.2.3
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/quagga-esr/Makefile107
-rw-r--r--net/quagga-esr/distinfo3
-rw-r--r--net/quagga-esr/files/extra-patch-ospf-nexthop184
-rw-r--r--net/quagga-esr/files/patch-bgpd__bgp_aspath.c11
-rw-r--r--net/quagga-esr/files/patch-configure11
-rw-r--r--net/quagga-esr/files/patch-doc_bgpd.821
-rw-r--r--net/quagga-esr/files/patch-vtysh_extract.pl.in11
-rw-r--r--net/quagga-esr/files/quagga.in148
-rw-r--r--net/quagga-esr/files/watchquagga.in30
-rw-r--r--net/quagga-esr/pkg-descr8
-rw-r--r--net/quagga-esr/pkg-message13
-rw-r--r--net/quagga-esr/pkg-plist98
14 files changed, 1 insertions, 646 deletions
diff --git a/MOVED b/MOVED
index 3ba35281864..ee79b241b99 100644
--- a/MOVED
+++ b/MOVED
@@ -9964,3 +9964,4 @@ net-mgmt/prometheus|net-mgmt/prometheus1|2018-02-14|Rename to include major vers
textproc/rubygem-tidy||2018-02-14|Has expired: No longer needed and not maintained
www/rubygem-scrapi||2018-02-14|Has expired: No longer maintained upstream
devel/boost-python3-libs|devel/boost-python-libs@py36|2018-02-15|Flavorize
+net/quagga-esr|net/quagga|2018-02-15|Fixes available, go back to the regular quagga
diff --git a/net/Makefile b/net/Makefile
index 185e03279a9..3536a4d6102 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1109,7 +1109,6 @@
SUBDIR += qt5-network
SUBDIR += qtweetlib
SUBDIR += quagga
- SUBDIR += quagga-esr
SUBDIR += queso
SUBDIR += quiterss
SUBDIR += quoted
diff --git a/net/quagga-esr/Makefile b/net/quagga-esr/Makefile
deleted file mode 100644
index ef54005b773..00000000000
--- a/net/quagga-esr/Makefile
+++ /dev/null
@@ -1,107 +0,0 @@
-# Created by: Bruce M Simpson <bms@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= quagga
-PORTVERSION= 0.99.24.1
-CATEGORIES= net ipv6
-MASTER_SITES= SAVANNAH
-PKGNAMESUFFIX= -esr
-
-MAINTAINER= pi@FreeBSD.org
-COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4, IS-IS route software
-
-LICENSE= GPLv2
-
-BUILD_DEPENDS= gawk:lang/gawk
-
-CONFLICTS= openbgpd openospfd zebra quagga frr pimd
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
-INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline compiler:c11 cpe
-USE_LDCONFIG= yes
-USE_PERL5= build
-
-INFO= quagga
-
-OPTIONS_DEFINE= ISISD PIMD PAM RTADV SNMP TCPSOCKETS DLMALLOC \
- NO_BGP_ANNOUNCE OSPF_NEXTHOP ISIS_TOPOLOGY
-# IRDP needs something freebsd does not seem to have:
-# configure: error: 'IRDP requires in_pktinfo at the moment!'
-OPTIONS_DEFAULT= ISISD PIMD RTADV
-OPTIONS_SUB= yes
-
-PIMD_DESC= PIM-SSM multicast routing
-IRDP_DESC= Enable IRDP server support
-ISISD_DESC= Enable ISIS daemon (beta)
-ISIS_TOPOLOGY_DESC= Enable IS-IS topology generator
-PAM_DESC= PAM authentication for vtysh
-RTADV_DESC= IPv6 Router Advertisements
-TCPSOCKETS_DESC= Use TCP/IP sockets for protocol daemons
-DLMALLOC_DESC= Use dlmalloc (makes bgpd much faster)
-NO_BGP_ANNOUNCE_DESC= Turn off BGP route announcement
-OSPF_NEXTHOP_DESC= Set ip next-hop in OSPF route maps
-
-ENABLE_USER?= quagga
-ENABLE_GROUP?= quagga
-
-USERS= ${ENABLE_USER}
-GROUPS= ${ENABLE_GROUP}
-
-SYSCONF_DIR?= ${ETCDIR}
-LOCALSTATE_DIR?=/var/run/quagga
-
-CONFIGURE_ARGS= --enable-user=${ENABLE_USER} \
- --enable-group=${ENABLE_GROUP} \
- --sysconfdir=${SYSCONF_DIR} \
- --localstatedir=${LOCALSTATE_DIR} \
- --enable-vtysh
-
-.if defined(ENABLE_VTY_GROUP)
-CONFIGURE_ARGS+=--enable-vty-group=${ENABLE_VTY_GROUP}
-.endif
-
-ISISD_CONFIGURE_ENABLE= isisd
-ISIS_TOPOLOGY_CONFIGURE_ENABLE= isis-topology
-PIMD_CONFIGURE_ENABLE= pimd
-IRDP_CONFIGURE_ENABLE= irdp
-PAM_CONFIGURE_WITH= libpam
-RTADV_CONFIGURE_ENABLE= rtadv
-SNMP_CONFIGURE_ENABLE= snmp
-SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
-TCPSOCKETS_CONFIGURE_ENABLE= tcp-zebra
-DLMALLOC_LIB_DEPENDS= libdlmalloc.so:devel/libdlmalloc
-DLMALLOC_LIBS= -L${LOCALBASE}/lib -ldlmalloc
-OSPF_NEXTHOP_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ospf-nexthop
-# inverse option.
-NO_BGP_ANNOUNCE_CONFIGURE_ON= --disable-bgp-announce
-NO_BGP_ANNOUNCE_CONFIGURE_OFF= --enable-bgp-announce
-
-USE_RC_SUBR= quagga watchquagga
-
-SUB_LIST+= LOCALSTATE_DIR=${LOCALSTATE_DIR} \
- SYSCONF_DIR=${SYSCONF_DIR}
-
-PLIST_SUB+= LOCALSTATE_DIR=${LOCALSTATE_DIR} \
- SYSCONF_DIR=${SYSCONF_DIR} \
- ENABLE_USER=${ENABLE_USER} \
- ENABLE_GROUP=${ENABLE_GROUP}
-
-pre-everything::
- @${ECHO} "============================================================="
- @${ECHO}
- @${ECHO} "You can build ${PORTNAME} with the following options:"
- @${ECHO}
- @${ECHO} "ENABLE_USER Specify user to run Quagga suite as"
- @${ECHO} "ENABLE_GROUP Specify group to run Quagga suite as"
- @${ECHO} "ENABLE_VTY_GROUP Specify group for vty socket ownership"
- @${ECHO} "SYSCONF_DIR Specify directory for Quagga configuration files"
- @${ECHO} "LOCALSTATE_DIR Specify directory for Quagga runtime files"
-
-post-install:
- ${MKDIR} ${STAGEDIR}${LOCALSTATE_DIR} ${STAGEDIR}${SYSCONF_DIR} \
- ${STAGEDIR}${EXAMPLESDIR}
- @${MV} ${STAGEDIR}${SYSCONF_DIR}/* ${STAGEDIR}${EXAMPLESDIR}
-
-.include <bsd.port.mk>
diff --git a/net/quagga-esr/distinfo b/net/quagga-esr/distinfo
deleted file mode 100644
index 1abb6b5ba5f..00000000000
--- a/net/quagga-esr/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1491761954
-SHA256 (quagga-0.99.24.1.tar.gz) = 84ae1a47df085119a8fcab6c43ccea9efb9bc3112388b1dece5a9f0a0262754f
-SIZE (quagga-0.99.24.1.tar.gz) = 2683800
diff --git a/net/quagga-esr/files/extra-patch-ospf-nexthop b/net/quagga-esr/files/extra-patch-ospf-nexthop
deleted file mode 100644
index 87fb9f456da..00000000000
--- a/net/quagga-esr/files/extra-patch-ospf-nexthop
+++ /dev/null
@@ -1,184 +0,0 @@
---- ospfd/ospf_asbr.c.orig 2016-10-18 13:03:52 UTC
-+++ ospfd/ospf_asbr.c
-@@ -122,6 +122,7 @@ ospf_reset_route_map_set_values (struct
- {
- values->metric = -1;
- values->metric_type = -1;
-+ values->nexthop.s_addr = -1;
- }
-
- int
---- ospfd/ospf_asbr.h.orig 2016-10-18 13:03:52 UTC
-+++ ospfd/ospf_asbr.h
-@@ -27,6 +27,7 @@ struct route_map_set_values
- {
- int32_t metric;
- int32_t metric_type;
-+ struct in_addr nexthop;
- };
-
- /* Redistributed external information. */
-@@ -50,6 +51,7 @@ struct external_info
- struct route_map_set_values route_map_set;
- #define ROUTEMAP_METRIC(E) (E)->route_map_set.metric
- #define ROUTEMAP_METRIC_TYPE(E) (E)->route_map_set.metric_type
-+#define ROUTEMAP_NEXTHOP(E) (E)->route_map_set.nexthop
- };
-
- #define OSPF_ASBR_CHECK_DELAY 30
---- ospfd/ospf_lsa.c.orig 2016-10-18 13:03:52 UTC
-+++ ospfd/ospf_lsa.c
-@@ -1644,7 +1644,8 @@ ospf_external_lsa_body_set (struct strea
- stream_put_ospf_metric (s, mvalue);
-
- /* Get forwarding address to nexthop if on the Connection List, else 0. */
-- fwd_addr = ospf_external_lsa_nexthop_get (ospf, ei->nexthop);
-+ fwd_addr = (ei->route_map_set.nexthop.s_addr != -1) ?
-+ ROUTEMAP_NEXTHOP (ei) : ospf_external_lsa_nexthop_get (ospf, ei->nexthop);
-
- /* Put forwarding address. */
- stream_put_ipv4 (s, fwd_addr.s_addr);
---- ospfd/ospf_routemap.c.orig 2016-10-18 13:03:52 UTC
-+++ ospfd/ospf_routemap.c
-@@ -668,6 +668,62 @@ struct route_map_rule_cmd route_set_tag_
- route_set_tag_free,
- };
-
-+/* `set ip next-hop IP_ADDRESS' */
-+/* Set nexthop to object. */
-+static route_map_result_t
-+route_set_ip_nexthop (void *rule, struct prefix *prefix,
-+ route_map_object_t type, void *object)
-+{
-+ struct in_addr *address;
-+ struct external_info *ei;
-+
-+ if (type == RMAP_OSPF)
-+ {
-+ /* Fetch routemap's rule information. */
-+ address = rule;
-+ ei = object;
-+
-+ /* Set metric out value. */
-+ ei->route_map_set.nexthop = *address;
-+ }
-+ return RMAP_OKAY;
-+}
-+
-+/* set ip next-hop compilation. */
-+static void *
-+route_set_ip_nexthop_compile (const char *arg)
-+{
-+ struct in_addr *address = NULL;
-+ int ret;
-+
-+ address = XMALLOC (MTYPE_ROUTE_MAP_COMPILED, sizeof (struct in_addr));
-+ ret = inet_aton (arg, address);
-+
-+ if (ret == 0)
-+ {
-+ XFREE (MTYPE_ROUTE_MAP_COMPILED, address);
-+ return NULL;
-+ }
-+
-+ return address;
-+}
-+
-+/* Free route map's compiled `set ip next-hop' value. */
-+static void
-+route_set_ip_nexthop_free (void *rule)
-+{
-+ XFREE (MTYPE_ROUTE_MAP_COMPILED, rule);
-+}
-+
-+/* Set ip next-hop rule structure. */
-+struct route_map_rule_cmd route_set_ip_nexthop_cmd =
-+{
-+ "ip next-hop",
-+ route_set_ip_nexthop,
-+ route_set_ip_nexthop_compile,
-+ route_set_ip_nexthop_free,
-+};
-+
- DEFUN (match_ip_nexthop,
- match_ip_nexthop_cmd,
- "match ip next-hop (<1-199>|<1300-2699>|WORD)",
-@@ -984,6 +1040,49 @@ ALIAS (no_set_tag,
- "Tag value for routing protocol\n"
- "Tag value\n")
-
-+DEFUN (set_ip_nexthop,
-+ set_ip_nexthop_cmd,
-+ "set ip next-hop A.B.C.D",
-+ SET_STR
-+ IP_STR
-+ "Next hop address\n"
-+ "IP address of next hop\n")
-+{
-+ union sockunion su;
-+ int ret;
-+
-+ ret = str2sockunion (argv[0], &su);
-+ if (ret < 0)
-+ {
-+ vty_out (vty, "%% Malformed Next-hop address%s", VTY_NEWLINE);
-+ return CMD_WARNING;
-+ }
-+
-+ return ospf_route_set_add (vty, vty->index, "ip next-hop", argv[0]);
-+}
-+
-+DEFUN (no_set_ip_nexthop,
-+ no_set_ip_nexthop_cmd,
-+ "no set ip next-hop",
-+ NO_STR
-+ SET_STR
-+ "Next hop address\n")
-+{
-+ if (argc == 0)
-+ return ospf_route_set_delete (vty, vty->index, "ip next-hop", NULL);
-+
-+ return ospf_route_set_delete (vty, vty->index, "ip next-hop", argv[0]);
-+}
-+
-+ALIAS (no_set_ip_nexthop,
-+ no_set_ip_nexthop_val_cmd,
-+ "no set ip next-hop A.B.C.D",
-+ NO_STR
-+ SET_STR
-+ IP_STR
-+ "Next hop address\n"
-+ "IP address of next hop\n")
-+
- /* Route-map init */
- void
- ospf_route_map_init (void)
-@@ -1005,6 +1104,7 @@ ospf_route_map_init (void)
- route_map_install_set (&route_set_metric_cmd);
- route_map_install_set (&route_set_metric_type_cmd);
- route_map_install_set (&route_set_tag_cmd);
-+ route_map_install_set (&route_set_ip_nexthop_cmd);
-
- install_element (RMAP_NODE, &match_ip_nexthop_cmd);
- install_element (RMAP_NODE, &no_match_ip_nexthop_cmd);
-@@ -1031,6 +1131,9 @@ ospf_route_map_init (void)
- install_element (RMAP_NODE, &set_metric_type_cmd);
- install_element (RMAP_NODE, &no_set_metric_type_cmd);
- install_element (RMAP_NODE, &no_set_metric_type_val_cmd);
-+ install_element (RMAP_NODE, &set_ip_nexthop_cmd);
-+ install_element (RMAP_NODE, &no_set_ip_nexthop_cmd);
-+ install_element (RMAP_NODE, &no_set_ip_nexthop_val_cmd);
- install_element (RMAP_NODE, &set_tag_cmd);
- install_element (RMAP_NODE, &no_set_tag_cmd);
- install_element (RMAP_NODE, &no_set_tag_val_cmd);
---- vtysh/extract.pl.in.orig 2016-10-20 11:59:56 UTC
-+++ vtysh/extract.pl.in
-@@ -180,7 +180,7 @@ foreach (@ARGV) {
- }
- }
-
--my $bad_cli_stomps = 102;
-+my $bad_cli_stomps = 105;
- # Currently we have $bad_cli_stomps. This was determined by
- # running this script and counting up the collisions from what
- # was returned.
diff --git a/net/quagga-esr/files/patch-bgpd__bgp_aspath.c b/net/quagga-esr/files/patch-bgpd__bgp_aspath.c
deleted file mode 100644
index 7b2b9ed7c8a..00000000000
--- a/net/quagga-esr/files/patch-bgpd__bgp_aspath.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bgpd/bgp_aspath.c.orig 2017-03-10 12:55:06 UTC
-+++ bgpd/bgp_aspath.c
-@@ -903,7 +903,7 @@ aspath_put (struct stream *s, struct aspath *as, int u
- assegment_header_put (s, seg->type, AS_SEGMENT_MAX);
- assegment_data_put (s, seg->as, AS_SEGMENT_MAX, use32bit);
- written += AS_SEGMENT_MAX;
-- bytes += ASSEGMENT_SIZE (written, use32bit);
-+ bytes += ASSEGMENT_SIZE (AS_SEGMENT_MAX, use32bit);
- }
-
- /* write the final segment, probably is also the first */
diff --git a/net/quagga-esr/files/patch-configure b/net/quagga-esr/files/patch-configure
deleted file mode 100644
index 7fa6e377857..00000000000
--- a/net/quagga-esr/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2016-10-18 13:06:39 UTC
-+++ configure
-@@ -19874,7 +19874,7 @@ fi
-
-
-
--if test "${enable_snmp}" != ""; then
-+if test "x${enable_snmp}" != "xno"; then
- if test -n "$ac_tool_prefix"; then
- # Extract the first word of "${ac_tool_prefix}net-snmp-config", so it can be a program name with args.
- set dummy ${ac_tool_prefix}net-snmp-config; ac_word=$2
diff --git a/net/quagga-esr/files/patch-doc_bgpd.8 b/net/quagga-esr/files/patch-doc_bgpd.8
deleted file mode 100644
index 54e50a1a970..00000000000
--- a/net/quagga-esr/files/patch-doc_bgpd.8
+++ /dev/null
@@ -1,21 +0,0 @@
---- doc/bgpd.8.orig 2016-10-18 13:03:52 UTC
-+++ doc/bgpd.8
-@@ -28,6 +28,8 @@ software
- ] [
- .B \-g
- .I group
-+] [
-+.B \--no_kernel
- ]
- .SH DESCRIPTION
- .B bgpd
-@@ -79,6 +81,9 @@ Skip setting the process effective user
- .TP
- \fB\-v\fR, \fB\-\-version\fR
- Print the version and exit.
-+.TP
-+\fB\--no_kernel\fR
-+Prevents route updates to be submitted to the kernel.
- .SH FILES
- .TP
- .BI /usr/local/sbin/bgpd
diff --git a/net/quagga-esr/files/patch-vtysh_extract.pl.in b/net/quagga-esr/files/patch-vtysh_extract.pl.in
deleted file mode 100644
index 44ddef59d4f..00000000000
--- a/net/quagga-esr/files/patch-vtysh_extract.pl.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- vtysh/extract.pl.in.orig 2016-10-18 13:03:52 UTC
-+++ vtysh/extract.pl.in
-@@ -69,7 +69,7 @@ my $cli_stomp = 0;
- foreach (@ARGV) {
- $file = $_;
-
-- open (FH, "@CPP@ -DHAVE_CONFIG_H -DVTYSH_EXTRACT_PL -DHAVE_IPV6 -I@top_builddir@ -I@srcdir@/ -I@srcdir@/.. -I@top_srcdir@/lib -I@top_builddir@/lib -I@top_srcdir@/isisd/topology @CPPFLAGS@ $file |");
-+ open (FH, "@CPP@ -DHAVE_CONFIG_H -DVTYSH_EXTRACT_PL -DHAVE_IPV6 -I@top_builddir@ -I@srcdir@/ -I@srcdir@/.. -I@top_srcdir@/lib -I@top_builddir@/lib -I/usr/local/include -I@top_srcdir@/isisd/topology @CPPFLAGS@ $file |");
- local $/; undef $/;
- $line = <FH>;
- close (FH);
diff --git a/net/quagga-esr/files/quagga.in b/net/quagga-esr/files/quagga.in
deleted file mode 100644
index a092650dedc..00000000000
--- a/net/quagga-esr/files/quagga.in
+++ /dev/null
@@ -1,148 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: quagga
-# REQUIRE: netif routing
-# KEYWORD: nojail shutdown
-
-# Add the following line to /etc/rc.conf to enable quagga:
-# quagga_enable="YES"
-#
-# You may also wish to use the following variables to fine-tune startup:
-# quagga_flags=""
-# quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"
-# quagga_vysh_boot="YES"
-# Per daemon tuning may be done with daemon_name_flags
-# zebra_flags="-P 0"
-# bgpd_flags="-nrP 0" and so on
-# If you want to give the routing deamons a chance to catchup before
-# continueing, set quagga_wait_for to a "default" or certain prefix.
-# quagga_wait_for="default"
-# Set the time limit for the wait.
-# quagga_wait_seconds="90"
-#
-# If the quagga daemons require additional shared libraries to start,
-# use the following variable to run ldconfig(8) in advance:
-# quagga_extralibs_path="/usr/local/lib ..."
-#
-
-. /etc/rc.subr
-
-name=quagga
-rcvar=quagga_enable
-
-start_postcmd=start_postcmd
-stop_postcmd="rm -f $pidfile"
-configtest_cmd=check_config
-extra_commands=configtest
-command_args="-d"
-
-load_rc_config $name
-
-quagga_enable=${quagga_enable:-"NO"}
-quagga_flags=${quagga_flags:-""}
-quagga_daemons=${quagga_daemons:-"zebra ripd ripngd ospfd ospf6d bgpd isisd"}
-quagga_vtysh_boot=${quagga_vtysh_boot:-"NO"}
-quagga_wait_for=${quagga_wait_for:-""}
-quagga_wait_seconds=${quagga_wait_seconds:-"90"}
-
-check_config()
-{
- echo "Checking $daemon.conf"
- $command $daemon_flags -C
- result=$?
- if [ "$result" -eq "0" ]; then
- echo "OK"
- else
- echo "FAILED"
- exit
- fi
-}
-
-start_postcmd()
-{
- local waited_for
- waited_for=0
- # Wait only when last daemon has started.
- if [ "${quagga_daemons}" = "${quagga_daemons% ${name}}" ]; then
- return;
- fi
- if [ -n "${quagga_wait_for}" ]; then
- echo Waiting for ${quagga_wait_for} route...
- while [ ${waited_for} -lt ${quagga_wait_seconds} ]; do
- /sbin/route -n get ${quagga_wait_for} >/dev/null 2>&1 && break;
- waited_for=$((${waited_for}+1))
- sleep 1;
- done
- [ ${waited_for} -lt ${quagga_wait_seconds} ] || echo Giving up...
- fi
-}
-
-do_cmd()
-{
- local ret
- ret=0
- for daemon in ${quagga_daemons}; do
- command=%%PREFIX%%/sbin/${daemon}
- required_files=%%SYSCONF_DIR%%/${daemon}.conf
- pidfile=%%LOCALSTATE_DIR%%/${daemon}.pid
- if [ ${quagga_cmd} = "restart" -o ${quagga_cmd} = "start" ]; then
- check_config
- fi
- if [ ${quagga_cmd} = "start" -a ! -f ${required_files} ]; then
- continue
- fi
- if [ ${quagga_cmd} = "stop" -a -z $(check_process ${command}) ]; then
- continue
- fi
- eval flags=\$\{${daemon}_flags:-\"${quagga_flags}\"\}
- name=${daemon}
- _rc_restart_done=false
- run_rc_command "$1" || ret=1
- done
- if checkyesno quagga_vtysh_boot; then
- echo "Booting for integrated-vtysh-config..."
- %%PREFIX%%/bin/vtysh -b
- fi
- return ${ret}
-}
-
-quagga_cmd=$1
-
-case "$1" in
- force*)
- quagga_cmd=${quagga_cmd#force}
- ;;
- fast*)
- quagga_cmd=${quagga_cmd#fast}
- ;;
-esac
-shift
-
-if [ $# -ge 1 ]; then
- quagga_daemons="$*"
-fi
-
-case "${quagga_cmd}" in
- start)
- if [ -n "${quagga_extralibs_path}" ]; then
- /sbin/ldconfig -m ${quagga_extralibs_path}
- fi
- do_cmd "start"
- ;;
- stop)
- quagga_daemons=$(reverse_list ${quagga_daemons})
- do_cmd "stop"
- ;;
- restart)
- quagga_daemons=$(reverse_list ${quagga_daemons})
- do_cmd "stop"
- quagga_daemons=$(reverse_list ${quagga_daemons})
- do_cmd "start"
- ;;
- *)
- do_cmd "${quagga_cmd}"
- ;;
-esac
diff --git a/net/quagga-esr/files/watchquagga.in b/net/quagga-esr/files/watchquagga.in
deleted file mode 100644
index 9e6f23dd472..00000000000
--- a/net/quagga-esr/files/watchquagga.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: watchquagga
-# REQUIRE: NETWORKING quagga
-# KEYWORD: shutdown
-
-# Add the following line to /etc/rc.conf to enable watchquagga:
-# watchquagga_enable="YES"
-#
-# You may also wish to use the following variables to fine-tune startup:
-# watchquagga_flags
-
-. /etc/rc.subr
-
-name=watchquagga
-rcvar=watchquagga_enable
-
-load_rc_config $name
-
-stop_postcmd="rm -f $pidfile"
-
-watchquagga_enable=${watchquagga_enable:-"NO"}
-
-command=%%PREFIX%%/sbin/watchquagga
-pidfile=%%LOCALSTATE_DIR%%/watchquagga.pid
-
-run_rc_command "$1"
diff --git a/net/quagga-esr/pkg-descr b/net/quagga-esr/pkg-descr
deleted file mode 100644
index 2ec7ce95d46..00000000000
--- a/net/quagga-esr/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Quagga is a routing software suite, providing implementations of
-OSPFv2, OSPFv3, RIP v1 and v2, RIPv3, BGPv4 and experemental ISIS
-for Unix platforms, particularly FreeBSD and Linux and also NetBSD,
-to mention a few. Quagga is a fork of GNU Zebra which was developed
-by KunihiroIshiguro. The Quagga tree aims to build a more involved
-community around Quagga than the current centralised model of GNU Zebra.
-
-WWW: http://www.quagga.net/
diff --git a/net/quagga-esr/pkg-message b/net/quagga-esr/pkg-message
deleted file mode 100644
index 054e520e177..00000000000
--- a/net/quagga-esr/pkg-message
+++ /dev/null
@@ -1,13 +0,0 @@
-==========================================================
-To enable quagga, add the following lines to rc.conf:
-
-defaultrouter="NO"
-quagga_enable="YES"
-
-Also, you may wish to set the following options:"
-quagga_daemons="zebra bgpd etc..."
-quagga_flags="...."
-quagga_extralibs_path="... ..."
-router_enable="NO"
-watchquagga_enable="YES"
-==========================================================
diff --git a/net/quagga-esr/pkg-plist b/net/quagga-esr/pkg-plist
deleted file mode 100644
index e48d7a536ad..00000000000
--- a/net/quagga-esr/pkg-plist
+++ /dev/null
@@ -1,98 +0,0 @@
-%%PIMD%%bin/test_igmpv3_join
-bin/vtysh
-sbin/babeld
-include/quagga/buffer.h
-include/quagga/checksum.h
-include/quagga/command.h
-include/quagga/distribute.h
-include/quagga/filter.h
-include/quagga/getopt.h
-include/quagga/hash.h
-include/quagga/if.h
-include/quagga/if_rmap.h
-include/quagga/jhash.h
-include/quagga/keychain.h
-include/quagga/libospf.h
-include/quagga/linklist.h
-include/quagga/log.h
-include/quagga/md5.h
-include/quagga/memory.h
-include/quagga/memtypes.h
-include/quagga/network.h
-include/quagga/ospfapi/ospf_apiclient.h
-include/quagga/ospfd/ospf_api.h
-include/quagga/ospfd/ospf_asbr.h
-include/quagga/ospfd/ospf_dump.h
-include/quagga/ospfd/ospf_ism.h
-include/quagga/ospfd/ospf_lsa.h
-include/quagga/ospfd/ospf_lsdb.h
-include/quagga/ospfd/ospf_nsm.h
-include/quagga/ospfd/ospf_opaque.h
-include/quagga/ospfd/ospfd.h
-include/quagga/plist.h
-include/quagga/pqueue.h
-include/quagga/prefix.h
-include/quagga/privs.h
-include/quagga/route_types.h
-include/quagga/routemap.h
-include/quagga/sigevent.h
-include/quagga/smux.h
-include/quagga/sockopt.h
-include/quagga/sockunion.h
-include/quagga/str.h
-include/quagga/stream.h
-include/quagga/table.h
-include/quagga/thread.h
-include/quagga/vector.h
-include/quagga/version.h
-include/quagga/vty.h
-include/quagga/workqueue.h
-include/quagga/zassert.h
-include/quagga/zclient.h
-include/quagga/zebra.h
-lib/libospf.a
-lib/libospf.so
-lib/libospf.so.0
-lib/libospf.so.0.0.0
-lib/libospfapiclient.a
-lib/libospfapiclient.so
-lib/libospfapiclient.so.0
-lib/libospfapiclient.so.0.0.0
-lib/libzebra.a
-lib/libzebra.so
-lib/libzebra.so.0
-lib/libzebra.so.0.0.0
-man/man1/vtysh.1.gz
-man/man8/bgpd.8.gz
-%%ISISD%%man/man8/isisd.8.gz
-man/man8/ospf6d.8.gz
-man/man8/ospfclient.8.gz
-man/man8/ospfd.8.gz
-%%PIMD%%man/man8/pimd.8.gz
-man/man8/ripd.8.gz
-man/man8/ripngd.8.gz
-man/man8/watchquagga.8.gz
-man/man8/zebra.8.gz
-sbin/bgpd
-%%ISISD%%sbin/isisd
-sbin/ospf6d
-sbin/ospfclient
-sbin/ospfd
-%%PIMD%%sbin/pimd
-sbin/ripd
-sbin/ripngd
-sbin/watchquagga
-sbin/zebra
-%%EXAMPLESDIR%%/babeld.conf.sample
-%%EXAMPLESDIR%%/bgpd.conf.sample
-%%EXAMPLESDIR%%/bgpd.conf.sample2
-%%ISISD%%%%EXAMPLESDIR%%/isisd.conf.sample
-%%EXAMPLESDIR%%/ospf6d.conf.sample
-%%EXAMPLESDIR%%/ospfd.conf.sample
-%%PIMD%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pimd.conf.sample
-%%EXAMPLESDIR%%/ripd.conf.sample
-%%EXAMPLESDIR%%/ripngd.conf.sample
-%%EXAMPLESDIR%%/vtysh.conf.sample
-%%EXAMPLESDIR%%/zebra.conf.sample
-@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%LOCALSTATE_DIR%%
-@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%SYSCONF_DIR%%