aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2014-04-30 12:47:25 +0800
committerjkim <jkim@FreeBSD.org>2014-04-30 12:47:25 +0800
commitdf940c62e46e0580091c82a8dedffb2fd4df0214 (patch)
tree4a23aded726b160afa6db6276278744c94712a76
parentd66f9b27cad29ccc4238caeb3836586c7de20210 (diff)
downloadfreebsd-ports-graphics-df940c62e46e0580091c82a8dedffb2fd4df0214.tar.gz
freebsd-ports-graphics-df940c62e46e0580091c82a8dedffb2fd4df0214.tar.zst
freebsd-ports-graphics-df940c62e46e0580091c82a8dedffb2fd4df0214.zip
Include bundled header files before others. For example, this fixes build
with conflicting header files from graphics/jpeg. Note OTHER_INCLUDES or OTHER_CPPFLAGS may be used instead. However, I think this is the least intrusive change. Also, note java/openjdk6 already has a similar fix and java/openjdk8 does not need it. Tested by: Jonathan Chen (jonc at chen dot org dot nz)
-rw-r--r--java/openjdk7/files/patch-jdk-make-sun-splashscreen-Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/java/openjdk7/files/patch-jdk-make-sun-splashscreen-Makefile b/java/openjdk7/files/patch-jdk-make-sun-splashscreen-Makefile
new file mode 100644
index 00000000000..5d8b1a4e63b
--- /dev/null
+++ b/java/openjdk7/files/patch-jdk-make-sun-splashscreen-Makefile
@@ -0,0 +1,28 @@
+--- jdk/make/sun/splashscreen/Makefile 2013-09-06 14:27:41.000000000 -0400
++++ jdk/make/sun/splashscreen/Makefile 2014-04-30 00:10:52.000000000 -0400
+@@ -61,6 +61,12 @@
+
+ CFLAGS += -DSPLASHSCREEN
+
++CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
++CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg
++ifneq ($(SYSTEM_ZLIB),true)
++ CPPFLAGS += -I$(SHARE_SRC)/native/java/util/zip/zlib-$(ZLIB_VERSION)
++endif
++
+ ifeq ($(PLATFORM), macosx)
+ CFLAGS += -DWITH_MACOSX
+
+@@ -121,11 +127,7 @@
+ CPPFLAGS += $(call NativeSrcDirList,-I,native/$(PKGDIR)/splashscreen)
+ CPPFLAGS += $(call NativeSrcDirList,-I,/native/sun/osxapp)
+ endif
+-CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
+-CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg
+-ifneq ($(SYSTEM_ZLIB),true)
+- CPPFLAGS += -I$(SHARE_SRC)/native/java/util/zip/zlib-$(ZLIB_VERSION)
+-else
++ifeq ($(SYSTEM_ZLIB),true)
+ OTHER_CFLAGS += $(ZLIB_CFLAGS)
+ OTHER_LDLIBS += $(ZLIB_LIBS)
+ endif