aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordryice <dryice@FreeBSD.org>2008-03-17 20:45:13 +0800
committerdryice <dryice@FreeBSD.org>2008-03-17 20:45:13 +0800
commitc95e9aaaa6ca91f6109f25c43123a772f68db123 (patch)
tree6d54ba2283c0ac7887548cf9e45696114b2b4e6b
parent793b69ca72ad9826b0d89b17ed4fbc37b27a7497 (diff)
downloadfreebsd-ports-graphics-c95e9aaaa6ca91f6109f25c43123a772f68db123.tar.gz
freebsd-ports-graphics-c95e9aaaa6ca91f6109f25c43123a772f68db123.tar.zst
freebsd-ports-graphics-c95e9aaaa6ca91f6109f25c43123a772f68db123.zip
use different versions of pysqlite according to different versions of
Python. Thanks "Christian Aastorp" <christian@widenoja-design.no> for pointing out.
-rw-r--r--www/roundup/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 3567827d2e5..9ca002e4fd0 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -26,7 +26,11 @@ OPTIONS+= MYSQL "Support mysql as backend" off
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SQLITE)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/sqlite/__init__.py:${PORTSDIR}/databases/py-PySQLite11
+.if ${PYTHON_REL} >= 250
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+.else
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
+.endif
.endif
.if defined(WITH_PGSQL)