aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-16 05:32:32 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-16 05:32:32 +0800
commit36935e0af92a33dd0ec40c905479db0ac63294f2 (patch)
treeeadfde3f0a21ca4fb9bcf246682d071c48a60a8a /Mk
parentc4e2c800e58984842da03bdec83213edacd9ff73 (diff)
downloadfreebsd-ports-graphics-36935e0af92a33dd0ec40c905479db0ac63294f2.tar.gz
freebsd-ports-graphics-36935e0af92a33dd0ec40c905479db0ac63294f2.tar.zst
freebsd-ports-graphics-36935e0af92a33dd0ec40c905479db0ac63294f2.zip
www/firefox: update to 58.0
Changes: https://www.mozilla.org/firefox/58.0/releasenotes/ PR: 223425 Tested by: Greg V, tobik Security: a891c5b4-3d7a-4de9-9c71-eef3fd698c77 MFH: 2018Q1 (piling up)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk6
2 files changed, 6 insertions, 4 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 432c60edd28..3afb4c50583 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=45:www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 52
-_GECKO_VERSIONS= 52 57
+_GECKO_VERSIONS= 52 58
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
52_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
-57_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
+58_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index a46a9c21b21..dd320f78067 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -109,14 +109,15 @@ USE_XORG+= xcb
MESA_LLVM_VER?= 50
BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>0:devel/llvm${MESA_LLVM_VER}
MOZ_EXPORT+= LLVM_CONFIG=llvm-config${MESA_LLVM_VER}
+.if ${MOZILLA_VER:R:R} < 58
MOZ_EXPORT+= BINDGEN_CFLAGS="${BINDGEN_CFLAGS}"
-# XXX bug 1341234
. if ! ${USE_MOZILLA:M-nspr}
BINDGEN_CFLAGS+=-isystem${LOCALBASE}/include/nspr
. endif
. if ! ${USE_MOZILLA:M-pixman}
BINDGEN_CFLAGS+=-isystem${LOCALBASE}/include/pixman-1
. endif
+.endif # MOZILLA_VER < 58
.endif
.if ${OPSYS} == FreeBSD && ${OSREL} == 11.1
@@ -144,6 +145,7 @@ PKGDEINSTALL_INC?= ${.CURDIR}/../../www/firefox/files/pkg-deinstall.in
MOZ_PKGCONFIG_FILES?= ${MOZILLA}-gtkmozembed ${MOZILLA}-js \
${MOZILLA}-xpcom ${MOZILLA}-plugin
+MAKE_ENV+= MACH=1 # XXX bug 1412398
ALL_TARGET?= build
MOZ_EXPORT+= ${CONFIGURE_ENV} \
@@ -395,7 +397,7 @@ post-patch-SNDIO-on:
.endif
.if ${PORT_OPTIONS:MRUST} || ${MOZILLA_VER:R:R} >= 54
-BUILD_DEPENDS+= ${RUST_PORT:T}>=1.19.0_2:${RUST_PORT}
+BUILD_DEPENDS+= ${RUST_PORT:T}>=1.21.0:${RUST_PORT}
RUST_PORT?= lang/rust
. if ${MOZILLA_VER:R:R} < 54
MOZ_OPTIONS+= --enable-rust