aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-22 23:51:07 +0800
committerbapt <bapt@FreeBSD.org>2013-04-22 23:51:07 +0800
commitc339c9e123c6f8755094acf41de4c05b575b736f (patch)
tree709f87b35e16256919a52ea3f6a7f09968aa9470 /Mk
parent0dcb0967159e8ad9d35ff87a6a40ff83f61b550a (diff)
downloadfreebsd-ports-graphics-c339c9e123c6f8755094acf41de4c05b575b736f.tar.gz
freebsd-ports-graphics-c339c9e123c6f8755094acf41de4c05b575b736f.tar.zst
freebsd-ports-graphics-c339c9e123c6f8755094acf41de4c05b575b736f.zip
LATEST_LINK makes no sense with pkgng
Remove any symlink and category in the packages directory when using WITH_PKGNG. Only keep links for pkg itself (to allow bootstrap)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.pkgng.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 97c2bbcc661..1cd9a8f15c0 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -259,8 +259,14 @@ do-package: ${TMPPLIST}
fi; \
fi;
@if ${PKG_CREATE} -o ${PKGREPOSITORY} ${PKGNAME}; then \
- if [ -d ${PACKAGES} ]; then \
- cd ${.CURDIR} && eval ${MAKE} package-links; \
+ if [ "${PKGORIGIN}" = "ports-mgmt/pkg" ]; then \
+ if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
+ if ! ${MKDIR} ${PKGLATESTREPOSITORY}; then \
+ ${ECHO_MSG} "=> Can't create directory ${PKGLATESTREPOSITORY}."; \
+ exit 1; \
+ fi; \
+ fi ; \
+ ${LN} -s ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
fi; \
else \
cd ${.CURDIR} && eval ${MAKE} delete-package; \