aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/rpm4/Makefile
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2010-08-24 01:46:45 +0800
committerjohans <johans@FreeBSD.org>2010-08-24 01:46:45 +0800
commit90142b77cd3f4952af9f7a5fedcc2f2668e2a2ea (patch)
tree3fa5c65485e13b1626073644ae1077d971b24549 /archivers/rpm4/Makefile
parent08b050d387d8453bf8d423b838f5913bb0fe1a77 (diff)
downloadfreebsd-ports-graphics-90142b77cd3f4952af9f7a5fedcc2f2668e2a2ea.tar.gz
freebsd-ports-graphics-90142b77cd3f4952af9f7a5fedcc2f2668e2a2ea.tar.zst
freebsd-ports-graphics-90142b77cd3f4952af9f7a5fedcc2f2668e2a2ea.zip
Fix compilation of the python module for rpm; and fix plist [1]
Add an OPTION to install this module PR: ports/149886 [1] Submitted by: Anders.F.Björklund
Diffstat (limited to 'archivers/rpm4/Makefile')
-rw-r--r--archivers/rpm4/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 51cbb03cfad..e50d3602702 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= rpm
PORTVERSION= 4.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R}.x/ \
ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/rpm-${PORTVERSION:E}.x/
@@ -19,6 +19,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
lzma:${PORTSDIR}/archivers/xz
BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
+OPTIONS= PYTHON "Build Python rpm module" Off
+
USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GMAKE= yes
@@ -34,14 +36,16 @@ CPPFLAGS+= -I${LOCALBASE}/include/nspr -I${LOCALBASE}/include/nss/nss \
LDFLAGS+= -L${LOCALBASE}/lib/nss -L${BDB_LIB_DIR} -L${LUA_LIBDIR}
CONFIGURE_ARGS+=--with-external-db
+.include <bsd.port.options.mk>
+
.ifdef WITH_PYTHON
-CONFIGURE_ARGS+=--with-python=auto
-USE_PYTHON= yes
+CONFIGURE_ARGS+=--enable-python
+USE_PYTHON= 2.6+
PLIST_SUB+= PYTHON=""
CPPFLAGS+= -I${PYTHON_INCLUDEDIR}
LDFLAGS+= -L${PYTHON_LIBDIR}
.else
-CONFIGURE_ARGS+=--without-python
+CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif