aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjwb <jwb@FreeBSD.org>2018-04-24 00:23:53 +0800
committerjwb <jwb@FreeBSD.org>2018-04-24 00:23:53 +0800
commit20bd7f8617b613e49fd431673d39b38e930337ae (patch)
tree95bed73c3703b696c500b087cb5058b947aecabd /biology
parent29ee5e53fa2ced71aef3102b04ef8c5055b3badf (diff)
downloadfreebsd-ports-graphics-20bd7f8617b613e49fd431673d39b38e930337ae.tar.gz
freebsd-ports-graphics-20bd7f8617b613e49fd431673d39b38e930337ae.tar.zst
freebsd-ports-graphics-20bd7f8617b613e49fd431673d39b38e930337ae.zip
biology/pbcopper: Core C++ library for Pacific Biosciences tools
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D15171
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/pbcopper/Makefile28
-rw-r--r--biology/pbcopper/distinfo3
-rw-r--r--biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake21
-rw-r--r--biology/pbcopper/pkg-descr5
-rw-r--r--biology/pbcopper/pkg-plist75
6 files changed, 133 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index b063fb6b034..996d7f82218 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -82,6 +82,7 @@
SUBDIR += p5-transdecoder
SUBDIR += paml
SUBDIR += pbbam
+ SUBDIR += pbcopper
SUBDIR += pbseqan
SUBDIR += pear-merger
SUBDIR += phrap
diff --git a/biology/pbcopper/Makefile b/biology/pbcopper/Makefile
new file mode 100644
index 00000000000..6a97311c285
--- /dev/null
+++ b/biology/pbcopper/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= pbcopper
+DISTVERSION= g20180413
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Core C++ library for Pacific Biosciences tools
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libboost_regex.so:devel/boost-libs
+
+USES= cmake
+# Although there are a couple releases, git describe --tags does not work
+# so we cannot use the usual USE_GITHUB tools here.
+USE_GITHUB= yes
+GH_ACCOUNT= PacificBiosciences
+GH_TAGNAME= 17ef457a0dbe1894a8d17af7ddba01a6261bf117
+
+do-install:
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/lib/*.a ${STAGEDIR}${PREFIX}/lib
+ cd ${WRKSRC}/include && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include
+ ${MV} ${STAGEDIR}${PREFIX}/include/meson.build \
+ ${STAGEDIR}${PREFIX}/include/pbcopper
+
+.include <bsd.port.mk>
diff --git a/biology/pbcopper/distinfo b/biology/pbcopper/distinfo
new file mode 100644
index 00000000000..4ee86047d81
--- /dev/null
+++ b/biology/pbcopper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524500014
+SHA256 (PacificBiosciences-pbcopper-g20180413-17ef457a0dbe1894a8d17af7ddba01a6261bf117_GH0.tar.gz) = 13f006d53334a0538657e0ba5c6e02f811f1901cd25fce220fc9011726ffe23f
+SIZE (PacificBiosciences-pbcopper-g20180413-17ef457a0dbe1894a8d17af7ddba01a6261bf117_GH0.tar.gz) = 3033636
diff --git a/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake b/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake
new file mode 100644
index 00000000000..56eb84971d3
--- /dev/null
+++ b/biology/pbcopper/files/patch-cmake_pbcopper-gitsha1.cmake
@@ -0,0 +1,21 @@
+--- cmake/pbcopper-gitsha1.cmake.orig 2018-03-16 16:16:38 UTC
++++ cmake/pbcopper-gitsha1.cmake
+@@ -5,16 +5,15 @@ endif()
+ set(__find_git_sha1 YES)
+
+ function(find_git_sha1 _GIT_SHA1)
+- find_package(Git QUIET REQUIRED)
+ execute_process(COMMAND
+- "${GIT_EXECUTABLE}" "describe" "--always" "--dirty=*"
++ echo ce9a4b6
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+ RESULT_VARIABLE res
+ OUTPUT_VARIABLE out
+ ERROR_QUIET
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+ if (NOT res EQUAL 0)
+- message(FATAL_ERROR "Could not determine git sha1 via `git describe --always --dirty=*`")
++ message(FATAL_ERROR "Could not determine git sha1")
+ endif()
+ set(${_GIT_SHA1} "${out}" PARENT_SCOPE)
+ endfunction()
diff --git a/biology/pbcopper/pkg-descr b/biology/pbcopper/pkg-descr
new file mode 100644
index 00000000000..5f3b33b7cff
--- /dev/null
+++ b/biology/pbcopper/pkg-descr
@@ -0,0 +1,5 @@
+The pbcopper library provides a suite of data structures, algorithms, and
+utilities for C++ applications. It is a core component of Pacific Biosciences
+genomics analysis tools.
+
+WWW: https://github.com/PacificBiosciences/pbcopper
diff --git a/biology/pbcopper/pkg-plist b/biology/pbcopper/pkg-plist
new file mode 100644
index 00000000000..0c9352560b7
--- /dev/null
+++ b/biology/pbcopper/pkg-plist
@@ -0,0 +1,75 @@
+include/pbcopper/PbcopperConfig.h
+include/pbcopper/align/Seed.h
+include/pbcopper/align/Seeds.h
+include/pbcopper/align/internal/Seed-inl.h
+include/pbcopper/align/internal/Seeds-inl.h
+include/pbcopper/cli/CLI.h
+include/pbcopper/cli/HelpPrinter.h
+include/pbcopper/cli/Interface.h
+include/pbcopper/cli/Option.h
+include/pbcopper/cli/OptionFlags.h
+include/pbcopper/cli/Parser.h
+include/pbcopper/cli/PositionalArg.h
+include/pbcopper/cli/Results.h
+include/pbcopper/cli/SingleDashMode.h
+include/pbcopper/cli/VersionPrinter.h
+include/pbcopper/cli/internal/Option-inl.h
+include/pbcopper/cli/toolcontract/Config.h
+include/pbcopper/cli/toolcontract/Driver.h
+include/pbcopper/cli/toolcontract/InputFileType.h
+include/pbcopper/cli/toolcontract/JsonPrinter.h
+include/pbcopper/cli/toolcontract/OutputFileType.h
+include/pbcopper/cli/toolcontract/ResolvedToolContract.h
+include/pbcopper/cli/toolcontract/ResourceType.h
+include/pbcopper/cli/toolcontract/Task.h
+include/pbcopper/cli/toolcontract/TaskType.h
+include/pbcopper/cli/toolcontract/internal/Config-inl.h
+include/pbcopper/cli/toolcontract/internal/Driver-inl.h
+include/pbcopper/cli/toolcontract/internal/InputFileType-inl.h
+include/pbcopper/cli/toolcontract/internal/OutputFileType-inl.h
+include/pbcopper/cli/toolcontract/internal/Task-inl.h
+include/pbcopper/data/CCSTag.h
+include/pbcopper/data/Cigar.h
+include/pbcopper/data/CigarOperation.h
+include/pbcopper/data/Interval.h
+include/pbcopper/data/MovieName.h
+include/pbcopper/data/Position.h
+include/pbcopper/data/RSMovieName.h
+include/pbcopper/data/RSReadName.h
+include/pbcopper/data/ReadName.h
+include/pbcopper/data/Zmw.h
+include/pbcopper/data/internal/CigarOperation-inl.h
+include/pbcopper/data/internal/Interval-inl.h
+include/pbcopper/data/internal/MovieName-inl.h
+include/pbcopper/data/internal/RSMovieName-inl.h
+include/pbcopper/data/internal/ReadNameBase-inl.h
+include/pbcopper/data/internal/ReadNameBase.h
+include/pbcopper/json/JSON.h
+include/pbcopper/json/internal/json.hpp
+include/pbcopper/logging/Logging.h
+include/pbcopper/logging/internal/Logging-inl.h
+include/pbcopper/meson.build
+include/pbcopper/parallel/FireAndForget.h
+include/pbcopper/parallel/WorkQueue.h
+include/pbcopper/qgram/Index.h
+include/pbcopper/qgram/IndexHit.h
+include/pbcopper/qgram/IndexHits.h
+include/pbcopper/qgram/internal/Hashing-inl.h
+include/pbcopper/qgram/internal/Index-inl.h
+include/pbcopper/stream/Stream.h
+include/pbcopper/utility/CallbackTimer.h
+include/pbcopper/utility/EnumClassHash.h
+include/pbcopper/utility/FileUtils.h
+include/pbcopper/utility/MoveAppend.h
+include/pbcopper/utility/PbcopperVersion.h
+include/pbcopper/utility/SafeSubtract.h
+include/pbcopper/utility/Stopwatch.h
+include/pbcopper/utility/StringUtils.h
+include/pbcopper/utility/SystemInfo.h
+include/pbcopper/utility/Unused.h
+include/pbcopper/utility/internal/CallbackTimer-inl.h
+include/pbcopper/utility/internal/FileUtils-inl.h
+include/pbcopper/utility/internal/Stopwatch-inl.h
+include/pbcopper/utility/internal/StringUtils-inl.h
+include/pbcopper/utility/internal/SystemInfo-inl.h
+lib/libpbcopper.a