aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-23 19:00:44 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-23 19:00:44 +0800
commitd67a1bbcbe2fe3a768d271da738634103e412c15 (patch)
treec6bd120ecd4a1fe62a2cabfd37f409be143743cb /biology
parente84ee761a0a2bb7677760dc7474e8dba8becef49 (diff)
downloadfreebsd-ports-graphics-d67a1bbcbe2fe3a768d271da738634103e412c15.tar.gz
freebsd-ports-graphics-d67a1bbcbe2fe3a768d271da738634103e412c15.tar.zst
freebsd-ports-graphics-d67a1bbcbe2fe3a768d271da738634103e412c15.zip
New port: biology/slclust.
Slclust is a utility that performs single-linkage clustering with the option of applying a Jaccard similarity coefficient to break weakly bound clusters into distinct clusters. WWW: http://sourceforge.net/projects/slclust/ PR: 207997 Submitted by: Jason Bacon <bacon4000@gmail.com>
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/slclust/Makefile23
-rw-r--r--biology/slclust/distinfo2
-rw-r--r--biology/slclust/files/patch-include_cmd__line__opts.h9
-rw-r--r--biology/slclust/files/patch-src_Makefile45
-rw-r--r--biology/slclust/pkg-descr5
6 files changed, 85 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index b998d56847c..bf13346a0bf 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -89,6 +89,7 @@
SUBDIR += seqio
SUBDIR += seqtools
SUBDIR += sim4
+ SUBDIR += slclust
SUBDIR += ssaha
SUBDIR += tRNAscan-SE
SUBDIR += t_coffee
diff --git a/biology/slclust/Makefile b/biology/slclust/Makefile
new file mode 100644
index 00000000000..628a08d0102
--- /dev/null
+++ b/biology/slclust/Makefile
@@ -0,0 +1,23 @@
+# Created by: Jason Bacon <bacon4000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= slclust
+PORTVERSION= 2010.02.02
+CATEGORIES= biology
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= slclust/slclust
+DISTNAME= ${PORTNAME}_02022010
+
+MAINTAINER= bacon4000@gmail.com
+COMMENT= Single-linkage clustering with Jaccard similarity
+
+LICENSE= ART10
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/slclust
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/slclust ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/slclust/distinfo b/biology/slclust/distinfo
new file mode 100644
index 00000000000..697a2f41840
--- /dev/null
+++ b/biology/slclust/distinfo
@@ -0,0 +1,2 @@
+SHA256 (slclust_02022010.tar.gz) = 9e21b65288e7fc35647721380cfedffd68608e164b4240c692c511c18c1620f8
+SIZE (slclust_02022010.tar.gz) = 23097
diff --git a/biology/slclust/files/patch-include_cmd__line__opts.h b/biology/slclust/files/patch-include_cmd__line__opts.h
new file mode 100644
index 00000000000..7b07b07ce28
--- /dev/null
+++ b/biology/slclust/files/patch-include_cmd__line__opts.h
@@ -0,0 +1,9 @@
+--- include/cmd_line_opts.h.orig 2010-02-02 14:00:41 UTC
++++ include/cmd_line_opts.h
+@@ -1,5 +1,5 @@
+ #ifndef __CMD_LINE_OPTS_H__
+-#define __CMD_LiNE_OPTS_H__
++#define __CMD_LINE_OPTS_H__
+
+ bool co_get_int(int argc, char** argv, const char* text, int* );
+ bool co_get_bool(int argc, char** argv, const char* text);
diff --git a/biology/slclust/files/patch-src_Makefile b/biology/slclust/files/patch-src_Makefile
new file mode 100644
index 00000000000..cee6db5e3a0
--- /dev/null
+++ b/biology/slclust/files/patch-src_Makefile
@@ -0,0 +1,45 @@
+--- src/Makefile.orig 2010-02-02 14:00:41 UTC
++++ src/Makefile
+@@ -20,8 +20,8 @@ LIBS =
+ # How they are invoked on the compile line (eg: -lspecial)
+ LLIBS =
+
+-# Local additions for the CFLAG options
+-LOCAL_CFLAGS = -Wall
++# Local additions for the CXXFLAGS options
++#LOCAL_CXXFLAGS = -Wall
+ #-static
+
+
+@@ -34,8 +34,8 @@ BIN = ${PROJECT_ROOT}/bin
+ INCLUDE = ${PROJECT_ROOT}/include
+
+ DEBUG = DEBUG
+-CFLAGS = -I${INCLUDE} ${LOCAL_CFLAGS}
+-CC = g++ ${CFLAGS}
++CXXFLAGS += -I${INCLUDE} ${LOCAL_CXXFLAGS}
++CXX ?= g++
+
+ MAKEFILE = Makefile
+
+@@ -43,10 +43,10 @@ MAKEFILE = Makefile
+ # Suffix rules
+
+ .cc.o:
+- ${CC} -c $<
++ ${CXX} -c ${CXXFLAGS} $<
+
+ .cpp.o:
+- ${CC} -c $<
++ ${CXX} -c ${CXXFLAGS} $<
+
+ # Target dependencies
+
+@@ -65,6 +65,6 @@ clean :
+ ${OBJ} : ${MAKEFILE}
+
+ ${EXECUTABLE} : ${OBJS}
+- ${CC} ${OBJS} ${LIBS} -o ${EXECUTABLE}
++ ${CXX} ${OBJS} ${LIBS} -o ${EXECUTABLE}
+ chmod 755 ${EXECUTABLE}
+
diff --git a/biology/slclust/pkg-descr b/biology/slclust/pkg-descr
new file mode 100644
index 00000000000..74d667f5afa
--- /dev/null
+++ b/biology/slclust/pkg-descr
@@ -0,0 +1,5 @@
+Slclust is a utility that performs single-linkage clustering with the option of
+applying a Jaccard similarity coefficient to break weakly bound clusters into
+distinct clusters.
+
+WWW: http://sourceforge.net/projects/slclust/