aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
commitf3daf2261fb178366adda1ccfd67d90513f16f2a (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /biology
parentcc1bd708b05005e884e1cb06113168318d3dbe5a (diff)
downloadfreebsd-ports-graphics-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.gz
freebsd-ports-graphics-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.zst
freebsd-ports-graphics-f3daf2261fb178366adda1ccfd67d90513f16f2a.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'biology')
-rw-r--r--biology/seqan-apps/Makefile10
-rw-r--r--biology/ugene/Makefile8
2 files changed, 3 insertions, 15 deletions
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index 7ef0d3d826f..a8bd2161b73 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -28,16 +28,6 @@ USE_GCC= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000
-post-patch:
- # missing C99 functions in FreeBSD's math.h, use C++ instead
- @${REINPLACE_CMD} -e 's|expl(|std::exp(|g' ${WRKSRC}/apps/snp_store/snp_store.h
- @${REINPLACE_CMD} -e 's|logl(|std::log(|g' ${WRKSRC}/apps/snp_store/snp_store.h
- # the other way around (use math.h instead of cmath)
- @${REINPLACE_CMD} -e 's|std::round|round|g' ${WRKSRC}/apps/yara/mapper_writer.h
- @${REINPLACE_CMD} -e 's|std::erfc|erfc|g' ${WRKSRC}/apps/yara/bits_matches.h
-.endif
-
.if ${ARCH} == "i386"
PLIST_SUB+= RM_I386="@comment "
.else
diff --git a/biology/ugene/Makefile b/biology/ugene/Makefile
index 337315a28f4..15b540e19e6 100644
--- a/biology/ugene/Makefile
+++ b/biology/ugene/Makefile
@@ -31,6 +31,9 @@ QMAKE_ARGS= INSTALL_PREFIX="${PREFIX}" UGENE_INSTALL_DATA="${DATADIR}" \
LUPDATE="${LUPDATE}"
ALL_TARGET= release
+# Required for Google Test code
+CXXFLAGS+= -std=c++11
+
DOCSDIR= ${DATADIR}/manuals
OPTIONS_DEFINE= DOCS
@@ -38,11 +41,6 @@ DOCS_DESC= Install official UGENE documentation (PDF)
.include <bsd.port.pre.mk>
-# Required for Google Test code
-.if ${OSVERSION} > 1000054
-CXXFLAGS+= -std=c++11
-.endif
-
.if ${ARCH} == amd64
# XXX: need to manually tell the build we are on x64
QMAKE_ARGS+= CONFIG+=x64