aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-18 20:21:43 +0800
committerrakuco <rakuco@FreeBSD.org>2017-08-18 20:21:43 +0800
commit21099c63004210f0686652ad0bf54a62682729a3 (patch)
treeea629ad4a6d9bf1cfeba04f950fdf8bb7e626efb /cad
parent7f51bffd77b54acb777c6d45995db7cb29e6fcbf (diff)
downloadfreebsd-ports-graphics-21099c63004210f0686652ad0bf54a62682729a3.tar.gz
freebsd-ports-graphics-21099c63004210f0686652ad0bf54a62682729a3.tar.zst
freebsd-ports-graphics-21099c63004210f0686652ad0bf54a62682729a3.zip
Explicitly pass -std=gnu++03 to the compiler.
This fixes the build with GCC 6, which defaults to -std=gnu++14. The port's code does not work with C++11 or later. PR: 219275
Diffstat (limited to 'cad')
-rw-r--r--cad/alliance/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index 28e04d902d3..bdfad7f5ea5 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -33,6 +33,9 @@ CONFIGURE_ENV+= ALLIANCE_TOP=${ALLIANCE_TOP}
CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
--prefix=${ALLIANCE_TOP}
+# The port does not build with C++11 or later (bug 219275).
+USE_CXXSTD= gnu++03
+
MAKE_JOBS_UNSAFE= yes
post-patch: