aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2016-07-22 02:47:55 +0800
committerkmoore <kmoore@FreeBSD.org>2016-07-22 02:47:55 +0800
commitb0b46be7fb806f55de887c40e62692c5e2503232 (patch)
treef5928a90a25c5e16a2ee2033ec76a4388d9c4df9 /deskutils
parent11b6e4d3b1e55399cf3c5509fc8bf14de60162e0 (diff)
downloadfreebsd-ports-graphics-b0b46be7fb806f55de887c40e62692c5e2503232.tar.gz
freebsd-ports-graphics-b0b46be7fb806f55de887c40e62692c5e2503232.tar.zst
freebsd-ports-graphics-b0b46be7fb806f55de887c40e62692c5e2503232.zip
CopyQ is advanced clipboard manager with editing and scripting features.
WWW: https://github.com/hluk/CopyQ
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/copyq/Makefile29
-rw-r--r--deskutils/copyq/distinfo3
-rw-r--r--deskutils/copyq/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c052b41e634..c59d36837cd 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -28,6 +28,7 @@
SUBDIR += conduit
SUBDIR += conkyemail
SUBDIR += conkyforecast
+ SUBDIR += copyq
SUBDIR += countdown
SUBDIR += cycle
SUBDIR += dailystrips
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
new file mode 100644
index 00000000000..f27e3e5af05
--- /dev/null
+++ b/deskutils/copyq/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= copyq
+PORTVERSION= 2.7.1
+DISTVERSIONPREFIX= v
+CATEGORIES= deskutils
+
+MAINTAINER= kris@ixsystems.com
+COMMENT= Qt5 based clipboard manager
+
+LICENSE= GPLv3
+
+USE_XORG+= x11 xfixes xtst
+USE_QT5= core gui network svg multimedia imageformats \
+ buildtools_build x11extras concurrent widgets xml \
+ script
+USE_GL+= gl
+USES= qmake
+
+PLIST_FILES= bin/copyq
+
+USE_GITHUB= yes
+GH_ACCOUNT= hluk
+GH_PROJECT= CopyQ
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/copyq ${STAGEDIR}${PREFIX}/bin/copyq
+
+.include <bsd.port.mk>
diff --git a/deskutils/copyq/distinfo b/deskutils/copyq/distinfo
new file mode 100644
index 00000000000..23d321d83cf
--- /dev/null
+++ b/deskutils/copyq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469125509
+SHA256 (hluk-CopyQ-v2.7.1_GH0.tar.gz) = 4b8efd6e4041a0aa5f3361eb3aef93f51b5919c14502138e9f4a0b756b290d91
+SIZE (hluk-CopyQ-v2.7.1_GH0.tar.gz) = 1490106
diff --git a/deskutils/copyq/pkg-descr b/deskutils/copyq/pkg-descr
new file mode 100644
index 00000000000..325552469ba
--- /dev/null
+++ b/deskutils/copyq/pkg-descr
@@ -0,0 +1,3 @@
+CopyQ is advanced clipboard manager with editing and scripting features.
+
+WWW: https://github.com/hluk/CopyQ