aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-perlqt/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /devel/p5-perlqt/Makefile
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-graphics-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-graphics-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-graphics-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'devel/p5-perlqt/Makefile')
-rw-r--r--devel/p5-perlqt/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/devel/p5-perlqt/Makefile b/devel/p5-perlqt/Makefile
index 5c77b0bb8e9..2e05e904291 100644
--- a/devel/p5-perlqt/Makefile
+++ b/devel/p5-perlqt/Makefile
@@ -18,10 +18,9 @@ USE_XZ= yes
USE_PERL5= yes
USE_KDE4= kdehier kdeprefix smokeqt qimageblitz
USE_QT4= qmake_build moc_build uic_build rcc_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
-USE_LDCONFIG= yes
# Respect PREFIX
CMAKE_ARGS+= -DCUSTOM_PERL_SITE_ARCH_DIR=${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}