aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2011-09-01 23:08:59 +0800
committerglarkin <glarkin@FreeBSD.org>2011-09-01 23:08:59 +0800
commit4eff855e9c6278ff1302664731fcda2004fffdf5 (patch)
treec5fd20f20ae9390913cc4e534d00c758d9b677d2 /devel
parent981d40e832a84342b4a43327c7b2a01114b95c68 (diff)
downloadfreebsd-ports-graphics-4eff855e9c6278ff1302664731fcda2004fffdf5.tar.gz
freebsd-ports-graphics-4eff855e9c6278ff1302664731fcda2004fffdf5.tar.zst
freebsd-ports-graphics-4eff855e9c6278ff1302664731fcda2004fffdf5.zip
- Set minimum Python version to 2.5
- Since it now requires 2.5+, use databases/py-sqlite3 instead of databases/py-pysqlite2x - Bump PORTREVISION PR: ports/160069 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> Approved by: c-s@c-s.li (maintainer, via email)
Diffstat (limited to 'devel')
-rw-r--r--devel/bzr-git/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/bzr-git/Makefile b/devel/bzr-git/Makefile
index 99247ceebc4..9a6c0d5d02d 100644
--- a/devel/bzr-git/Makefile
+++ b/devel/bzr-git/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bzr-git
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://launchpadlibrarian.net/76814124/ \
http://www.c-s.li/ports/
@@ -14,15 +15,15 @@ MASTER_SITES= https://launchpadlibrarian.net/76814124/ \
MAINTAINER= c-s@c-s.li
COMMENT= Plugin for bzr to work with git trees
+LICENSE= GPLv2
+
BUILD_DEPENDS= bzr:${PORTSDIR}/devel/bazaar-ng
RUN_DEPENDS= bzr:${PORTSDIR}/devel/bazaar-ng \
py*-dulwich>=0.8.0:${PORTSDIR}/devel/dulwich \
- py*-pysqlite>=2.3:${PORTSDIR}/databases/py-pysqlite23
-
-LICENSE= GPLv2
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_PYTHON= yes
+USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= bzr_git