aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-09-04 14:17:22 +0800
committertota <tota@FreeBSD.org>2011-09-04 14:17:22 +0800
commit65fd829b7f2880a746170bb84ca1f70743c19211 (patch)
treeedab8cb5561bf7a9754125d213152823985a92e8 /devel
parentf68ffd92854f0ca5f4c06e8850a365f0824d9ab2 (diff)
downloadfreebsd-ports-graphics-65fd829b7f2880a746170bb84ca1f70743c19211.tar.gz
freebsd-ports-graphics-65fd829b7f2880a746170bb84ca1f70743c19211.tar.zst
freebsd-ports-graphics-65fd829b7f2880a746170bb84ca1f70743c19211.zip
- Add a new port: devel/R-cran-foreach
Support for the foreach looping construct. Foreach is an idiom that allows for iterating over elements in a collection, without the use of an explicit loop counter. This package in particular is intended to be used for its return value, rather than for its side effects. In that sense, it is similar to the standard lapply function, but doesn't require the evaluation of a function. Using foreach without side effects also facilitates executing the loop in parallel. WWW: http://cran.r-project.org/web/packages/foreach/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-foreach/Makefile24
-rw-r--r--devel/R-cran-foreach/distinfo2
-rw-r--r--devel/R-cran-foreach/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4272c1bac9e..e10d7c65b03 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -10,6 +10,7 @@
SUBDIR += ORBit2-reference
SUBDIR += R-cran-bitops
SUBDIR += R-cran-caret
+ SUBDIR += R-cran-foreach
SUBDIR += R-cran-iterators
SUBDIR += R-cran-itertools
SUBDIR += R-cran-plyr
diff --git a/devel/R-cran-foreach/Makefile b/devel/R-cran-foreach/Makefile
new file mode 100644
index 00000000000..1c360329cad
--- /dev/null
+++ b/devel/R-cran-foreach/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: R-cran-foreach
+# Date created: 2011-09-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= foreach
+PORTVERSION= 1.3.2
+CATEGORIES= devel
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Foreach looping construct for R
+
+LICENSE= ASL
+
+RUN_DEPENDS= R-cran-iterators>=1.0.0:${PORTSDIR}/devel/R-cran-iterators
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-foreach/distinfo b/devel/R-cran-foreach/distinfo
new file mode 100644
index 00000000000..d7a108bb5b8
--- /dev/null
+++ b/devel/R-cran-foreach/distinfo
@@ -0,0 +1,2 @@
+SHA256 (foreach_1.3.2.tar.gz) = 337e497b1550df1ef2595c9284f86fc03a6a8c992947fe53be917456f32439b1
+SIZE (foreach_1.3.2.tar.gz) = 340437
diff --git a/devel/R-cran-foreach/pkg-descr b/devel/R-cran-foreach/pkg-descr
new file mode 100644
index 00000000000..82a9c664418
--- /dev/null
+++ b/devel/R-cran-foreach/pkg-descr
@@ -0,0 +1,9 @@
+Support for the foreach looping construct. Foreach is an idiom that
+allows for iterating over elements in a collection, without the use
+of an explicit loop counter. This package in particular is intended
+to be used for its return value, rather than for its side effects.
+In that sense, it is similar to the standard lapply function, but
+doesn't require the evaluation of a function. Using foreach without
+side effects also facilitates executing the loop in parallel.
+
+WWW: http://cran.r-project.org/web/packages/foreach/