aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2011-08-30 07:00:51 +0800
committerrakuco <rakuco@FreeBSD.org>2011-08-30 07:00:51 +0800
commite88878888a7d697db7eb7ab730bb98d134b5ad2a (patch)
tree9df192a85a13dd47c67110ee760e4a91fa4c622e /devel
parented2bbd68c882319ea30083975b53a1cb9402e510 (diff)
downloadfreebsd-ports-graphics-e88878888a7d697db7eb7ab730bb98d134b5ad2a.tar.gz
freebsd-ports-graphics-e88878888a7d697db7eb7ab730bb98d134b5ad2a.tar.zst
freebsd-ports-graphics-e88878888a7d697db7eb7ab730bb98d134b5ad2a.zip
Set datadir and docdir correctly, just like devel/cmake does.
If we do not specify any value, CMake uses default paths which do not exist in the system and fails when configuring a project. This should fix [1] and likely [2] as well. PORTREVISION bumped as this fixes an error and a crash. [1] http://mail.kde.org/pipermail/kde-freebsd/2011-February/010278.html [2] http://mail.kde.org/pipermail/kde-freebsd/2011-May/010881.html Approved by: avilla (mentor) Reported by: arrowdodger <6yearold@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake-gui/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 6d0de6fe331..142457bc388 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cmake
PORTVERSION= 2.8.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/
PKGNAMESUFFIX= -gui
@@ -19,7 +20,9 @@ RUN_DEPENDS= ${CMAKE_BIN}:${CMAKE_PORT}
USE_QT_VER= 4
QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build
USE_CMAKE= yes
-CMAKE_ARGS= -DBUILD_QtDialog:bool=on
+CMAKE_ARGS= -DBUILD_QtDialog:bool=on \
+ -DCMAKE_DATA_DIR:STRING="/${DATADIR_REL}" \
+ -DCMAKE_DOC_DIR:STRING="/${DOCSDIR_REL}"
MAN1= cmake-gui.1
BUILD_WRKSRC= ${WRKSRC}/Source/QtDialog