aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
committermat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
commit359f486d9eb2765e2538b660686a47ca7f489039 (patch)
tree33a19b5745c1e5e7cbfa4a5ab2c30f6971177e74 /editors
parent16d9767b56dfb66fc3cda0c10604d546bd95003f (diff)
downloadfreebsd-ports-graphics-359f486d9eb2765e2538b660686a47ca7f489039.tar.gz
freebsd-ports-graphics-359f486d9eb2765e2538b660686a47ca7f489039.tar.zst
freebsd-ports-graphics-359f486d9eb2765e2538b660686a47ca7f489039.zip
Don't quote {} in find -exec calls.
Braces are not shell metacharacters, and they do not need to be quoted. By the time find parses its arguments and dicovers them, the quoting will have been removed by the shell anyway. Sponsored by: Absolight
Diffstat (limited to 'editors')
-rw-r--r--editors/lazarus/Makefile6
-rw-r--r--editors/lazarus/Makefile.common12
2 files changed, 9 insertions, 9 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 0b002153a07..775161d6aaf 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -151,7 +151,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/${DIRE}
@cd ${WRKSRC}/${DIRE} && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DATADIR}/${DIRE}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/${DIRE}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/${DIRE}/{}" \;
.endfor
@${CHMOD} +x ${STAGEDIR}${DATADIR}/tools/svn2revisioninc ${STAGEDIR}${DATADIR}/tools/lazres ${STAGEDIR}${DATADIR}/tools/lrstolfm \
${STAGEDIR}${DATADIR}/tools/updatepofiles
@@ -162,12 +162,12 @@ do-install:
@cd ${WRKDIR}/docs && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DOCSDIR}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DOCSDIR}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DOCSDIR}/{}" \;
@${LN} -s ${DOCSDIR} ${STAGEDIR}${DATADIR}/docs
@cd ${WRKDIR}/examples && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${EXAMPLESDIR}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${EXAMPLESDIR}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${EXAMPLESDIR}/{}" \;
@${LN} -s ${EXAMPLESDIR} ${STAGEDIR}${DATADIR}/examples
${INSTALL_SCRIPT} ${WRKSRC}/localize.sh ${STAGEDIR}${DATADIR}
diff --git a/editors/lazarus/Makefile.common b/editors/lazarus/Makefile.common
index df135661f81..8888044feeb 100644
--- a/editors/lazarus/Makefile.common
+++ b/editors/lazarus/Makefile.common
@@ -89,16 +89,16 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/components/lazcontrols/lib/${BUILDNAME}/${LCL_INTERFACE}
@cd ${WRKSRC}/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/lcl/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/lcl/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
.if ${PKGNAMESUFFIX} == "-lcl-nogui"
@cd ${WRKDIR}/${PORTNAME}/components/debuggerintf/lib/${BUILDNAME} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/components/debuggerintf/lib/${BUILDNAME}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/components/debuggerintf/lib/${BUILDNAME}/{}" \;
@cd ${WRKDIR}/${PORTNAME}/components/lazdebuggergdbmi/lib/${BUILDNAME} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/components/lazdebuggergdbmi/lib/${BUILDNAME}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/components/lazdebuggergdbmi/lib/${BUILDNAME}/{}" \;
.endif
@cd ${WRKDIR}/${PORTNAME}/components/ideintf/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/components/ideintf/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/components/ideintf/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
@cd ${WRKDIR}/${PORTNAME}/components/synedit/units/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/components/synedit/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/components/synedit/units/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
@cd ${WRKDIR}/${PORTNAME}/components/lazcontrols/lib/${BUILDNAME}/${LCL_INTERFACE} && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/components/lazcontrols/lib/${BUILDNAME}/${LCL_INTERFACE}/{}" \;
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/components/lazcontrols/lib/${BUILDNAME}/${LCL_INTERFACE}/{}" \;